Support » Plugin: Translate Multilingual sites - TranslatePress » (Woocommerce) Only first order’s mail being translated

  • Resolved szymonwordpress

    (@szymonwordpress)


    Hello,
    i’ve problem with translation of Woocommerce’s mails:

    Issue: Translatepress plugin does not translate emails in customers’ preferred language except the very first email they receive when they land on thankyou page.

    Steps to Reproduce:
    1. A customer purchase an item on WooCommerce store and land on /order-received/ page
    2. WooCommerce order notification email (Processing Email) will be sent to the customer in chosen language
    3. An admin changes the status of the order to ‘Completed’ after shipping the product
    4. WooCommerce order delivery conformation email (Completed Email) will be sent to the customer in store’s default language

    How can i repair it?

    Regards,
    Szymon

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Szymon,

    It’s sent in the default language because Translatepress doesn’t store personal information about the user so this feature ​unfortunately is something that we dont have yet.

    ​We prioritize new features, based on the number of requirements from our users. This is a tracked feature and will be available in the future versions of TranslatePress – but, as there are other features more requested that require prioritization​​, I can’t give you a timeframe for when will this be implemented.

    Thank you for understanding.

    Best regards,
    Cristian

    I can’t understand how come this feature is not top priority? You develop a translate plugin that is being used for multilingual websites, and there’s not enough requests to send the emails in correct language? That sounds insane.

    A customer who choses to shop in one language means she/he wants to get all the communication through that language.

    I have been looking for a solution for this isuue for months, and seen many people asking for it in the forums. It’s exhausting to send all the follow up emails manually.

    Please consider moving this feature up, as all the other translate plugins have it in their premium version.

    I am also looking for a long time solution to this problem! this is a very important function that should work! many people on the forum ask you about it !!

    Other translate plugins all have some solutions for that. Weglot offers a php code or snippet to solve this problem: https://developers.weglot.com/wordpress/use-cases/translation-of-woocommerce-emails-sent-to-customers

    You can at least offer something similar as well.

    I have found a workaround for this. It works in bulk email actions as well so I wanted to share with all in need.

    HERE IS THE WORKAROUND: Before changing an order’s status, add desired language slug to your admin browser url. Such as: yoursite.com/en/wp-admin/post.php?post=3440&action=edit

    The slug needs to be whatever you set-up in translatepress settings.

    Then change your orders status to completed or refunded or whatever you need and the email will be sent in that language.

    Woocommerce emails are already translated in many languages so I just added conditional shortcodes for additional content, and this solved my problem. Hope this will help you too.

    Is there any other solution to this instead of adding desired language slug to admin browser url? Is there a way to use the <?php
    add_filter( ‘weglot_wooccommerce_translate_following_mail’, ‘__return_true’ ); which they use in weglot to do the same thing automatically?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘(Woocommerce) Only first order’s mail being translated’ is closed to new replies.