Support » Plugin: WooCommerce » WooCommerce not sending customer emails but is sending internal emails?

  • Resolved jackitk

    (@jackitk)


    Hi, wondering if anyone can help? Recently changed email hosting for a client from Cpanel hosted emails over to Google. When we did this, internal emails from WooCommerce stopped sending to the store owner, so we added an SMTP plugin and routed the mail through SendGrid. This fixed the issue with the internal emails and we started receiving them again. Since then, customer emails have now stopped going out but internal ones still being received. Has anyone had this issue before and found a fix? Everything I can find relating to this says the solution is to install an smtp plugin but I have already done this – driving me crazy! The email notifications are enabled and should be running, so not a simple issue such as them not being enabled. I have installed the mail log plugin and it’s logging the emails are being sent, with no errors to any of them. Any help would be appreciated.

    • This topic was modified 1 year, 10 months ago by jackitk.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter jackitk

    (@jackitk)

    Sorry one more thing to add, the email notifications are enabled and should be running, so not a simple issue such as them not being enabled.

    • This reply was modified 1 year, 10 months ago by jackitk.
    Plugin Support Adam a11n

    (@adamkheckler)

    I have installed the mail log plugin and it’s logging the emails are being sent, with no errors to any of them.

    This is the key bit here. If you have a mail logging plugin and it’s saying that all of the emails (including customer emails) are being sent just fine, then the issue does not lie with WooCommerce or WordPress itself.

    I would consult with the SendGrid support folks about why certain emails don’t seem to be sent or received. They likely have logs you can check to see what the issue might be.

    https://support.sendgrid.com/hc/en-us

    Sorry I can’t be of more help here! 🙁

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WooCommerce not sending customer emails but is sending internal emails?’ is closed to new replies.