Support » Plugin: WooCommerce » WooCommerce Not Charging Monthly Subscriptions


    Ever since WooCommerce was updated to Version 3.0+ my monthly subscribers are not being automatically charged. I use both Stripe and Paypal, and have contact both companies. Everything is set up correctly.

    The theme and all plugins are up to date, too. The problem is specific to the WooCommerce 3.0+ update.

    Any ideas on how to fix this issue?

    Below is the system status report:

    ### WordPress Environment ###
    Home URL:
    Site URL:
    WC Version: 3.0.3
    Log Directory Writable: ✔
    WP Version: 4.7.3
    WP Multisite: –
    WP Memory Limit: 768 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    ### Server Environment ###
    Server Info: Apache
    PHP Version: 5.6.30
    PHP Post Max Size: 128 MB
    PHP Time Limit: 120
    PHP Max Input Vars: 3000
    cURL Version: 7.53.0
    SUHOSIN Installed: –
    MySQL Version: 5.6.28
    Max Upload Size: 128 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    ### Database ###
    WC Database Version: 3.0.3
    WC Database Prefix: SBB
    woocommerce_sessions: ✔
    woocommerce_api_keys: ✔
    woocommerce_attribute_taxonomies: ✔
    woocommerce_downloadable_product_permissions: ✔
    woocommerce_order_items: ✔
    woocommerce_order_itemmeta: ✔
    woocommerce_tax_rates: ✔
    woocommerce_tax_rate_locations: ✔
    woocommerce_shipping_zones: ✔
    woocommerce_shipping_zone_locations: ✔
    woocommerce_shipping_zone_methods: ✔
    woocommerce_payment_tokens: ✔
    woocommerce_payment_tokenmeta: ✔
    ### Security ###
    Secure connection (HTTPS): ✔
    Hide errors from visitors: ✔
    ### Active Plugins (23) ###
    Admin Custom Login: by Weblizar –
    AffiliateWP - PayPal Payouts: by Pippin Williamson and Andrew Munro – 1.1.7
    AffiliateWP: by AffiliateWP
    LLC – 2.0.6
    Akismet Anti-Spam: by Automattic – 3.3
    Autoptimize: by Frank Goossens (futtta) – 2.1.0
    Fusion Builder: by ThemeFusion – 1.1.6
    Fusion Core: by ThemeFusion – 3.1.6
    iThemes Security Pro: by iThemes – 3.7.4
    Jetpack by by Automattic – 4.8.2
    Regenerate Thumbnails: by Alex Mills (Viper007Bond) – 2.2.6
    Remove Query Strings From Static Resources: by Speed Up My Website
    Your WP Expert – 1.4
    WP REST API: by WP REST API Team – 2.0-beta15
    Rocket Lazy Load: by WP Media – 1.1.1
    SG Optimizer: by SiteGround – 3.2.3
    SSL Insecure Content Fixer: by WebAware – 2.2.3
    Thrive Leads: by Thrive Themes – 1.95.15
    WangGuard: by WangGuard – 1.7.3
    WooCommerce PayPal Powered by Braintree Gateway: by WooThemes – 1.2.7
    WooCommerce Stripe Gateway: by WooCommerce – 3.1.7
    WooCommerce Subscriptions: by Prospress Inc. – 2.2.4
    WooCommerce: by Automattic – 3.0.3
    WP-Optimize: by David Anderson
    Ruhani Rabin
    Team Updraft – 2.1.1
    WP Smush: by WPMU DEV – 2.6.3
    ### Settings ###
    API Enabled: ✔
    Force SSL: ✔
    Currency: USD ($)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    Taxonomies: Product Types: external (external)
    grouped (grouped)
    simple (simple)
    subscription (subscription)
    variable (variable)
    variable subscription (variable-subscription)
    Taxonomies: Product Visibility: exclude-from-catalog (exclude-from-catalog)
    exclude-from-search (exclude-from-search)
    featured (featured)
    outofstock (outofstock)
    rated-1 (rated-1)
    rated-2 (rated-2)
    rated-3 (rated-3)
    rated-4 (rated-4)
    rated-5 (rated-5)
    ### WC Pages ###
    Shop base: #100 - /shop/
    Cart: #101 - /cart/
    Checkout: #102 - /checkout/
    My account: #103 - /my-account/
    ### Theme ###
    Name: Avada Child
    Version: 1.0.0
    Author URL:
    Child Theme: ✔
    Parent Theme Name: Avada
    Parent Theme Version: 5.1.6
    Parent Theme Author URL:
    WooCommerce Support: ✔
    ### Templates ###
    Overrides: Avada/woocommerce/cart/cart.php
    ### subscriptions ###
    WCS_DEBUG: ✔ No
    Subscriptions Mode: ✔ Live
Viewing 3 replies - 1 through 3 (of 3 total)
  • Same here. We noticed that around 70% of our customers had been changed to ‘manual renewal’. After a days work of manually fixing many of them (going into the subscription options, going to payment method and selecting either stripe or paypal.) we’ve realized it still isn’t working. Any help would be appreciated. The 3.0+ updates have really put a hurting on us.

    @jeffwilliams-1 – I had been having a similar issue since the WC 3.0 update and after reading your post, realized that we are both using Siteground. I cleared my Siteground cache from cPanel and believe that may have solved the issue for me. Have you tried that yet?

    I cleared my Siteground cache from cPanel and believe that may have solved the issue for me.

    @mj4455 that’s a great tip, thanks for sharing!

    We noticed that around 70% of our customers had been changed to ‘manual renewal’

    @autonomite that is a different issue. It occurs when WooCommerce was upgraded prior to upgrading Subscriptions to 2.2.0 or newer. If you have not already, please immediately submit a support ticket to Support and we will be able to fix up the subscriptions.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘WooCommerce Not Charging Monthly Subscriptions’ is closed to new replies.