Support » Plugin: WooCommerce » Woocommerce New order Doesn’t send emails

  • Woo-commerce isn’t sending me new order’s email. I’ve trying a lot of different troubleshooting tips without success. I installed the WP SMTP Mail plugin and tested it with SMTP and PHP. Still can’t see emails in my inbox. Changed my email from @mydomain.com to gmail address. Nothing happened. Installed Email log and can see that nothing happen after successful orders are placed. When I visit the order tab I found the order status as “Processing” but I don’t receive any email neither as a customer nor as admin. Only when I manually change the status to “On Hold”, save, change it back to “Processing” and save, I recieve the email as customer but nothing as Admin. How can I get notified that there a new order is placed if I’m not able to receive email notifications???

Viewing 12 replies - 1 through 12 (of 12 total)
  • The same problem I have. How to solve this problem?

    motorollie

    (@motorollie)

    Yes, setting up mail in WordPress can be a hassle. Struggled with it too… much depends on your hosting provider and the settings they use.

    All my problems were solved with this free plugin: https://nl.wordpress.org/plugins/postman-smtp/

    I’v set it up with the Gmail API. So your mail completely runs on Gmail. No more hosting/PHP/Wordpress/Woocommerce dependancy. Works perfectly. The plugin also keeps a log of which mails were sent. And it has very good self diagnostic tools, to check if something is wrong.

    • This reply was modified 4 years ago by motorollie.
    • This reply was modified 4 years ago by motorollie.
    Serdobolniy

    (@serdobolniy)

    The problem is not the hosting provider. I upgraded to 2.6.11 and the mail stopped coming. But thanks anyway for the temporary solution.

    ibrahimwalied

    (@ibrahimwalied)

    I totally agree with Serdobolniy. I’ve tested Postman with Gmail API and with my hosting provider and sent test emails. Everything work great but still when orders placed I receive nothing. And only after manually changing the order status to “Completed”, I receive an email as a customer not an admin.

    I’ve tested with 20+ different real transactions and wasted a lot of effort and time without success. Do WooCommerece people see our posts here???

    Same problem here, I already spending so much time looking for a solution…

    The logs of the server I’m using for the SMTP shipping I see that the emails aren’t even being sent, so no errors are shown.

    Anyone found a solution?

    Very easy. No need plugin
    If your wordpress admin email is a@gmail.com(send email to customer)
    and then woocommerce email setting should be set b@gmail.com(receive by yourself)

    a-email vs b-email ok!

    a-email vs a-email bad!

    100% work.
    If not. Please check your Spam folder.

    @yakach Goood Job ! Thanx mate

    @yakach Please can you explain more as I have some issues my end driving me crazy!

    Lets say I have e-mails of user@domain.com that needs to received the ‘New Customer Order’ email.

    Then I have no-reply@domain.com which needs to be the sender… what do I need to do?

    Then there is the customer@customerdomain.com which is the customer of an order…

    Thanks,

    Harvey

    @yakach : Version 3.2.3 do not work

    @okegima @harveyl12

    General Settings – Email address: a@gmail.com
    Woocommerce settings – Emails – Email sender options
    “From” name: Store name

    “From” address : b@gmail.com

    Then c@gmail.com to order your product.

    Ok?
    My email address yakach@gmail.com

    • This reply was modified 2 years, 10 months ago by yakach.
    • This reply was modified 2 years, 10 months ago by yakach.

    Email notifications
    Email notifications sent from WooCommerce are listed below. Click on an email to configure it.

    Email Content type Recipient(s)

    New order text/html a@gmail.com

    Cancelled order text/html a@gmail.com

    Failed order text/html a@gmail.com

    (a@gmail.com same as wordpress admin email address.)

    General Settings – Email address: a@gmail.com

    Woocommerce settings – Emails – Email sender options
    “From” name: Your Store Name

    “From” address : b@gmail.com (Set to sale@yourdomain.com is also ok.)

    Then c@gmail.com to order your product.

    My email address is yakach@gmail.com.

    • This reply was modified 2 years, 10 months ago by yakach.
    • This reply was modified 2 years, 10 months ago by yakach.
    • This reply was modified 2 years, 10 months ago by yakach.
Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Woocommerce New order Doesn’t send emails’ is closed to new replies.