Support » Plugin: WooCommerce » WooCommerce Loading Issues [TTFB]

  • Resolved realpashy

    (@realpashy)


    Hey,

    I’ve been stuck with an issue quite some time now and I can’t figure it out. I tried literally everything I know from 3 years experience in WordPress but nothing seems to help.

    Basically, I am getting 5-12 seconds TTFB on pages where WooCommerce is called, for example a product page, shop category, etc… However, in pages where WooCommerce is not called, it runs smoothly.
    Example with WooCommerce
    Example without WooCommerce
    Note: The back-end is also extremely slow on pages that loads WooCommerce beside order pages which seems to load alright.

    You can clearly see the difference. Note that you might see it as “okay” but it might be cached. However, if you’re a logged in user or admin, it takes forever.

    I tried WP Rocket, W3TC and SG Optimizer since my webhost is Siteground, tried optimizing database as the theme author says I have bottleneck in my mysql executions. Even though, the server runs very fast and smooth (other websites on the same server are enough proof). I have also tried with and without Cloudflare but same results.

    I also tried disabling all my plugins but nothing really seems to change unless I deactivate WooCommerce which brings me to the site load speed when WooCommerce function is called, then it is fast.

    I am wondering why I am getting this and hopefully I can get a solution as I have a running website.

    Test for WooCommerce page: https://tools.pingdom.com/#!/eBSVsu/https://www.kpopbae.com/shop/
    Test for non WooCommerce page: https://tools.pingdom.com/#!/QTKjR/https://www.kpopbae.com/contact-us/

    GTMetrix: https://gtmetrix.com/reports/www.kpopbae.com/NkOplCgq

    Web Page Test: https://www.webpagetest.org/performance_optimization.php?test=171211_6C_7efae71cb9e50a72a5f411dcc65c0ad9&run=3

    Note: As of writing this, I have the latest versions of everything; WooCommerce, WordPress, the theme and all plugins.

    Thanks in advance for the help!

    • This topic was modified 2 years, 3 months ago by realpashy. Reason: adding information

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • About everyone received a reply but I didn’t 🙁 Any help would be highly appreciated… Still trying things out but without luck.

    I get a response in 650 msecs. Without cache, I think (added ?x=random_string to the url).

    Response header:

    content-encoding:br
    content-type:text/html; charset=UTF-8
    date:Wed, 13 Dec 2017 20:31:52 GMT
    host-header:192fc2e7e50945beb8231a492d6a8024
    link:<https://www.kpopbae.com/wp-json/&gt;; rel=”https://api.w.org/&#8221;
    server:cloudflare-nginx
    status:200
    vary:Accept-Encoding,User-Agent
    x-proxy-cache:MISS

    What if you disable cloudflare?

    This is another pingdom result: https://tools.pingdom.com/#!/dmNhxo/https://www.kpopbae.com/shop/?z=zz

    Thank you! I am currently testing so what you are seeing is not what I am encounter when I posted this. Apparently, there are 2 conflicts with WooCommerce. The first one from the theme and the second is necessary plugin for WooCommerce. I contacted theme author and got as usual generic copy pasted text… Next, I’ll will contact plugin author to get more information.

    Currently customizing Storefront theme.

    We haven’t heard back from you in a while, so I’m going to mark this as resolved. If you have any further questions, you can start a new thread.

    Hey did you had any lack in order to fix this? i am also having the same problem

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WooCommerce Loading Issues [TTFB]’ is closed to new replies.