Support » Plugin: WPAdverts - Classifieds Plugin » WooCommerce Issue

  • Resolved bigswp

    (@bigswordpress)


    Hi,
    I was having trouble uploading an image when you create a classified on the front end. Everything works except you cannot upload an image. I tried disabling all my other plugins and discovered it will not work while WooCommerce is enabled.

    You also can’t view the contact info either when you click the button.

    When you try to hit either of those buttons you just get an # on the end like this…

    https://dugout.bullpen.ca/advert/baum-bat-30-inch/#

    https://dugout.bullpen.ca/listings/add/#

    I assume this is a javascript issue. Any fix?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Greg Winiarski

    (@gwin)

    Hi,
    there is the following JavaScript error on your website Uncaught ReferenceError: Cookies is not defined, which is actually caused by a 404 (not found) error when loading woocommerce/assets/js/js-cookie/js.cookie.min.js file.

    It looks like one or more files from the WooCommerce plugin are missing, you can try uploading just this file to your server or reinstalling the WooCommerce plugin.

    If this will not help you can try asking WC support for help, they might already be aware of this issue.

    In either case this JavaScript error is most likely preventing the WPAdverts upload scripts from executing. Once you will have the above errors fixed the file upload should start working fine.

    If you would like to verify if WC is actually the source of the problem, you can try disabling WC for a while and see if it fixes the file upload.

    bigswp

    (@bigswordpress)

    Hi Greg,
    Yes that was the issue thanks so much for your help.

    For those of you having the same issue you have a couple of options…

    1st – Ask your host to update their outdated mod_security rulesets

    2nd – Go to https://github.com/rynaldos/woocommerce-js-cookie-fix and download this file as a zip. Then simply install it on your site as a regular plugin and activate it. There are no settings it works on its own.

    Thanks again Greg.

    Plugin Author Greg Winiarski

    (@gwin)

    Hi,
    i am glad you have it resolved and thanks for the feedback i am marking the thread as resolved maybe someone will find it helpful in the future.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.