Support » Plugin: LiteSpeed Cache » Woocommerce Inventory Stock not Updating

  • Resolved Chris

    (@eaonflux)


    After i buy a product and finish the checkoutpage. the product stock is not being updated? When i am loged in it does but when i am visiting the page anonymous i get an old cached version of the productpage where the product stock is not being updated?

    https://github.com/litespeedtech/lscache_wp/blob/master/thirdparty/woocommerce.cls.php#L111

    on this page i see the code that should do the trick but somehow it doesnt work? i have no clue what i am doing wrong?

    wp-admin/admin.php?page=litespeed-cache#woocommerce
    it doesnt matter what i choose as option none of them works when not logged in

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please check this doc for how to get purge tag

    it’s for different issue , but the process for grab tag is same.

    please get the tag, and we will see what happened.

    Best regards,

    I put it on advanced debug but the only thing LS is purging are:
    cart
    widget
    comments
    Feeds

    it doesnt purge the specific product page(s) where is set a quantity stock amount.

    I created a custom esi block as dirty fix but that is not what i want because of the following;

    I need to edit the WC template files the blank out the product stock display so i can inject mine esi version in to a hook.
    With the variation template there is no hook but Java, which i dont know how to replace the avaibility with mine custom esi block.

    i test this problem on 3 websites that are running on LS Enterprise and to my suprise on none of these 3 websites the stock quantity gets updated (purged) after i buy that specific product???

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Did you change anything in Purge setting ?

    and please provide the report number.

    Best regards,

    Report nr: 902249
    ON the purge page everything should be the default settings.

    section “Purge All On Upgrade” > On
    section “Auto Purge Rules For Publish/Update”
    everything is checked except:
    – All pages
    – Yearly Archive
    – Daily Archive

    Section “Server Stale” > Off

    Section “Scheduled Purge URLs” > Empty

    Section “Purge All Hooks” contains all Recommended values;
    switch_theme
    wp_create_nav_menu
    wp_update_nav_menu
    wp_delete_nav_menu
    create_term
    edit_terms
    delete_term
    add_link
    edit_link
    delete_link

    but when i read and understand it correct;
    When a stock amount is set in the product and it gets bought. when it passes the checkout the cache returns the post id(s) and only these productpages gets purged.
    This behaviour is see when i use my own created custom esi block.

    i gues i am probally missing something in the settings, but what?

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Could you please try fully reset it to default setting, purge all , and then test it to see how it goes ?

    Best regards,

    i reset everything to default. didnt touch any of the settings and tried again. still not purging the product page

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please create a ticket here, we will investigate it further.

    Best regards,

    i already did. Thanks for your effort to help me 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.