Support » Plugins » Woocommerce has suddenly stopped sending emails for new order

  • Our site has suddenly stopped sending ANY Woocommerce email notifications! Since Friday last week. Up until then our WooCommerce site has been working happily for over 18 months.
    http://www.woodypeck.com

    I have tried to resend the “New Order” email for order we have received today but even that will not work – No Emails are coming through from Woocommerce either auto generated or manually prompted & requested?

    This is not a new website & shop our site has been up and running for over 18 months happily.

    Any idea’s why this should have suddenly stopped?

    The only event that has happened is we do send out Mailpoet email newsletters and we have been doing this for a couple of months! We did one last week using Mailpoet and the SendGrid 3rd party SMTP facility.

    Any help would be appreciated.
    Thanks. Steve

Viewing 15 replies - 1 through 15 (of 15 total)
  • You can install this plugin and check the email log to verify Woocommerce is not sending email. Perhaps it is receiving email that is the problem. It’s very common.

    Thread Starter Woodypeck

    (@woodypeck)

    Thanks Jason.
    I will try the plugin tomorrow.
    I am getting emails from WordPress and new users / subscribers to our site – just nothing from the WordPress plugin.

    I will see what this plugin tells us and report back.

    Many Thanks
    Steve

    Thread Starter Woodypeck

    (@woodypeck)

    I am back in the office today and by magic this morning New Order emails started to work again – by magic>?
    I went back to some of the last orders and tried to pushed “New Order” email from inside woo commerce. One of them actually came through OK but the other one has not yet?

    So something is half working it seems even though I have not used your plugin yet.

    I will upload the plugin this afternoon later and give you a report.

    Thanks
    Steve

    Thread Starter Woodypeck

    (@woodypeck)

    Well I am still getting the problems! I didn’t want to add any more plugins at this stage as I wanted to check what was happenening in all events before moving forward and I have found out the following!

    I upgraded to the latest WordPress version 4.4 Clifford in the hope that this might clear the email problem up – but it hasn’t!+

    I do get the odd occasional random email from WooCommerce when an order comes in but it is probably 12% of the time!

    I get all my emails from WordPress perfectly for new users and posts etc so WordPress works correctly as far as I can see.

    The other strange point is that if I open a new order and manually click to action an email for a new order then this will come through – some of the time maybe 60%. Sometimes it doesn’t make it. But if I repeat the sned new order action a few times eventually it comes through. But this doesn’t work all the time???

    So I have a Woo Commerce shop that occasionaly sends out email alerts but not regularly. Most orders do not generate any email within WooCommerce unless manually regenerated via the “New Order” tab! The whole thing is completely random and Woo Commerce is just not sending out the emails as it used to do up until 4 weeks ago!

    Can anyone actually help with this or is it just another post/complaint that gets ignored?

    I guess the ISP is blocking some emails due to being seen as Spam.
    I’d suggest you to try with plain text emails
    Woocommere > Settings > Emails and set the email type to Text.

    See if it works now. If it does, then you could use Mandrillapp.com. They do have a WP plugin and it uses the Mailchimp engine to send WP emails out. This way no email will be marked as spam.

    Goto Woocommerce > Setting > Emails. You can see a field name “Email Sender Options” under this in “From” Address” field save email as “wordpress@yourdomain.com” its look like stupid but really work Enjoy !!! 🙂

    Thread Starter Woodypeck

    (@woodypeck)

    Plasmax
    Thanks for your reply. Tried your suggestion to send only Text – but this did not make any difference at all! Sorry – still nothing coming thru.

    We have now performed the latest Woocommerce update today & even this hasn’t changed anything – still NO Emails coming thru! Over the last 4 weeks we have had 4 emails come thru out of 50+ orders. So some do come thru but not many. We can sometimes Force the emails to come thru if we open an order and force another email notification in the actions box. This works about 15% of the time not more.

    So something is broken somewhere or the ISP is blocking most and only letting the occasional one thru?

    This is killing our business to work in this way!
    Wish I had never adopted WordPress and Woocommerce now!

    Very frustrated!

    Cedcommerce – I have tried your fix….so lets hope it works in the next few hours when the next order arrives.

    Thank you all, we do appreciate your help and assistance keep trying ideas

    Steve

    Thread Starter Woodypeck

    (@woodypeck)

    Cedcommerce – your fix seems to have worked – Brilliant
    It works with me making a repeat order notification – and has worked half a dozen times with that very quickly!
    I have also put back the email settings from Text back to HTML and it still works quickly. Emails come straight in to my inbox!

    So all we need now is to see a genuine New Order come in to our site this evening and to see if the fix works for that too!

    Good news so far – many thanks for that neat fix!

    Steve

    WordPress+Woocommerce is probably the most clever combination you could have gone for. I’m not taking any part here but according to the randomness of your error it was very likely to be because of your server. It’s happening on many of my installations too. Right now your WP is using PHP mail() to send notifications out. PHPMail() does not authenticate the messages via smtp and nowadays most hosting companies require to do so (to avoid email spoofing). In case you will encounter this kind of issue again, the best workaround is to install a plugin like WP Mail SMTP to send all your notifications with SMTP authentication. All you will have to do is install the plugin and fill the settings in with the SMTP credentials of the account you want to set as the notifications sender (for example info@yoursite.com).

    More and more hosting companies are going to tighten their email servers security and for this reason I hope Wp will natively introduce some smtp settings very soon, as in fact PHP mail() doesnt work on many servers anymore (especially on shared hosting plans)

    Hi,

    I am using Listify – WordPress Directory Theme. When a new user registers on my site, they must receive a welcome mail with username and password link/ if user has forgotten the password they must receive mail with reset password link. These mails are not being received neither in inbox nor in spam folder. My site displays success message. But mails are not being received.

    I have installed SB welcome mail, WP mail SMTP plugins. I am able to receive the test mails sent from these plugins. I have also installed WP mail logging, mail logs are also created. But no mails are received neither in inbox nor in spam.

    My site is hosted on GoDaddy’s Linux shared hosting.
    I am using yahoo mail id as admin main address. Please advice if any settings need to be done in this regards. (I am not a developer)

    I have contacted the theme support forum, but said that they does not handle mail. Mail are handled by wordpress and woo-commerce.

    Please help to resolve this issue.

    Thanks in advanced. Any help is appreciated.

    Gaurav.

    • This reply was modified 4 years, 10 months ago by gshah1993.

    It’s very likely to be a server issue.

    Paste your website IP here: http://mxtoolbox.com/blacklists.aspx

    If you get some red flags get in touch with GoDaddy as that means some other people on your same server (being that a shared hosting) have been using the account to send spam, therefore the IP has got banned by some providers.

    If that’s the case GoDaddy will contact the provider and ask to

    I would never recommend hosting an ecommerce platform (or anything important) on a shared hosting. At least you should get yourself a dedicated IP as the email notifications are crucial on a website like yours.

    If all the checks are green then I would still get in touch with GD and ask them. If they can’t solve it you should then open a new topic as these are the rules on these forums.

    Cheers

    Thank you Pelly Benassi! Now I receive mail form woo commerce again and you made my day (y)

    • This reply was modified 4 years, 10 months ago by kvisten.

    very glad I could be of help! 🙂

    @cedcommerce, your fix worked for me as well. Thanks!

    I am having this same issue, seemed to crop up over the weekend, no idea why. I’ve tried changing the from email as suggested, set to plain text, and checked against any blacklists on the domain. No luck. I was unable to successfully configure web mail smtp – probably because I’m using a shared godaddy server? any help would be greatly appreciated!

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Woocommerce has suddenly stopped sending emails for new order’ is closed to new replies.