Support » Plugin: WooCommerce » WooCommerce extremely slow after WordPress 4.2 update

  • Resolved Lakjin

    (@lakjin)


    Hello,

    After updating to WordPress 4.2, it is literally taking 10 mins to open up one WooCommerce product in the admin backend. Everything else seems to be fine — opening products for edit or creating new products is the thing screwing up. Any idea what is up?

    Thanks!

    https://wordpress.org/plugins/woocommerce/

Viewing 15 replies - 31 through 45 (of 94 total)
  • @doug Smith: Awesome, thanks for the temporary workaround — it totally solved the issue for me. However, can someone please confirm this: editing out line 680 as Doug suggests only disables the dropdown menu for custom fields when I’m editing products / posts, right? It doesn’t stop plugins from adding custom fields?

    Thanks!

    @doug Smith You’ve saved us!

    We also had this weird 28sec load time all of a sudden and couldn’t pinpoint what the culprit was. I did feel it had something to do with WP 4.2, but could never have found the solution that you shared. It did the trick, so a massive thank-you.

    Yes, we may no longer have a dropdown for custom fields (unused anyway, probably by most users – @lakjin you should be safe), but we got back our 3sec load time back and that’s far more important. Terrific investigative work @doug Smith.

    This time it wasn’t WooCommerce (for a change); I confirm that it’s a core WordPress 4.2 issue and I therefore strongly recommend that someone in WP takes note and raises this as a core fix for WP 4.2.3. We really do not want to tamper around with core files, but this was a necessity.

    I confirm the temporary fix @dough Smith mentioned works.

    it’s an issue between woocommerce and the newest version of wordpress, if you check your database you will see in the ‘options’ section that wocommerce is creating 10’s of thousands to upwards of 300k of empty fields. so your website is being slowed down because it’s having to load all these empty fields, i only discovered this because i had so many empty fields that it finally exhausted the memory and the site wouldn’t load anymore. I have had extensive talks with tech support over this at my hosting company and they say it’s happening to a Ton of sites that are using woocommerce. They said that the options fields should hover around 800 – 1500 not 300,000 – so i encourage you to check that, have all the blank fields flushed and you will notice an immediate increase in your sites speed., I know i have, fixed mine immediatly and is blazing fast.

    they say there isn’t a fix yet and to reach out to woocommerce about it. they did say that some customers have found that uninstalling woocommerce and then re-installing it has worked for some but not all. The only real fix right now is to de-ativeate woocommerce, or you just have to keep flushing the empty feilds as they continue to fill up your database and slow down your website.

    so those that are disabling plugins etc and still have a slow site it’s because you need to remove all those empty fields in your database first. then it will load just fine. (i suggest you let your hosting company do this if you don’t know how)

    So hopefully woocommerce will fix what ever it is that is causing this with the newest wordpress update.

    @mike Jolley, Yes I do have a site with this occurring now and I’d be happy to make access available to you. What’s the best way to get in touch?

    And as @mobipowered mentioned, I’m also seeing tons of transients building up in my database, which has been part of the problem. I had my database crash several times so I installed the Transient Cleaner plugin (https://wordpress.org/support/plugin/artiss-transient-cleaner, which has helped some. But that doesn’t really solve the root problem, of course. I just checked and my database and it has built up over 100K transients even with that running.

    Plugin Author Mike Jolley

    (@mikejolley)

    @doug Smith We will have a release later today with some transient optimisation. Try that first, then I’ll look if its no better.

    *ach!* Was wondering why the backup files were so much bigger this week and discovered 37,215 rows in the options table.

    Using the above mentioned plugin Cleaner only took out 2,000 rows.

    Hey Everyone,
    Actually, I’m having the same problem and I don’t use Woocommerce…I don’t even run an e-commerce site.

    Here my original post –
    https://wordpress.org/support/topic/wp-backend-is-very-slow-almost-non-functioning?replies=4#post-7039460

    – and it started with 4.2, not 4.1, I have a mirror running fine on 4.1. I’ve removed every single plugin, exported the db and installed on an older version of WP and it works fine.

    Does anyone know if WP is aware of this – working on it? It seems pretty widespread.

    Rob

    Hi all,
    I’ve got a test version of my website with the new version of Woocommerce Version 2.3.10 on WordPress Version 4.2.2
    Unfortunately the slowness issue hasn’t been fixed. I’m still having to run my live site on WP 4.1.5 in order for it to be usable.

    I got this error where a widget was supposed to be loaded:

    Fatal error: Maximum execution time of 60 seconds exceeded in /wp-includes/taxonomy.php on line 181

    I haven’t made the temp fix that Doug Smith came up with on this website because I want to be able to see if the issue has been fixed.

    @doug Smith
    @mike Jolley

    Doug! How did you ever come up with that solution? It works for me too. I couldn’t even create a new post, page, have the admin operations of my plugins were so slow I wasn’t even able to work with them.

    I use that workaround you came up – comment out line 680 in /wp-admin/includes/template.php – and now the plugins are all “normal” speed – being very fast. The other things – add new page/post – are usable but still slow. They went from 70-100 seconds down to 10-20 seconds.

    I have no Woo installed at all. Nothing Woo, I’d removed all my plugins, and nothing had an impact. Fairly certain this is a WP issue – do you know if it’s being worked on by anyone at WP as it is not related to just Woocommerce.

    Thanks Doug – lifesaver man!
    Rob

    I spoke too soon…lol

    It worked on my test server but not my production server.

    Which is very strange since the test server was built from an image of the production server and is virtually the same exact thing.

    Back to downgrading WordPress it seems.

    Ahha! Found this page:

    • Too many wc_sessions in WooCommerce?
    https://www.remicorson.com/too-many-wc_sessions-in-woocommerce/

    … then followed the instructions to “Clear all sessions” with the Woo/System Status/Tools and removed 30,000 empty rows from my site’s Options table.

    Hi,

    I experienced the same issue when upgrading from a lower version directly to 4.2. It seems that the updates in version 4.1 does not play well when upgrading at once.

    I tracked it down to the error in the following ticket (see my post on it):

    https://core.trac.wordpress.org/ticket/31388

    The database upgrade doesn’t recreate the indexes as it should due to the errors so the table doesn’t use the right indexes which seems to cause the slow response.

    You can manually recreate the indexes by running this snippet in the db:

    DROP INDEX meta_key ON wp_usermeta;
    DROP INDEX name ON wp_terms;
    DROP INDEX meta_key ON wp_commentmeta;
    DROP INDEX meta_key ON wp_postmeta;
    DROP INDEX post_name ON wp_posts;
    
    ALTER TABLE wp_usermeta ADD KEY meta_key (meta_key(191));
    ALTER TABLE wp_terms ADD KEY name (name(191));
    ALTER TABLE wp_commentmeta ADD KEY meta_key (meta_key(191));
    ALTER TABLE wp_postmeta ADD KEY meta_key (meta_key(191));
    ALTER TABLE wp_posts ADD KEY post_name (post_name(191));

    (You might get some errors while dropping if you don’t have the index but don’t worry, as long as the new indexes are created it will work just fine)

    Hi jstensved,
    That didn’t work for me, my site still becomes excruciatingly slow and I get errors like this:

    Fatal error: Maximum execution time of 60 seconds exceeded in /wp-includes/taxonomy.php on line 181

    …when I upgrade to WP 4.2.2

    @doug Smith : THANK YOU!
    I don’t have woocommerce installed but my wp was also very slow after upgrading to 4.2.2. Your solution fixed it, thank you!

Viewing 15 replies - 31 through 45 (of 94 total)
  • The topic ‘WooCommerce extremely slow after WordPress 4.2 update’ is closed to new replies.