Support » Plugin: WooCommerce » WooCommerce extremely slow after WordPress 4.2 update

  • Resolved Lakjin

    (@lakjin)


    Hello,

    After updating to WordPress 4.2, it is literally taking 10 mins to open up one WooCommerce product in the admin backend. Everything else seems to be fine — opening products for edit or creating new products is the thing screwing up. Any idea what is up?

    Thanks!

    https://wordpress.org/plugins/woocommerce/

Viewing 15 replies - 16 through 30 (of 94 total)
  • When I update to 4.2 I get the following message with debug turned on:

    Notice: register_taxonomy was called incorrectly. Taxonomy names must be between 1 and 32 characters in length. Please see Debugging in WordPress for more information. (This message was added in version 4.2.) in /wp-includes/functions.php on line 3560

    Is that any help Mike? I can also give you a login to a test site if you think that might help.

    I know Claudio has been looking into this but so far unable to find a cause, mainly due to that function not changing between 4.1.x and 4.2.x. If someone could send an export (tools > export) of their products to mike.j[at]woothemes.com we can import that and see if there is anything erroneous/if it happens on another install.

    I don’t know if it helps but after WP 4.2 update, I had to let it “upgrade” (“update”?) my database, which took a very long time.

    Mike,

    Just sent you an e-mail with all of my products as an attachment. I have not yet updated to 4.2 as I noticed this thread beforehand and have been afraid to update.

    Was the Woo team able to figure out what is going on?

    Thanks!

    Hi Mike.
    Does the problem this person is having here:
    https://wordpress.org/support/topic/urgent-max_related_posts_query-extremely-slow-please-help
    …give you any additional clues?
    Cheers

    It’s been 3 weeks without any update, my business lost a lot because of this, removed all the plugins and the website is still too slow! is there anyone working on this problem?

    It’s been 3 weeks without any update, my business lost a lot because of this, removed all the plugins and the website is still too slow! is there anyone working on this problem?

    If Woo is so important to your business, how about quit your whining about lack of FREE support and start paying someone to fix it for you? Asking for updates is one thing; whining about FREE support is another.

    Want it done on your timetable? Open your wallet. Until then, be respectful to the people who spend their time and energy using something you pay $0 for.

    Someone here should be able to fix it:
    http://jobs.wordpress.net/

    Hi Lakjin, Where did you see I asked for FREE support? some respect please, this is a professional thread it is supposed to help solve problems. If the team is getting annoyed from comments then why would there be support threads to start with.

    Hi Lakjin, Where did you see I asked for FREE support? some respect please, this is a professional thread it is supposed to help solve problems. If the team is getting annoyed from comments then why would there be support threads to start with.

    Pot, meet kettle.

    Plugin Author Mike Jolley

    (@mikejolley)

    We’ve still be unable to replicate. 1 user sent us data but it was for a site without confirming they had the issue first. If anyone else wants to email anything to me I’m willing to review it.

    We’ve still be unable to replicate. 1 user sent us data but it was for a site without confirming they had the issue first. If anyone else wants to email anything to me I’m willing to review it.

    Unfortunately, I can’t send you any tables (for various reasons). However, from my end, the issue is fairly straightforward.

    Each time a Woo product is open via the backend (or refreshed, such as after an update has been posted), the following query is called (by either Woo or WordPress — I think it is WordPress):

    SELECT meta_key
    FROM wp_postmeta
    GROUP BY meta_key
    HAVING meta_key NOT LIKE '\\_%'
    ORDER BY meta_key
    LIMIT 30

    As I have a wp_postmeta table that is over 6 GB, it takes 5-10 mins for this query to run. This did not happen before WordPress 4.2 update.

    My wordpress site is also extremely slow. I can barely get into the admin area to make any changes and I can barely get to the front side either. Using storefront and boutique.

    I’m updated to 4.2.2. I’m new to WP and getting VERY discouraged.

    http://www.poorridgeranch.com/soap/

    I can confirm that I am having the same problem, though not as severely as others. I’m seeing a delay of around 15 to 30 seconds. It has been happening for the last week or two, which does correspond with the approximate time frame of my updating WordPress.

    This isn’t limited to opening products for me. I see it with products, orders, posts, pages, etc. In fact, if I disable WooCommerce I still get the delay loading pages and posts. No matter what the post type, it is associated with that same query posted above.

    There still may be some tie into WooCommerce, though. That query is used for the custom fields metabox. It populates the Name dropdown menu for when you add a new custom field. On my site I’m seeing a bunch of WC SKUs in that menu, which I didn’t expect. They are all in the form of [SKU: 12345]. So maybe a site with a lot of products would be affected more.

    There has been some recent trac ticket activity regarding this issue. #32361 was closed as a duplicate of #24498, which has been hanging around for a couple years.

    Each of those tickets have different solutions. I tried both and they significantly reduce the load time for me. However, the one in #24498 eliminates the dropdown menu completely, so there may be problems with it.

    If you don’t care about that menu for adding a custom field, you can remove the database query completely and speed things up. Normally, you wouldn’t want to be editing WordPress core files, but this is just for a temporary workaround and testing purposes. All you have to do is comment out line 680 of /wp-admin/includes/template.php, like this.

    //$keys = $wpdb->get_col( $wpdb->prepare( $sql, $wpdb->esc_like( ‘_’ ) . ‘%’, $limit ) );

    @mike Jolley,

    I’m willing to send you a product export if you want it, but I’m not sure how helpful considering the above. I am a paying Woo customer, so if it’s of help I would be happy to file a ticket or make a login to my site available for investigation.

    Plugin Author Mike Jolley

    (@mikejolley)

    Nice investigation @doug Smith. You have a site with this occurring now? I’d actually love to get a look at this with code access to try improving that query. Maybe I can submit a core patch (if I can find a solution of course). This code did not change with 4.2 so I imagine its related to query caching..

Viewing 15 replies - 16 through 30 (of 94 total)
  • The topic ‘WooCommerce extremely slow after WordPress 4.2 update’ is closed to new replies.