Support » Plugin: WooCommerce » Woocommerce errors when uploading theme

  • Resolved queenb123

    (@queenb123)


    hi when installing woocommerce plugin i get:

    Installing Plugin: WooCommerce

    Downloading install package from https://downloads.wordpress.org/plugin/woocommerce.2.2.10.zip…

    Unpacking the package…

    Could not copy file. woocommerce/assets/images/chosen-sprite.png

    can someone please help as the theme authors are saying its nothing to do with them, this is the message i get from them:

    Again: thats not theme related.
    Make sure that directories are writable. The error is from woocommerce and we are not the authors.

    My best guess: Directories not writable.
    If that doesnt work you can download woocommerce and copy it yourself via ftp

    ****I have downloaded it and ftp it but still showing errors, Please help***

    https://wordpress.org/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 16 total)
  • I have now tried to upload via wordpress with zip file i get:

    Unpacking the package…

    Could not copy file. woocommerce/templates/loop/sale-flash.php

    never come across this before, i just wanna begin building my site!

    Plugin Author royho

    (@royho)

    So if you used FTP, you shouldn’t get the same error message because the error message is only happening when you’re installing it via WordPress auto update/install. So another words, if you have uploaded it via FTP, you no longer need to install it, just activate it.

    i have activated it and i get:

    Fatal error: Class ‘WC_Widget_Cart’ not found in /homepages/19/d501441938/htdocs/atahahair.co.uk/www/wp-includes/widgets.php on line 560

    and
    The plugin generated 5250 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    Plugin Author royho

    (@royho)

    I would suggest you double check to see if you have uploaded all the files..

    i have, ive done this a million times before, ive never experienced this!

    tried again i now get:

    Downloading install package from https://downloads.wordpress.org/plugin/woocommerce.2.2.10.zip…

    Unpacking the package…

    Could not copy file. woocommerce/includes/emails/class-wc-email-new-order.php

    Plugin Author royho

    (@royho)

    Try deleting the plugin folder completely and then re-upload a fresh copy of the plugin via FTP.

    Plugin Author royho

    (@royho)

    So again, you’re not using FTP. As stated, don’t use the WordPress backend to install this.

    i am using ftp, i get an error message, i use wordpress theres an error, dunno what to do!

    Plugin Author royho

    (@royho)

    Please read and follow my last two comments.

    ok i am afraid to do this as theme did not come with a list of plugin folder!

    Plugin Author royho

    (@royho)

    Actually this has nothing to do with the theme. You’re looking for wp-content/plugins/woocommerce so delete that folder and then upload a new copy back into wp-content/plugins/

    ok i have tried that, downloaded a fresh copy of woocommerce plugin, and uploaded it to the plugin folder, STILL an error, the authors of the theme think its:

    Directories not writable.

    i have called my hosting company, they cant help, really dunno what to do now, never experienced this before!

    Plugin Author royho

    (@royho)

    Check your folder permissions via FTP. So files should be 0644 permission and folders generally 0755 permission.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Woocommerce errors when uploading theme’ is closed to new replies.