Support » Plugin: WooCommerce » Woocommerce-NEW Error While Importing CSV

  • Dear Team, Urgent help.

    While iam trying to bulk import the products only some products imported. then i got this error: Slug "type" is not allowed because it is a reserved term. Change it, please. & also one more error in same import Slug "neck-style" is already in use. Change it, please.

    By seeing “slug neck style” i came to know that it is from one of attributes, I already have many attributes in Product>Attributes & hundreds of terms in each attributes. Does it fail to re-write the attribute or how.

    Incase even though some of the attributes and terms exist in the system, if i upload new products with same attributes & values, it is better if it assigns to available attribute & terms because these attributes also used as filters, which result in filtering this new product also

    Screenshot of error:

    exmple attributes:

    • This topic was modified 1 week, 5 days ago by venkeyaccent.
Viewing 1 replies (of 1 total)
  • Plugin Support Shameem (woo-hc)


    Hi @venkeyaccent

    The error message “Slug ‘type’ is not allowed because it is a reserved term” indicates that you’re using a term reserved by WordPress or WooCommerce and cannot be used as a slug. You should change this slug in your CSV file to a term that is not reserved.

    As for the error “Slug ‘neck-style’ is already in use” it means that a product, category, tag, or attribute already exists with the same slug. You can resolve this by changing the slug in your CSV file to something unique.

    Regarding your question about attributes, when you import a CSV with existing attribute values, WooCommerce should automatically assign the existing attribute terms to the new products. If this isn’t happening, please ensure that your CSV file’s attribute names and values exactly match those in your WooCommerce settings.

    For further information, I recommend following our detailed guide here:

    If you continue to experience issues, please provide us with more information about your import process and the CSV file you’re using, and we’ll be glad to assist you further.


Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.