Support » Plugin: WooCommerce » WooCommerce Emails HTML Broken

  • Resolved chinaman123

    (@chinaman123)


    Hi,
    WooCommerce HTML emails sent to notify of new orders and such are broken. Background colors not showing, part of tags like ‘<tr’ are showing. No logo showing in header. Table is broken and not showing properly, no emoji showing and so on.

    It broke since updating to WooCommerce 4.0. Before that it worked fine last month.

    Things I did to try resolve the problem:

    – Deactivated all the plugins except WooCommerce.
    – Deactivated and then activated WooCommerce plugin.
    – Changed theme to the twenty nineteen or so.
    – Reinstalled WordPress update in Dashboard > Update
    – Simplified my function.php down to the bare minimum needed to link the theme to the Parent theme.
    – Changed the Charset and Collation in database to utf8_uni, and going to wp_config.php and changing that to utf8 instead of utf8mb4, and alternating between all these.
    – Checked WooCommerce Email template php file and see no changes between it and the update.
    – Called my hosting company and asked the tech guy if he knew anything about this, and if it’s their hosting side that is the problem causing the broken HTML emails. He didn’t know anything about WooCommerce or WordPress emails. So he was useless.
    – Changed the email format from HTML to the other options and only Plain Text worked properly. The other option showed the same broken html email.
    – Checked email HTML and can see spaces are also added between certain text.
    – Checked WooCommerce status and everything is fine.
    – Everything including theme are up-to-date.

    So I don’t know what the problem is. I think the update to WooCommerce 4.0 messed the email up.

    Much help appreciated.

    Thanks.

Viewing 9 replies - 61 through 69 (of 69 total)
  • My order email HTML is broken. i have upgrade the woocommerce version from WC 3.5.

    it seems like that before

    < table border=”0″ cellpadding=”0″ cellspacing=”0″ height=”100%” widt h=”100%”>
    Gone With The Wind

    Not sure why this conversation is marked “resolved”. I’m just joining it now (May 1, 2020), and have the same problem. It wasn’t fixed with the 4.0.1 update. Does anyone from WooCommerce even pay attention to these discussions, or are we just talking to ourselves?

    @restorm I don’t know why it’s marked resolved but this workaround works great for me: https://remicorson.com/remove-the-woocommerce-3-json-ld-structured-data-format/

    Thanks, Jim. Since it’s not urgent (the broken emails only come to me), I don’t think I’ll mess with the code. I’ll just wait for WooCommerce to wake from their long, deep slumber and fix it.

    Here the same problem and been waiting for a solution from Woocommerce for a long time. Tried everything, disabled various plugins, changed themes and the like, but no change. I am now running on version 3.9 which is going well.

    @glicit thank you for that! The code worked for me.

    In testing, it appears this issue is Outlook related. I sent a test email to my Gmail and the formatting was correct. Perhaps that observation was made before, but that’s what I experienced.

    Hi, Chris Bingham. FYI: I don’t use Outlook or gmail: I use Thunderbird, and I’ve got the problem.

    Hi everyone, I’m having a ton of issues with woocommerce emails, there appears to be a bunch of “=09” characteres added to my html, here’s a sample:

    =09=09=09<address class=3D"address" style=3D"padding: 12px; color: #636363;=
     border: 1px solid #e5e5e5;">
    =09=09=09=09Nathalie Arguedas<br>DEL EBAIS del LLANO 250 metros sur.Casa co=
    lor terracota con muro prefabricado<br>Desamparados, San Miguel<br>San Jos=
    =C3=A9<br>10302=09=09=09=09=09=09=09=09=09<br><a href=3D"tel:70168770" styl=
    e=3D"color: #020202; font-weight: normal; text-decoration: underline;">7016=
    8770</a>=09=09=09=09=09=09=09=09=09=09=09=09=09<br>naty.arguedas@gmail.com=
    =09=09=09=09=09=09=09</address>
    =09=09</td>
    =09=09=09=09=09<td valign=3D"top" width=3D"50%" style=3D"text-align: left; =
    font-family: 'Helvetica Neue', Helvetica, Roboto, Arial, sans-serif; paddin=
    g: 0;">
    =09=09=09=09<h2 style=3D'color: #020202; display: block; font-family: "Helv=
    etica Neue", Helvetica, Roboto, Arial, sans-serif; font-size: 18px; font-we=
    ight: bold; line-height: 130%; margin: 0 0 18px; text-align: left;'>Direcci=
    =C3=B3n de env=C3=ADo</h2>
    
    =09=09=09=09<address class=3D"address" style=3D"padding: 12px; color: #6363=
    63; border: 1px solid #e5e5e5;">Nathalie Arguedas<br>DEL EBAIS del LLANO 25=
    0 metros sur.Casa color terracota con muro prefabricado<br>Desamparados, Sa=
    n Miguel<br>San Jos=C3=A9<br>10302</address>
    =09=09=09</td>
    =09=09=09</tr>
    </table>
    <p>Enhorabuena por la venta.</p>
    =09=09=09=09=09=09=09=09=09=09=09=09=09=09=09
    =09=09=09=09=09=09=09=09=09=09=09=09=09=09
    =09=09=09=09=09=09=09=09=09=09=09=09=09
    =09=09=09=09=09=09=09=09=09=09=09=09
    =09=09=09=09=09=09=09=09=09=09=09=09<!-- End Content -->
    =09=09=09=09=09=09=09=09=09=09=09
    =09=09=09=09=09=09=09=09=09=09
    =09=09=09=09=09=09=09=09=09
    =09=09=09=09=09=09=09=09=09<!-- End Body -->
    =09=09=09=09=09=09=09=09
    =09=09=09=09=09=09=09
    =09=09=09=09=09=09
    =09=09=09=09=09
    =09=09=09=09
    =09=09=09=09<tr>
    =09=09=09=09=09<td align=3D"center" valign=3D"top">
    =09=09=09=09=09=09<!-- Footer -->

    any ideas how to fix this? I tried adding the fix mentioned in this thread to my child theme’s function.php but it didn’t work. This started to happen for no reason, it was working fine. I also disable all plugins and it’s still not working.

    Hello All,
    in the email that customer receives after requesting a qoute, the HTML shows in the amount column <span class=”woocommerce-Price-amount amount”><span class=”woocommerce-Price-currencySymbol”>R</span>2,661,211.00</span>

    I am no coding expert and my knowledge is basic, and I too have done the most basic troubleshooting, deactivate plugins for conflict code, reactivate one by one. checked woocom mail setting and changed all to plain text and the back to HTML.
    http://www.soteriafiresa.com

Viewing 9 replies - 61 through 69 (of 69 total)
  • You must be logged in to reply to this topic.