Support » Plugin: WP Mail SMTP by WPForms » WooCommerce emails aren’t send when WP Mail SMTP is activated

  • Hi,

    I would like to use WP Mail SMTP for emails that are send through the contact form on my website. However, when I activate WP Mail SMTP, the WooCommerce order emails aren’t send to customers (I can check with WP Mail Log).

    How can I fix this?

    Greetings,
    Tess

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Slava Abakumov

    (@slaffik)

    Hi @tessvstaten,

    1. Are you using WooCommerce on a MultiSite? Latest version of WC and WP?
    2. Where WC is installed – on a root site or on a subsite?
    If you on a multisite: where is WP Mail SMTP installed – on a root site or on a subsite? 3. How have you configured WP Mail SMTP plugin (options in admin area or constants)? Latest version?

    Thread Starter tessvstaten

    (@tessvstaten)

    Hi,

    Thank you for your fast reply.

    1. I’m not using a MultiSite. I’m using the latest version of WC and WP.
    2. It is installed on a root site.

    Greetings,
    Tess

    Plugin Author Slava Abakumov

    (@slaffik)

    3. How have you configured WP Mail SMTP plugin (options in admin area or constants)? Latest version? Which mailer? Does test email work when WC activated?

    Thread Starter tessvstaten

    (@tessvstaten)

    What do you mean? I’ve followed the instructions and set up WP Mail SMTP with my host. They checked it.

    It’s the latest version although I’m not using it at the moment, because WooCommerce emails aren’t send when customers place an order and WP Mail SMTP is activated. I use Contact Form 7.

    So the problem is that when WP Mail SMTP is activated, customers don’t receive WooCommerce order emails.

    Plugin Author Slava Abakumov

    (@slaffik)

    You haven’t answered any of my questions in my previous message.

    An additional question: Are CF7 emails delivered when WP Mail SMTP activated?

    Thread Starter tessvstaten

    (@tessvstaten)

    You neither, because I asked you what you meant.

    Yes, when WP Mail SMTP is activated, CF7 mails are delivered.

    Plugin Author Slava Abakumov

    (@slaffik)

    I’m not sure how those questions cannot be understood.

    How have you configured WP Mail SMTP plugin (options in admin area or constants)?

    I meant how the plugin is configured. Did you use a mouse to click in plugin settings or code constants in wp-config.php?

    Latest version?

    Is the plugin the latest version? 1.3.3 as of now.

    Which mailer?

    Which mailer in the plugin settings is selected: http://cloud.supportally.com/9bf628e109ca

    Does test email work when WC activated?

    Does WP Mail SMTP test email work (is sent to you) when WooCommerce is activated?

    This is not working with latest WordPress and Woocommerce. It does not send out any emails. I am using GMAIL with authorized client key. It will send out test emails from the plugin just fine but the plugin will not not the actual woocommerce emails sent via a new order, or via the “email invoice” on the backend individual order screen.

    • This reply was modified 2 years, 5 months ago by webmaster1234.

    I am facing exact same issue.
    WP Mail SMTP test email works.
    Contact Form 7 email works.
    but WooCommerce Emails are not working 🙁

    Issue is resolved.
    at SMTP mail Plugin setting you need to check following option.

    *Force From Email*
    If checked, the From Email setting above will be used for all emails, ignoring values set by other plugins.

    Plugin Support Jess Quig

    (@jquigam)

    Thanks for sharing what ended up working for you, shantiwebsolution! I generally recommend checking that “Force From Email” unless you have a specific reason not to.

    (I can’t quite remember when this option was added, but possibly it didn’t exist when @tessvstaten originally posted this message)

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WooCommerce emails aren’t send when WP Mail SMTP is activated’ is closed to new replies.