Support » Plugins and Hacks » WooCommerce » woocommerce email notifications not working

woocommerce email notifications not working

  • Hi,

    I am facing a odd issue – the woocommerce email notifications sent to the customer for New Order Confirmation & to the Admin for New Order received have suddenly stopped working! The emails were being sent properly till a week back, now they dont seem to work, unless I go to “Woocommerce-Orders” & change the “Pending” status to “Processing”, after which the Confirmation Email is automatically sent to the Customer & to the Admin respectively.

    Which means, I would have to continuosly keep tracking the Orders from my Backend without which the customer would not get the Order confirmation email,even after making the payment, which would really mess up things & look unprofessional. The worst part is that I have already gone LIVE on my site & cant afford these issues any longer!

    Request your help as I need to get this sorted out ASAP – Anyone with a suggestion on how to get woocommerce emails to work properly again would be highly appreciated.



Viewing 15 replies - 1 through 15 (of 40 total)
  • I’d suggest looking at this –

    How to Replace WordPress Cron With A Real Cron Job

    I have the same trouble!
    any solution?

    Does anyone know if WooCommerce will track sent email invoices? There’s no confirmation message when you send email invoices to customers from the Order page.

    I had the same issue before going live with my site. But i used .htaccess for password protection while developing the site. But after I removed the password protection everything worked like a charm.

    This also happened to me and now i have two confirmation emails when i get an order, one from Woo and one a debug from my gateway. check to make sure your gateway didn’t have an update that broke this function.

    Sorry my english… i´m a brazilian guy

    I solved the mystery … go in the Woocommerce´s options emails and change the “Email Sender Options” to “wordpress@yourdomain.com” …its look like stupid but really work!

    Yuji you are a STAR! Spent all day trying to fix this issue 😀 Thank you.

    @yujisato: simple like that. Your solution works!!! Thanks!!

    @yujisato by “WordPress@yourdomain.com” are you referring to, for example, “wordpress@ldsmag.com” or do you mean literally change it to “wordpress@yourdomain.com”. I tried with the settings set to [ email redacted ] with no email upon trying a test order. What email address would it send the notification to with the email set to wordpress@yourdomain.com?

    I’m trying to get the emails to be sent to a gmail address where I previously had everything functioning perfectly fine, (i.e. an order is placed- order email is sent to customer and order notification is sent to admin at the gmail address) but for some reason it stopped working.

    Help would be appreciated. Thanks!

    @tproctor: it’s YOUR DOMAIN. Replace “yourdomain.com” with the name of your own domain.

    Here is a screenshot of my settings page in WooCommerce > Emails


    I have tried everything I can think of with no luck. I really need to get this working as it will simplify my workload exponentially.



    @tproctor: and that email address does really exists? Some servers will deny sending an email from an inexistent email address. you can configure an email forward or alias if you don’t want to add another email address to your email client software.

    You see those other links near the top of the page.

    New Orders | Processing Order | Completed Order | etc.,

    Each one of those needs to be enabled and setup properly.

    I spent a day fooling around with everything else before noticing that those were not set correctly. They are very easy to miss.

    In my case I was sending every email except Admin New Order emails, because the email address in that section was not set correctly.


    Thank you, jimlongo.
    I would have missed that. It also seems odd that you can only add email recipients in one place. Has anyone seen a plug-in that adds more versatility to the email moment?

    Still no luck, even with the email address set to an existing address:

    See here

    All tabs (new order, processing order, completed, etc.) are turned on, so that’s not the issue either.

    This is so frustrating!

    I have no idea what could be causing this to not function properly. It is even more of a killer because we’re in the middle of a sales campaign right now, so I can’t exactly go about turning things on/off store wise, etc. I just hope customers have been getting the emails!

    I have tried several test orders myself, and have received the payment confirmation email from our payment gateway Authorize.net, but noting at all from the Store regarding the order details etc. like I used to with a previous sales campaign we ran in April.

    I just spent close to 3 hours doing what could be done automatically if the emails were functioning properly, forwarding screenshots of every single order over to our shipping fulfillment house.

    Oi vey!

Viewing 15 replies - 1 through 15 (of 40 total)
  • The topic ‘woocommerce email notifications not working’ is closed to new replies.
Skip to toolbar