• Resolved k83uhse6v

    (@k83uhse6v)


    Hi,

    I have SMTP plugin on the website that works fine.

    However, Woocommerce doesn’t want to send emails using SMTP.

    I installed the WP Mail Logging Log plugin to check what is going on.

    It’s in the logs:
    could not initiate mail function

    I disabled all plugins except Woocommerce and SMTP, changed themes to the default, problem still exists.

    How to fix it or how to debug it?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Missy a11n

    (@m155y5)

    Automattic Happiness Engineer

    Hi @k83uhse6v

    There are a few possibilities here:

    – You may need to tweak some settings in your SMTP plugin (which one are you using?). What email service are you using and have you filled out all of your credentials/authentication information in the plugin?
    – Does the email you’ve set for WooCommerce emails in WooCommerce > Settings > Emails > Email sender options (from address) match what you’re using with the SMTP plugin?
    – If neither of the options don’t resolve the issue, you may need to contact your hosting provider for assistance as it could possibly be a setting on the server itself.

    Thread Starter k83uhse6v

    (@k83uhse6v)

    Hi @m155y5,

    Thank you for response.

    I tested it with Easy WP SMTP + mail account. Sends email to the store admin, but not to the customers.

    I tested with Mailpoet and their (your :)) email service. E-mails don’t arrive at all. WP Mail Logging Log plugin says:
    could not initiate mail function

    Does the email you’ve set for WooCommerce emails in WooCommerce > Settings > Emails > Email sender options (from address) match what you’re using with the SMTP plugin?

    Yes. The address is also authorized in the Mailpoet account.

    If neither of the options don’t resolve the issue, you may need to contact your hosting provider for assistance as it could possibly be a setting on the server itself.

    It’s me 🙂 I use a VPS. And yes, I have the sendmail feature disabled. However, this does not affect the SMTP plugins. I have other websites with WooCommerce on this server that send emails via SMTP without any problem. So the problem is related only to this WordPress / WooCommerce installation.

    • This reply was modified 3 years, 3 months ago by k83uhse6v.
    • This reply was modified 3 years, 3 months ago by k83uhse6v.
    Plugin Support Missy a11n

    (@m155y5)

    Automattic Happiness Engineer

    Hi @k83uhse6v

    Thank you for confirming all of that. Do you happen to have any fatal error logs in WooCommerce > Status > Logs?

    Thread Starter k83uhse6v

    (@k83uhse6v)

    Thanks for your answer and sorry I didn’t mark this topic as resolved.

    Basic configuration mistake in Mailpoet. Everything works.

    Thank you for your help and I will mark topics as solved in the future.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Woocommerce doesn’t want use SMTP.’ is closed to new replies.