WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] Woocommerce Description in Category Page (5 posts)

  1. ableweb
    Member
    Posted 1 year ago #

    Hi,

    I have incorporated my product description onto my category page so each product shows the description, price, variations and add to cart button. The problem I'm having is the description seems to cut off, I have tried to edit the <p> tag which changes size but it has no effect on the actual description text. I have also searched high and low through the woocommerce css and templates to try identify if there is any other tags controlling the description but have had no luck.

    This is the code I entered into my content-product.php

    <li <?php post_class( $classes ); ?> >

    <?php do_action( 'woocommerce_before_shop_loop_item' ); ?>

    <?php
    /**
    * woocommerce_before_shop_loop_item_title hook
    *
    * @hooked woocommerce_show_product_loop_sale_flash - 10
    * @hooked woocommerce_template_loop_product_thumbnail - 10
    */
    do_action( 'woocommerce_before_shop_loop_item_title' );
    ?>

    <h2 style="color: #666;"><?php the_title(); ?></h2>

    <p><?php the_content(); ?></p>

    <?php
    /**
    * woocommerce_after_shop_loop_item_title hook
    *
    * @hooked woocommerce_template_loop_price - 10
    */
    do_action( 'woocommerce_after_shop_loop_item_title' );
    ?>

    <?php do_action( 'woocommerce_after_shop_loop_item' ); ?>

    PLEASE HELP!

    Thanks in advance

    https://wordpress.org/plugins/woocommerce/

  2. Daniel Espinoza
    Member
    Posted 1 year ago #

    Post the URL of the page and it would be easier to offer assistance.

  3. ableweb
    Member
    Posted 1 year ago #

    Daniel thanks for your response but I found the issue, I was scanning through the css too much and seemed to have missed the obvious, I have resolved it now.
    The problem was the ul.products li p css tag that I was constantly overlooking, how embarrassing!

  4. ableweb
    Member
    Posted 1 year ago #

    Daniel thanks for your response but I found the issue, I was scanning through the css too much and seemed to have missed the obvious, I have resolved it now.
    The problem was the ul.products li p css tag that I was constantly overlooking, how embarrassing!

  5. Daniel Espinoza
    Member
    Posted 1 year ago #

    Glad it's sorted!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic