Support » Plugin: WooCommerce » WooCommerce database update running since 6 hours

  • Resolved bertelemanuel

    (@bertelemanuel)


    Today in the morning I´ve started the WooCommerce database update. Normally this is finished within 10 minutes.

    This time I wait since 6 hours and the database update is still running.

    In the WordPress Dashboard I still see the message “WooCommerce database update: WooCommerce updates the database in the background. The update of the database may take a while. Please have a little patience.”

    What can I do?
    Thanks for help.

Viewing 15 replies - 16 through 30 (of 32 total)
  • @freshlabs, I don’t really know what you mean by “headless shop”. Nothing, I think, has changed in our page except for the very annoying message.

    I started this thread 9 months ago. Today I´ve made the next woocommerce database update and now I have the same issue once again.

    There are 3 pending scheduled actions:

    ‘update_callback’ => ‘wc_update_390_move_maxmind_database’
    ‘update_callback’ => ‘wc_update_390_change_geolocation_database_update_cron’
    ‘update_callback’ => ‘wc_update_390_db_version’

    The option to run these pending actions manually isn´t available any more. 9 months ago I had this option, but today it isn´t available any more.

    What can I do now? Thanks for your support.

    arantzazu

    (@arantzazu)

    Hi,
    I have the same issue, the same pending scheduled actions and “run” link is missing.
    Is there anything we can do? Any help would be very appreciated.
    Thanks.

    Yuki

    (@yuklintang)

    the RUN button in Woocommerce Scheduled Actions is missing, it used to be there…. anyone can help me out? thanks so much!

    matrim

    (@matrim)

    Hello everyone,

    I found a fix to this issue but it requires some technical knowledge.
    You can use the WP-CLI tool to update woocommerce manually.

    Command is: wp wc update

    It worked flawlessly for me. Only thing to mention is that the scheduled actions still were present in the WP Backend. I just bulk-deleted them 😉

    More information on this topic:
    https://support.pagely.com/hc/en-us/articles/115003313251-Manually-Updating-Your-WooCommerce-Database-via-Command-Line

    Information on how to install and use wp-cli:
    https://www.sitepoint.com/wp-cli/

    I hope this helps some of you!

    p. s.
    Since I have some expercience with wp-cli, feel free to contact me if you have questions.

    • This reply was modified 4 months ago by matrim.
    matrim

    (@matrim)

    arantzazu

    (@arantzazu)

    Thank you so much matrim!!!

    Yuki

    (@yuklintang)

    Thank you matrim. I just want to know if this is a bug that woocommerce will fix it in the next update? to be honest I do not want to study yet another plugin to fix this.

    matrim

    (@matrim)

    @yuklintang

    For me it looks like a bug so I hope they are going to fix it. I’m just a web developer who had the same problem and I found a solution which I shared here.

    WP-CLI is not another WordPress plugin, it’s a command line interface which allows you to do various (awesome) things. But as mentioned before it requires technical knowledge like command line experience via SSH. If you’re not familiar with this I suggest you get in touch with your web hoster and ask for support by providing this link:
    https://support.pagely.com/hc/en-us/articles/115003313251-Manually-Updating-Your-WooCommerce-Database-via-Command-Line

    Unfortunately I’m not aware of another solution so far.

    Yuki

    (@yuklintang)

    Thanks so much for your time @matrim

    Hobby Factory

    (@robhoutkamp)

    Does anyone has un update of this issue. I’m facing the same problem. Database updates keeps pending for weeks.

    ofisierra

    (@ofisierra)

    If the files that do not update have to do with Geolocalization:
    This is most likely due to a setting in the WooCommerce plugin. Go to WooCommerce > Settings, scroll down and find Default customer location. Switching to any option other than Geolocate (with page caching support) will take care of the issue.

    In my case, I first had to go to a previous version of Woocommerce to do it.

    At this link I found an easier solution:

    3.61 Database update doesnt complete after 5 + hours

    Hello,

    I got this while updating the database:

    woocommerce_run_update_callback In afwachting

    ‘update_callback’ => ‘wc_update_390_move_maxmind_database’

    woocommerce-db-updates Niet-herhalend 2020-02-18 16:23:35 +0000
    (1 week 1 dag geleden)

    2020-02-18 16:23:35 +0000
    actie aangemaakt

    woocommerce_run_update_callback In afwachting

    ‘update_callback’ => ‘wc_update_390_change_geolocation_database_update_cron’

    woocommerce-db-updates Niet-herhalend 2020-02-18 16:23:36 +0000
    (1 week 1 dag geleden)

    2020-02-18 16:23:35 +0000
    actie aangemaakt

    woocommerce_run_update_callback In afwachting

    ‘update_callback’ => ‘wc_update_390_db_version’

    woocommerce-db-updates Niet-herhalend 2020-02-18 16:23:37 +0000
    (1 week 1 dag geleden)

    2020-02-18 16:23:35 +0000
    actie aangemaakt

    woocommerce_run_update_callback In afwachting

    ‘update_callback’ => ‘wc_update_390_move_maxmind_database’

    woocommerce-db-updates Niet-herhalend 2020-02-18 16:23:51 +0000
    (1 week 1 dag geleden)

    2020-02-18 16:23:51 +0000
    actie aangemaakt

    woocommerce_run_update_callback In afwachting

    ‘update_callback’ => ‘wc_update_390_change_geolocation_database_update_cron’

    woocommerce-db-updates Niet-herhalend 2020-02-18 16:23:52 +0000
    (1 week 1 dag geleden)

    2020-02-18 16:23:51 +0000
    actie aangemaakt

    woocommerce_run_update_callback In afwachting

    ‘update_callback’ => ‘wc_update_390_db_version’

    woocommerce-db-updates Niet-herhalend 2020-02-18 16:23:53 +0000
    (1 week 1 dag geleden)

    2020-02-18 16:23:51 +0000
    actie aangemaakt

    What do I have to do?

    Best regards,
    Timothy

    Just want to say, I had to remove my .htpasswd in order for this to work.
    I also do not have the manual “run” button by the way (Woo v4.0)

Viewing 15 replies - 16 through 30 (of 32 total)
  • You must be logged in to reply to this topic.