Support » Plugin: WooCommerce » WooCommerce database update running since 6 hours

  • Resolved bertelemanuel

    (@bertelemanuel)


    Today in the morning I´ve started the WooCommerce database update. Normally this is finished within 10 minutes.

    This time I wait since 6 hours and the database update is still running.

    In the WordPress Dashboard I still see the message “WooCommerce database update: WooCommerce updates the database in the background. The update of the database may take a while. Please have a little patience.”

    What can I do?
    Thanks for help.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Mike Jolley

    (@mikejolley)

    Can you go to Tools > Scheduled Actions > Pending and see what is left to run?

    You can run those tasks manually from there too.

    Thanks, that was helpful. I´ve runned the tasks manually.

    There is only one task which didn´t get in the status completed. This is: woocommerce_update_marketplace_suggestions

    When I run this task it´s still pending.

    The message about the WooCommerce database update is now gone. But now I have a bigger problem. My dashbord site is completely empty. When I click on dashboard, I have an empty white site. The same problem when I click on installed plugins. Here the site is also completely empty.

    Do you have a tip Mike?

    Plugin Author Mike Jolley

    (@mikejolley)

    @bertelemanuel When you did that, how many pending tasks where there left?

    No one else has reported a blank dashboard I’ve seen. Would it be possible to enable debug mode to see what shows up on the dashboard? https://codex.wordpress.org/Debugging_in_WordPress If there is an error, please paste it here.

    Only the Dashboard and the installed plugins pages are blank now. All the other admin sites are still working.

    In scheduled tasks it says Pending (2), but only “woocommerce_update_marketplace_suggestions” is pending. When I click here on run the message is “Successfully executed action: woocommerce_update_marketplace_suggestions”, but it still stays in Pending.

    Plugin Author Mike Jolley

    (@mikejolley)

    Thats fine, that one is recurring. I’m more interested in which ones you had to run manually before to get things working again.

    bertelemanuel

    (@bertelemanuel)

    I don´t know exactly because there were many tasks to run.

    Now I´ve enabled the debug mode. This is the error:

    Fatal error: Uncaught ActionScheduler_InvalidActionException: Action [2813] has invalid arguments. It cannot be JSON decoded to an array. in /home/www/wordpress/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_InvalidActionException.php:26 Stack trace: #0 /home/www/wordpress/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_wpPostStore.php(799): ActionScheduler_InvalidActionException::from_decoding_args(2813) #1 /home/www/wordpress/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_wpPostStore.php(135): ActionScheduler_wpPostStore->validate_args(NULL, 2813) #2 /home/www/wordpress/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_wpPostStore.php(118): ActionScheduler_wpPostStore->make_action_from_post(Object(WP_Post)) #3 /home/www/wordpress/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/functions.php(171): ActionScheduler_wpPostStore->fetch_a in /home/www/wordpress/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_InvalidActionException.php on line 26

    Plugin Author Mike Jolley

    (@mikejolley)

    Thats thats helpful. I’ve logged this here https://github.com/woocommerce/woocommerce/issues/23373

    You might be able to get things back by deleting post 2813 from the DB manually… sorry there isn’t an easier fix.

    When this is solved we’ll update https://github.com/woocommerce/woocommerce/issues/23373 with a patch and make sure it goes into 3.6.2.

    Thanks

    bertelemanuel

    (@bertelemanuel)

    Where can I find post 2813 in my FTP? Sorry I´m not an expert 😉

    Plugin Author Mike Jolley

    (@mikejolley)

    database, wp_posts table. See what row with ID 2813 contains. Your host may have PhpMyAdmin installed to do this but it is technical..

    bertelemanuel

    (@bertelemanuel)

    OK, I just phoned with my host. He explained me how I get in the PhpMyAdmin.
    I deleted the row with the ID 2813 and now everything works.

    Thank you very much 🙂

    Hello Mike Jolley,

    I’m having the same problem of the database update stalling in the Pending status. You say above “Can you go to Tools > Scheduled Actions > Pending and see what is left to run?
    You can run those tasks manually from there too.”

    I tried that and the only choice available to me under “Bulk Actions” is “Delete”. I see no way that I can force an update. Perhaps I’m looking in the wrong place? How do you manually update?

    Thank you,
    Alice in Oregon

    Okay, never fails. Ask someone for help, go back and look again and find the answer. It was “check each box under hook in turn, then press “Run”. Run or Cancel is just below the name of the hook. That did seem to clear them. I just went to check the site and it seems to be okay. The dashboard seems to be okay.

    I have the same issue, Woocommerce database update is running for several hours and there is failure. I use cloudways, managed cloud hosting. Please help.

    Hi!

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

    In this case, WordPress caught an error with one of your plugins, WooCommerce.

    First, visit your website (https://gheestore.in/) and check for any visible issues. Next, visit the page where the error was caught (https://gheestore.in/wp-admin/admin.php?page=wc-status&tab=action-scheduler&s=woocommerce_run_update&status=pending&row_action=run&row_id=23337&nonce=ade49d6a5c) and check for any visible issues.

    Please contact your host for assistance with investigating this issue further.

    If your site appears broken and you can’t access your dashboard normally, WordPress now has a special “recovery mode”. This lets you safely log in to your dashboard and investigate further.

    https://gheestore.in/wp-login.php?action=enter_recovery_mode&rm_token=wiBomMGMD1xywBxBTmhrGS&rm_key=dsd3Goo6LXHlAkcXfHTXil

    To keep your site safe, this link will expire in 1 day. Don’t worry about that, though: a new link will be emailed to you if the error occurs again after it expires.

    Error Details
    =============
    An error of type E_ERROR was caused in line 190 of the file /home/216388.cloudwaysapps.com/uvsdekhzcg/public_html/wp-content/plugins/woocommerce/includes/class-wc-install.php. Error message: Uncaught ArgumentCountError: Too few arguments to function WC_Install::run_update_callback(), 0 passed in /home/216388.cloudwaysapps.com/uvsdekhzcg/public_html/wp-includes/class-wp-hook.php on line 286 and exactly 1 expected in /home/216388.cloudwaysapps.com/uvsdekhzcg/public_html/wp-content/plugins/woocommerce/includes/class-wc-install.php:190
    Stack trace:
    #0 /home/216388.cloudwaysapps.com/uvsdekhzcg/public_html/wp-includes/class-wp-hook.php(286): WC_Install::run_update_callback()
    #1 /home/216388.cloudwaysapps.com/uvsdekhzcg/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array)
    #2 /home/216388.cloudwaysapps.com/uvsdekhzcg/public_html/wp-includes/plugin.php(531): WP_Hook->do_action(Array)
    #3 /home/216388.cloudwaysapps.com/uvsdekhzcg/public_html/wp-content/plugins/woocommerce/includes/libraries/action-scheduler/classes/ActionScheduler_Action.php(22): do_action_ref_array(‘woocommerce_run…’, Array)
    #4 /home/216388.cloudwaysapps.com/uvsdekhzcg/public_html/wp-content/plugins/woocommer

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.