Support » Plugin: WooCommerce » WooCommerce data update

  • at the top of my wordpress dashboard i have the following notice:

    WooCommerce data update – Your database is being updated in the background. Taking a while? Click here to run it now.

    i’ve waited at least 6 hrs and it’s still there. any ideas?

    
    ### WordPress Environment ###
    
    Home URL: http://www.kclwoods.com
    Site URL: http://www.kclwoods.com/20wp15
    WC Version: 3.1.2
    Log Directory Writable: ✔
    WP Version: 4.8.1
    WP Multisite: –
    WP Memory Limit: 256 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    
    ### Server Environment ###
    
    Server Info: Apache
    PHP Version: 5.6.27
    PHP Post Max Size: 8 MB
    PHP Time Limit: 30
    PHP Max Input Vars: 1000
    cURL Version: 7.38.0
    OpenSSL/1.0.1e
    
    SUHOSIN Installed: –
    MySQL Version: 5.6.35
    Max Upload Size: 8 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    
    ### Database ###
    
    WC Database Version: 3.1.1
    WC Database Prefix: wp_
    woocommerce_sessions: ✔
    woocommerce_api_keys: ✔
    woocommerce_attribute_taxonomies: ✔
    woocommerce_downloadable_product_permissions: ✔
    woocommerce_order_items: ✔
    woocommerce_order_itemmeta: ✔
    woocommerce_tax_rates: ✔
    woocommerce_tax_rate_locations: ✔
    woocommerce_shipping_zones: ✔
    woocommerce_shipping_zone_locations: ✔
    woocommerce_shipping_zone_methods: ✔
    woocommerce_payment_tokens: ✔
    woocommerce_payment_tokenmeta: ✔
    MaxMind GeoIP Database: ✔
    
    ### Security ###
    
    Secure connection (HTTPS): ❌Your store is not using HTTPS. Learn more about HTTPS and SSL Certificates.
    Hide errors from visitors: ✔
    
    ### Active Plugins (12) ###
    
    Child Theme Configurator: by Lilaea Media – 2.2.8.1
    Google Analytics for WordPress by MonsterInsights: by MonsterInsights – 6.2.2
    Jetpack by WordPress.com: by Automattic – 5.2.1
    Storefront Powerpack: by WooCommerce – 1.4.1
    WooCommerce Colors: by WooThemes – 1.0.6
    WooCommerce Services: by Automattic – 1.7.0
    WooCommerce USPS Shipping: by WooCommerce – 4.4.8
    WooCommerce: by Automattic – 3.1.2
    Wordfence Security: by Wordfence – 6.3.16
    Yoast SEO: by Team Yoast – 5.2
    WP Maintenance Mode: by Designmodo – 2.0.9
    WPS Hide Login: by Remy Perona for WPServeur – 1.1.7
    
    ### Settings ###
    
    API Enabled: ✔
    Force SSL: –
    Currency: USD ($)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    Taxonomies: Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)
    
    Taxonomies: Product Visibility: exclude-from-catalog (exclude-from-catalog)
    exclude-from-search (exclude-from-search)
    featured (featured)
    outofstock (outofstock)
    rated-1 (rated-1)
    rated-2 (rated-2)
    rated-3 (rated-3)
    rated-4 (rated-4)
    rated-5 (rated-5)
    
    ### WC Pages ###
    
    Shop base: #4 - /about-us/shop/
    Cart: #5 - /cart/
    Checkout: #6 - /checkout/
    My account: #7 - /my-account/
    
    ### Theme ###
    
    Name: Storefront Child v2 01/17
    Version: 2.1.7.1485639215
    Author URL: https://woocommerce.com/
    Child Theme: ✔
    Parent Theme Name: Storefront
    Parent Theme Version: 2.2.4
    Parent Theme Author URL: https://woocommerce.com/
    WooCommerce Support: ✔
    
    ### Templates ###
    
    Overrides: –
    

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • What happens when you click on Click here to run it now.?

    Thread Starter cw_mcdowwll

    (@cw_mcdowwll)

    it drops me in the woocommerce settings page. where i can make whatever changes and hit save.

    but while i’m in there it still says that message at the top of the screen and if i hit the save button it just says that my changes were saved but still shows that message.

    I have the same issue. The message is still there even after few days.

    Thread Starter cw_mcdowwll

    (@cw_mcdowwll)

    i’ve also noticed that the reported hard drive usage is increasing dramatically. as in space used in that account.

    Thread Starter cw_mcdowwll

    (@cw_mcdowwll)

    ok looks like the space issue was from an error_log in wp-admin.

    and my issue was a corrupt database which i resolved by editing my wp-config.php file from the root folder of my wordpress install and added

    define('WP_ALLOW_REPAIR', true);

    to the end of the file just before the if ( !defined('ABSPATH') ) line.

    then in the browser went to http://yoursite.com/wp-admin/maint/repair.php (of course i put in my domain name in the place of ‘yoursite.com’)

    and ran the database repair and then ran the database repair & optimize.

    went back to wordpress dashboard and ran the update again and the message went away.

    thanks for your time!

    We’re having the same issues on a site after a recent WC update. Repaired & optimized DB. No change. Cleared every cache server and browser side. No change. No debug messages when debug is turned on.

    Anyone else find a culprit? Thanks!

    Increasing memory worked for me:

    wp-config.php

    define( ‘WP_MEMORY_LIMIT’, ‘325M’ );

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WooCommerce data update’ is closed to new replies.