WordPress.org

Forums

WooCommerce - excelling eCommerce
Woocommerce Checkout Timeout problem (admin-ajax.php?action=woocommerce-checkout (15 posts)

  1. pplong
    Member
    Posted 1 year ago #

    Hi - I’m creating a WooCommerce site on WP3.8, MyStile theme, using latest version of WC 2.0.20, hosted on a VPS (I’ve used Linode and Digital Ocean, both with LEMP setup, similar problem on both).

    All was going just fine.

    Part way through creating the site, my checkout process seemed to stop working – when you click on the ‘place order’ button, the screen would ‘grey-out’ and the spinning timer icon would remain indefinitely. The order seems to be created OK in the back end, but the user is never taken to the order confirmation screen when the payment type is anything other than PayPal (more below).

    On delving deeper, I can see that I’m getting a 504 Gateway Timeout after 60s when the system is trying to post admin-ajax.php?action=woocommerce-checkout. I have increased the timeout value (just to check whether it would ever complete the process), and it still times out, even after 3 minutes. I am assuming that after the POST has timed out, the user will continue to see the ‘hanging’ screen regardless of how long you stare at it.

    Now, I’ve researched this, and seen some other threads relating to this problem, so I’ve tried a variety of things before posting this, including:

    - WP general settings – my WP URL and site URL match (i.e not cross-domain)
    - I’ve checked and increased my PHP memory allocation to 96Mb (originally 40Mb)
    - I’ve switched themes to twentythirteen, same problem
    - Force secure checkout is disabled
    - I’ve deactivated all plugins (including WC, but I obviously had to reactivate it to test), and I get the same behaviour. I’ve even created a completely clean WP/WC site (without any ‘unnecessary’ plugins) and I still get the same problem.
    - I get the same problems regardless of whether I’m placing the order as a logged-in user or not.

    The thing I find really peculiar is that I’ve now noticed that, when using PayPal as the payment method, the process works OK – I’m redirected to PayPal, can make the payment, and can then successfully come back to the ‘order confirmation’ screen. But whatever I do, I can’t make a ‘cheque’ or ‘BACS’ payment type work properly. I know it worked fine when I first created the test site, because I was using payment type ‘cheque’ to avoid repeated ‘test’ paypal transactions.

    As mentioned above, I’ve also tried the site on a brand new VPS slice (on Digital Ocean), to try to eliminate whether my other hosting was just too slow. Whilst the site as a whole is faster on a ‘dedicated’ VPS, the checkout problem with cheque/bacs order was the same.

    I’ve tried all sorts of things that I’ve seen on forums, and now I’m running out of ideas.

    If anyone has any insight on this, I’d be most grateful.
    Thank you

    http://wordpress.org/plugins/woocommerce/

  2. pplong
    Member
    Posted 1 year ago #

    Update on this issue in case anyone can help:

    I've discovered that the admin-ajax.php?action=woocommerce-checkout action WILL eventually complete if you increase the timeout value high enough. After approximately 4 minutes (on a server that is otherwise pretty fast), the order will complete. So it does work, it just takes foreeeever!

    I've looked at PHP logs, and no errors are created during this period.

    Other instances of posting admin-ajax.php work fine.

    All help appreciated.

  3. martongergo
    Member
    Posted 1 year ago #

    I have the same problem.

    woocommerce-checkout action on admin-ajax.php is taking 16 seconds to respond.

    Other Ajax requests work relatively fine.

    Any updates on this?

  4. pplong
    Member
    Posted 1 year ago #

    Maybe - through a LOT of trial and error, I think I've narrowed it down to one of the packages on my VPS - will be interesting to see if there's any commonality with yours:

    I was running sendmail on my VPS for outbound-only emails.

    I created a brand new virtual server (trying both nginx and apache), and the checkout process worked fine. As soon as I installed sendmail, it stopped working (or at least took upwards of 1 minute to process).

    I removed sendmail and configured exim4 instead, and the checkout works again. On reflection, maybe that makes sense, given that the system is triggering an email on order creation.

    Hope it helps - even if you haven't got exactly the same setup, it might be worth disabling emails to see if it makes a difference ...

  5. martongergo
    Member
    Posted 1 year ago #

    Hello,

    Thanks for your response.

    I'm still struggling with this.

    We are on a VPS using Postfix not Sendmail...also, to narrow the source of the issue even further down, we've tested with 3rd party e-mail sending (ManDrill) and with external SMTP sending.

    The issue still remains. Any ideas are welcome.

    Thanks

  6. pplong
    Member
    Posted 1 year ago #

    ah, frustrating. Is it feasible for you to disable the order notification email (even temporarily) to see if that makes a difference?

    I don't know if you already suspected the issue was email-related (you may have been ahead of me on that one, I think I got there through luck rather than good judgement) - but it might narrow the problem down further.

    For the record, changing from sendmail to exim seemed to resolve my issue across two sites using different web servers (nginx and apache), both on debian7.

    I guess you've been through all of the other 'fixes'? PHP memory limit etc?

  7. martongergo
    Member
    Posted 1 year ago #

    Hello,

    Here's what I've tried so far:

    1. Disable all plugins
    2. Change theme to twentytwelve
    3. Disable all e-mail notifications
    4. Changed to Mandrill as a 3rd party e-mail sender
    5. Tried changing all e-mail sending from WP to an external SMTP
    6. Fine tuned MySQL to see if that was the problem
    7. Deleted all custom functions from my functions.php which were extending WooCommerce
    8. Went through Woocommerce -> System status -> Tools and click each of those functions.
    9. Disabled jQuery from the theme I use.
    10. Stopped PostFix e-mail server
    11. Changed rewrite rules for NGINX.
    12. Tried changing shipping rules and payment options (nothing improved with any of the combinations)
    13. Raised the Memory Allocation in PHP-FCGI to 96,128,256,512 MB, but no improvement.
    14. Tried asking WooCommerce for PAYED support, but they are only giving this kind of support to customers who bought either a theme, plugin, etc. from them. (LAME)
    15. Prayed for a miracle.

    Anything else you've tried and it's not on this list?

    Thanks,

  8. pplong
    Member
    Posted 1 year ago #

    Nope, your list is longer than mine to be honest. And 15 didn't work for me either...
    I was prepared to pay for support too - I did consider buying the cheapest possible extension from WooCommerce just to get access to the support.

    Actually, there was something else I tried - there are a number of threads about admin-ajax.php being slow generally (not just on checkout) and its relationship to the Heartbeat API (where it appears to repeatedly post admin-ajax.php, thereby slowing everything else down).

    I did deregister the heartbeat API using information from .

    Otherwise, I think I'm out of ideas, sorry :-/

  9. pplong
    Member
    Posted 1 year ago #

    oops, that link was meant to be this one

    I can't write html either ;-)

  10. laurabfont
    Member
    Posted 1 year ago #

    have you found a solution for this? I do have a premium woocommerce plugin and was able to get support for this. Unfortunately, it has not proven to be helpful. I am really at a loss for what to do - it seems like a number of people have had this issue and nothing is working. My server is digitalocean 2GB Ram 30GB SSD Disk.

    I have tried:

    1) deregistering the heartbeat api
    2) increasing the memory limit (96M) and php memory limit (64M)
    3) my WP URL and site URL match
    4) switched to default wp theme (no change)
    5) same issue on http and https
    6) logged in and non logged in - issue persists

    woocommerce support replied with:
    "I've seen those but there is no concrete cause. Unless someone can give proof and solution that works, we can't move forward with this as we don't see this issue on our end."

    this is a huge issue for us as we are having customers complain that the checkout process is slow. they feel our site is broken. the site is only slow when they checkout using any payment method with woocommerce - non of the other pages are slow.

  11. pplong
    Member
    Posted 1 year ago #

    Hi laurabfont

    The issue for me appeared to be email-related. When I did a fresh, test install, the checkout process worked fine until the sendmail package was installed. Then, immediately, the checkout started timing out.

    So my personal fix was to remove sendmail and configure exim4 instead, and the checkout process worked fine. For the record, that's on a Digital Ocean droplet too, albeit lower spec than yours.

    It's a shot in the dark, but I wonder whether disabling your new order notification/customer email temporarily might be worth trying - in case it's the email trigger that's causing the problem.

    All the best
    Paul

  12. laurabfont
    Member
    Posted 1 year ago #

    i disabled the new order email notification and this SIGNIFICANTLY improved the load time. The load time is still not ideal but this is the only thing that has seemed to work. Please note, I did not disable customer email notifications, just the email that gets sent to me when a user submits an order. Easy fix and very helpful.

  13. pplong
    Member
    Posted 1 year ago #

    good, glad it helped - it's obviously not ideal to have to disable useful functionality though; I don't know what mail transfer agent you're using, but there might be some mileage in changing to another one - I found some decent documentation on the Digital Ocean knowledgebase on setting up exim, and now the performance of the checkout process is good, and all emails work.

  14. styledev
    Member
    Posted 1 year ago #

    Just wanted to throw in some more info. We were seeing this problem on our Digital Ocean one-click install of WordPress. Digital Ocean uses send mail and we had not moved the site over to a FQDN as we wanted to test first. I found the following fix:

    From: https://www.digitalocean.com/community/questions/sendmail-is-slow-to-send-mail
    update your "/etc/hosts" file: nano /etc/hosts
    to look like this: 127.0.0.1 localhost.localdomain localhost yourhostname
    Save and Then
    sudo service sendmail restart

  15. PhilipZheng
    Member
    Posted 11 months ago #

    It is WooFramework problem. After A/B testing, the new version WooFramework has 500 error of "admin-ajax.php?action=woocommerce-checkout". But, still stay old version 5.5.6 is working.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.