Support » Plugin: Yoast SEO » Woocommerce checkout takes over 1 minute to place an order when Yoast Is active.

  • Resolved wpbuffs

    (@jpwpbuffs)


    Having a default Theme, WordPress at the latest version, Learndash and Woocommerce updated, when I click on place order it takes over 1 minute to process the order and show the payment complete page.

    This only happens when Yoast is active, when the plugin is not active the issue does not happen, the same issue happens on other sites having Yoast, Learndash, and Woocommerce.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Suwash Kunwar

    (@suascat_wp)

    @jpwpbuffs We understand that this issue is frustrating, especially since it’s affecting your checkout page.

    We tried to reproduce the issue on our end, but we were unable to. Can you please check your Tools > Site Health and see if any errors being reported there?

    We would like some more information.
    – Are any JavaScript errors appearing in browser console?
    – Does the issue resolve if you clear your cache and cookies?
    – Does the issue resolve if you use a different browser such as Chrome or FireFox?
    – If you have any browser plugins/extensions, does disabling them resolve the issue?

    Thread Starter wpbuffs

    (@jpwpbuffs)

    Hi, Please find my responses below

    please check your Tools > Site Health and see if any errors being reported there? No
    – Are any JavaScript errors appearing in browser console? No
    – Does the issue resolve if you clear your cache and cookies? No
    – Does the issue resolve if you use a different browser such as Chrome or FireFox? No
    – If you have any browser plugins/extensions, does disabling them resolve the issue? No

    Please try to add this product to the cart and do the checkout https://jimmymaths.e.wpstage.net/product/5-challenging-questions-psle-math-free-online-course/ you will notice it takes a lot, when I deactivate Yoast it does not happen.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi @jpwpbuffs!

    We were able to reproduce the issue on your site. We added some data, see image: https://ibb.co/vBY2qLN. We then checked out and the page was spinning. See image: https://ibb.co/cCjGysG. It then timed out, see image: https://ibb.co/f8wNqTq.

    We would like some more information.

    1. Are all your non-Yoast plugins and themes also updated?

    2. If you go to SEO-General-Features and disable the Rest API endpoint, does the issue resolve?

    3. Can you confirm your server has all the right requirements?  If you are not sure, speak to your host provider. They may need to increase the PHP memory by doubling or tripling it. This guide explains more: https://kb.yoast.com/kb/plugin-requirements/.

    Thread Starter wpbuffs

    (@jpwpbuffs)

    Hi, Please see my responses below

    1. Are all your non-Yoast plugins and themes also updated? Yes, at least the active ones which are, Learndash, Woocommerce, Yoast.

    2. If you go to SEO-General-Features and disable the Rest API endpoint, does the issue resolve? No, it doesn’t resolve the issue.

    3. Can you confirm your server has all the right requirements? If you are not sure, speak to your host provider. They may need to increase the PHP memory by doubling or tripling it. This guide explains more: https://kb.yoast.com/kb/plugin-requirements/.
    Yes, the server meets the requirements, we can have all the plugins running without any issue, the issue only happens when activating Yoast.

    Plugin Support Pcosta88

    (@pcosta88)

    Hi @jpwpbuffs!

    To clarify, does the issue still only if you are using a default theme, Yoast v16.0.2, WordPress v5.7, and with Yoast, WooCommerce, and LearnDash as the only plugins active?

    If so, based on the information you provided, we expect this to be an issue. We’re actively using the bug tracking on our GitHub repository so your best next step would be to create a new issue for our developers at https://github.com/Yoast/wordpress-seo/issues/new. They are monitored by our developers so there is good chance you can expect some kind of reply. You will need an account to create a new issue. If this is your first bug report, please check out: https://kb.yoast.com/kb/how-to-write-a-good-bug-report/.

    Be sure in your report to link back to this forum.

    Thread Starter wpbuffs

    (@jpwpbuffs)

    Hi @pcosta88

    It happens with any theme, Woocommerce, and Learndash, a default theme is being used to troubleshoot.

    Github is not allowing me to pass the registration page for some reason. Any other way to report this bug?

    Plugin Support devnihil

    (@devnihil)

    @jpwpbuffs You would need to log into GitHub in order to be able to submit a bug report. If you don’t yet have an account yet with GitHub you can create one here.

    Plugin Support devnihil

    (@devnihil)

    We are going ahead and marking this issue as resolved due to inactivity. If you require any further assistance please create a new issue.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Woocommerce checkout takes over 1 minute to place an order when Yoast Is active.’ is closed to new replies.