Support » Plugin: WooCommerce » Woocommerce Checkout infinite spinning icon

  • I’m having issues on Woo Commerce checkout page where there is infinite spinning icon stays there. Site hosted on Nginx virtual server. Woo commerce version is 3.2.1.

    I have searched o forums and people had solved their issues either by increasing php memory or some css tricks.

    Chrome Console shown these errors:

    Failed to load resource: the server responded with a status of 405 (Not Allowed)
    /?wc-ajax=update_order_review 
    Failed to load resource: the server responded with a status of 405 (Not Allowed)/?wc-ajax=get_refreshed_fragments

    What I have tried to solve:

  • Increased memory to 128M.

    Disabled all other plugins, even disabled and enabled Woo commerce plugin too.

    Disabled cache.

    Disabled Nginx redirect force to https.

    Tried using another theme, also tried default simple theme.

    In general settings, everything looks ok.

    Woocommerce status shows no errors.

  • Still looking for solution..

    Any solution/idea?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Subscribed as I have same problem and can’t upgrade from WC 3.1+

    Plugin Author Mike Jolley

    (@mikejolley)

    Does the same error occur if you go to your homepage + /?wc-ajax=get_refreshed_fragments directly? The host may be able to advise here. I’ve seen htaccess rules do it so far.

    filehomes

    (@filehomes)

    When I do this https://mydomain.com/?wc-ajax=get_refreshed_fragments it just shows homepage.

    For the try, I install wordpress on my same server on another domain, installed woocommerce and it was working flawlessly. So issue related to specific wordpress and not to server.

    filehomes

    (@filehomes)

    /** Disable Ajax Call from WooCommerce added in functions.php*/
    add_action( 'wp_enqueue_scripts', 'dequeue_woocommerce_cart_fragments', 11); 
    function dequeue_woocommerce_cart_fragments() { if (is_front_page()) wp_dequeue_script('wc-cart-fragments'); }
    function disable_checkout_script(){
    wp_dequeue_script( 'wc-checkout' );
    }
    add_action( 'wp_enqueue_scripts', 'disable_checkout_script' );

    I used above code to disable ajax on checkout page. However there is checkbox on my site when checked it add additional prices and without ajax it do not update additional prices on checkout page but on PayPal it shows additional.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Woocommerce Checkout infinite spinning icon’ is closed to new replies.