Support » Plugin: PHPEnkoder » WooCommerce Checkout conflict

  • Resolved hughpryorartist

    (@crimelovingfunster)


    My WooCommerce checkout page started dropping off the screen after a second of being loaded up and leaving an email address. On inspection in the browser there was this error:

    VM394:8 Uncaught TypeError: Cannot read property ‘parentNode’ of null
    followed by gobbledygook.

    I deactivated all my plug ins which fixed the problem, then reintroduced them one by one, and the problem started happening again when I reintroduced PHP Enkoder.

    I’ve always used PHP Enkoder!
    I don’t want to not use it because I’m sure it’s been keeping spammers away for me for over a decade and I’ve never had any other problems with it.

    If you can look into the problem I’d be a very happy customer – I could reactivate it to show you what the problem is.

    All the best,

    Hugh Pryor

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author michael_greenberg

    (@michael_greenberg)

    Hmm… can you temporarily put up a version of the site with PHPEnkoder running? It’s hard to tell where it would go wrong, though there seem to be a couple of @ signs that might confuse it…

    Thread Starter hughpryorartist

    (@crimelovingfunster)

    OK – I’ve reactivated it. Go to https://www.hughpryor.co.uk/prints/
    Click “Add to Basket” on any of the prints
    Click “View Basket” button which pops up
    On the woocommerce_basket page click “Proceed to checkout”
    On the woocommerce-checkout page the checkout loads up and then drops off the screen and leaves my email link.

    Please let me know when you’ve had a look so I can put the shop back to normal. (I’m not receiving a lot traffic at the moment…)

    Plugin Author michael_greenberg

    (@michael_greenberg)

    Okay, I’ve taken a look, so feel free to change it back. It’s hard to see what the conflict is, since checkout.js has been minified and isn’t exactly the smallest bit of code.

    I think the simplest thing to do is to disable PHP Enkoder on that checkout page. (I doubt it will have material impact on what spam you get, since it’s pretty far in.) If WooCommerce has an explicit page, all you need to do is write the [noenkode] shortcode at the top of the page. If it’s a PHP file (probably in wp-content/woocommerce-checkout/index.php), you can manually edit the PHP to turn off PHPEnkoder by calling ‘enkoder_unregister_filters()’ after requiring/importing the appropriate WordPress headers. Please let me know if that works!

    Thread Starter hughpryorartist

    (@crimelovingfunster)

    Thanks for checking it out.
    No joy with the [noenkode] as suggested.
    I was unable to find the corresponding .php file for the checkout page so couldn’t manually edit it – I guess the page is generated from the database.
    I tried the “Plugin Organiser” plugin and disabled enkoder for that page and still no joy… The [enkoder] tags show up on the page so it’s clearly switching off the plugin on that particular page. The conflict must be happening on a different page…
    Anyways in the mean time I’m using the javascript generated on the hivelogic site – unless you have any other suggestions?

    All the best,

    Hugh

    Plugin Author michael_greenberg

    (@michael_greenberg)

    Unfortunately not—sorry to be unhelpful! 🙁 It might be worth raising the issue with the WooCommerce folks, since they’ll atleast be able to point you to the part of the code that’s generating that page.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WooCommerce Checkout conflict’ is closed to new replies.