Support » Plugin: Afterpay Gateway for WooCommerce » Woocommerce Blocks compatibility

  • Hi – just wanting to check the status of the Afterpay gateway with the WooCommerce Blocks plugin: https://wordpress.org/plugins/woo-gutenberg-products-block/

    From a trial on a staging site, it doesn’t look like your payment gateway is compatible with the Woocommerce Blocks checkout – just doesn’t appear despite being active and showing in the preview on the blocks editing page.

    Can you confirm this?

    You don’t appear on the compatibility list, but you’re also not on the list of know incompatibles either. https://woocommerce.com/document/cart-checkout-blocks-support-status/

    Be great to see the plugin compatible with WC Blocks which creates a great checkout experience and I imagine will become the standard checkout as time goes on.

    Thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Afterpay

    (@afterpayit)

    Hi @bob33,

    Thank you for your message.

    The Afterpay Gateway for WooCommerce should be compatible with WooCommerce Blocks at checkout. As it is not appearing on the site, the engineering team would like to assist with an investigation. To facilitate this please submit a support request including a link to this post using the following web form: https://help.afterpay.com/hc/requests/new?ticket_form_id=193406

    Thank you.

    Thread Starter BobFest

    (@bob33)

    hi @afterpayit

    I’m pursuing the ticket, however, what I’d really just like to know if whether your gateway has actually been tested in your own development environment and confirmed to work with Woocommerce Blocks.

    If it has then perhaps the best way forward for both of us and for any future inquiries on this issue might be for you to liaise with Woocommerce and get on the official list of gateways that are confirmed to work with Woocommerce Blocks as per the link I shared in the original post above.

    That would probably remove any doubt or confusion around the issue.

    Plugin Author Afterpay

    (@afterpayit)

    Hi @bob33,

    Again, thank you for the feedback.

    To answer your question, yes the gateway has been tested in local environments by the engineering team. Given the nature of WordPress / WooCommerce and the many different combinations of configurations, themes and plugins, compatibility with every installation cannot be guaranteed.

    On the point of being added to the list of block compatible gateways, the team are investigating this internally. Again, the feedback around that is appreciated and validates prioritising this.

    Thank you.

    Thread Starter BobFest

    (@bob33)

    Hi @afterpayit

    Thanks for the follow up. I’ve shared my configuration (via WC system report) with your engineers.

    Look forward to seeing Afterpay on the WooCommerce Blocks compatibility list!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.