Support » Plugin: WooCommerce » WooCommerce Autocomplete PayPal Order for physical shipping

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mike Jolley

    (@mikejolley)

    https://docs.woothemes.com/document/woocommerce-order-status-control/ looks like it will do it – but you’d need to set it to ‘all orders’.

    That said, if these are real orders, the order should be processing, otherwise you’re going to forget to fulfil things.

    wpforum

    (@wordpressorgforum)

    I do not see the options to set it to ‘all orders’ in WooCommerce > Settings > General (in the WordPress admin).

    In the Woocommerce on the WordPress site it show “IPN payment completed”. Great! But in https://www.sandbox.paypal.com/home – the PayPal support buyer account says “pending” and in the PayPal support facilitator account it says ” capture”.

    I reviewed and did the following.

    https://docs.woothemes.com/document/paypal-standard/#section-9

    Debugging IPN issues
    The below steps can be taken if IPN is not updating your orders. Whilst working on these problems you may want to prevent pending (unpaid) orders cancelling automatically so you have a chance to manually confirm payment without IPN. To do this, go to WooCommerce > Settings > Products > Inventory and set the “Hold Stock (minutes)” option to nothing (leave the field empty).

    Check Email Addresses
    Check that the Email Address in the PayPal gateway settings matches the email address passed back by IPN. Use your primary email address for your PayPal account. They need to match.
    Failure to do so will cause the IPN response to be rejected. This could result in orders remaining on hold or not completing.

    Plugin Author Mike Jolley

    (@mikejolley)

    The setting is not there by default. Order status control is a plugin.

    Processing is the correct default status after IPN/payment.

    wpforum

    (@wordpressorgforum)

    Where can I get the Order status control plugin? Will the payment is “completed” automatically in Woocommerce and PayPal after I add this?

    Currently the order is “complete” in woocommerce, and appears “pending” in the PayPal buyer account and “capture” in the Paypal facilitator account in Paypal Sandbox.

    Plugin Author Mike Jolley

    (@mikejolley)

    If its pending in PayPal, 1) in settings ensure it’s set to capture, not authorize, and 2) in the paypal account ensure its set to auto accept in your currency.

    wpforum

    (@wordpressorgforum)

    Thanks Mike. You’re a genius!

    I went to Woocommerce > Settings > Checkout > PayPal > Payment Action > Change it from Authorzie to Capture.
    And in Woocommerce > Orders > it says IPN payment completed.

    In the Sandbox test buyer and test facilitator’s Test Store Payment status both say Completed.

    Where would I go in the Developer (or real account) to ensure its set to auto accept in your currency. Since this purchase was with the Sandbox account from a US account to a US client there was not a problem.

    So does that means everything is working fine? can we switch to the real account from the sandbox account? Thanks again.

    Plugin Author Mike Jolley

    (@mikejolley)

    It’s usually fine by default if you only accept USD.

    wpforum

    (@wordpressorgforum)

    Thanks again.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WooCommerce Autocomplete PayPal Order for physical shipping’ is closed to new replies.