Support » Plugin: Printful Integration for WooCommerce » * WooCommerce authentication URL access=> FAIL

  • I keep getting an API error from Printful stating that

    “Hey! Something went wrong with the sync.
    Last sync error: Error: Invalid response from your WooCommerce store. Please make sure your site is working and no plugins are blocking WooCommerce API access. Try to refresh data. If error persists, contact customer support.”

    I’ve contact Printful customer support and they say my hosting provider is blocking the API connection.
    I contact my hosting provider, they check mod_security and whitelist errors, but cannot find any other blocks.

    Additionally this is a WordPress Multisite. One of the sites under this works with Printful on the same hosting just fine, but the primary does not.

    In WordPress, within the Printful settings under the ‘Status’ tab. I can see this error:

    Name:
    WooCommerce authentication URL access

    Description:
    Printful needs access to WooCommerce API authorize page. This sometimes may get blocked due to hosts having unnecessarily intrusive security checks in place that prevent WooCommerce API authentication from working (for example mod_security rule #1234234). If this check fails, you will not be able authorize Printful app.

    Status:
    FAIL`

    `##### Printful Checklist #####
    * Connection to Printful API => OK
    * Printful API key is set => OK
    * WordPress Permalinks => OK
    * WordPress version => OK
    * WooCommerce Webhooks => OK
    * WooCommerce API keys are set => OK
    * WooCommerce authentication URL access=> FAIL
    * WordPress remote requests => OK
    * WordPress Site URL => OK
    * Recent store sync errors => OK
    * Write permissions => OK
    * PHP memory limit => OK
    * PHP script time limit => OK

    ##### Printful Last Sync’s #####

    ##### Environment #####
    * home_url => https://(hidden for security reasons)
    * site_url => https://(hidden for security reasons)
    * version => 6.7.0
    * log_directory => /home/(hidden for security reasons)/public_html/wp-content/uploads/wc-logs/
    * wp_version => 6.0.1
    * language => en
    * server_info => Apache
    * php_version => 7.4.30
    * curl_version => 7.71.0, OpenSSL/1.1.1d
    * mysql_version => 5.7.38
    * mysql_version_string => 5.7.38-cll-lve
    * default_timezone => UTC

    ##### Database #####
    * wc_database_version => 6.7.0
    * database_prefix => wp_
    * maxmind_geoip_database =>

    ##### Active Plugins #####
    * Printful Integration for WooCommerce (2.1.34)
    * WooCommerce (6.7.0)
    * Akismet Anti-Spam (5.0)
    * Classic Editor (1.6.2)
    * Printful Integration for WooCommerce (2.1.34)
    * WooCommerce (6.7.0)

    ##### Theme #####
    * name => Magazine 7
    * version => 2.0.0
    * version_latest => 2.0.0
    * author_url => https://www.afthemes.com/
    * parent_name =>
    * parent_version =>
    * parent_version_latest =>
    * parent_author_url =>

    ##### WooCommerce settings #####
    * currency => USD
    * currency_symbol => $
    * currency_position => left
    * thousand_separator => ,
    * decimal_separator => .
    * woocommerce_com_connected => yes

    recapping the concern.

    My main issue is this: “WooCommerce authentication URL access” what am I missing that hosting support and Printful are not finding. How can I make “* WooCommerce authentication URL access=> FAIL” become an “OK” and connect to Printul successfully?

Viewing 1 replies (of 1 total)
  • Plugin Support katherineprintful

    (@katherineprintful)

    Hi! As much as we’d like to help, we can’t see what exactly is blocking the connection and access from our side. What we know is that this error usually means that something on your server’s side is creating connection issues. It might be an unsupported plugin, server issues, or a variety of other problems. But it truly can’t be seen from our side.
    I’d advise reaching out to your hosting provider again to see if they can assist you further.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.