WordPress.org

Support

Support » Plugins and Hacks » WooCommerce Admin Widgets freeze the Admin Dashboard

WooCommerce Admin Widgets freeze the Admin Dashboard

  • As soon as i activate the Woocommerce Plugin ALL Admin Widgets are not Drag&Dropable nor editable.

    When i deactivate WooCommerce all other Admin Widgets are working normal.

    The Chrome Console tells me the following:

    Uncaught TypeError: Cannot set property 'w' of undefined jquery.flot.resize.min.js?ver=1.0:1
    a jquery.flot.resize.min.js?ver=1.0:1
    x.event.dispatch load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:5
    v.handle load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:5
    x.event.trigger load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:5
    e.event.trigger load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:10
    (anonymous function) load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:5
    x.extend.each load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:4
    x.fn.x.each load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:4
    x.fn.extend.trigger load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:5
    x.fn.(anonymous function) load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:6
    (anonymous function) dashboard_sales.min.js?ver=1.0:1
    c load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:4
    p.fireWith load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:4
    x.extend.ready load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:4
    q load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,thickbox,utils,j…5,plupload-f&load%5B%5D=lash,plupload-silverlight,plupload-html4&ver=3.6:4

    When i click on the Options Tab (upper right corner) i get

    Uncaught ReferenceError: stopme is not defined
    (anonymous function)

    http://wordpress.org/plugins/woocommerce/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Roy Ho

    @splashingpixelscom

    You should first test by turning off all plugins except WooCommerce and see if that fixes your issue.

    nlozovan

    @nlozovan

    Same here. After installing WooCommerce – same error, same issues on board. Have anyone a solution to this?

    Hi,
    As splashingpixels said, the best way to isolate js errors is to do the inactivate dance – change the theme to 2012, deactivate all but woo, test, add 1 back, test, etc…

    I’m experiencing the same issue after installing WooCommerce. When I deactivate WooCommerce everything works fine, when activated that javascript error appears on dashboard load and breaks the dropdown menus, screen options, help and draggable widgets.

    Hi Guys,

    I can confirm that I deactivated all of my plugins except for WooCommerce and the issue was still present. Any idea’s on how to fix this?

    Thanks,
    Tristan

    Same issue, never seen it before, just installed WooCommerce and it breaks the dashboard.

    Here is a bit more information on my setup, in case there might be some similarities.

    Theme: Builder (http://themeforest.net/item/builder-responsive-multipurpose-theme/3596009?ref=OrangeIdea) – using child theme
    Hosting Providers: http://wpengine.com/

    This is happening for me with my own custom theme on localhost. Same error when I switch to the Twenty Fourteen theme.

    The issue’s clearly with WooCommerce. Anyone out there?

    Can you both confirm that you’ve tested with all plugins deactivated except woo and with a default WP theme (2012-14) active…

    Haha, seems to be a clash with one of my plugins here :-/

    http://wordpress.org/plugins/developers-custom-fields/

    I’ve had a good look and can’t see any obvious part of the admin JS code that might cause the issue. But my scripts should be better targetted – they’re not necessary on the dashboard anyway. Do let me know if you find anything specific in debugging, but I’ll try and find time to update my plugin to target the script enqueueing better – hopefully this will fix things.

    Tristan, are you using the DCF plugin?

    Hi Guys,

    Steve: No I am not using that particular plugin but am using Advanced Custom Fields – http://www.advancedcustomfields.com/

    Varktech: I have not actually tried to switch back to the default WP theme, I will do that once I get a chance!

    Thanks,
    Tristan

    I guess if the issue is also happening with other plugins, it’d be simplest to fix the clash at the WooCommerce end if possible. I’ve added an issue to my issue list:

    https://github.com/gyrus/WordPress-Developers-Custom-Fields/issues/27

    Even if WooCommerce fix things at their end, it’ll be a good idea when I get time to target my scripts better.

    I’m not sure if it’s the better script targetting in my Developer’s Custom Fields, or a fix in WooCommerce, but FTR there’s no longer a JS clash with the current versions of these plugins (0.9.1 and 2.1.10 respectively).

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WooCommerce Admin Widgets freeze the Admin Dashboard’ is closed to new replies.