Support » Plugin: WooCommerce » Woocommerce 3.2.4 – Product Variations do not save – Variations Revert to Defaul

  • Resolved bryanr18lowe

    (@bryanr18lowe)


    Hello,

    I have many products and have been able to successfully set up product variations for all of them.

    Post update of Woocommerce, my product variations will not save. They revert back to “Any …. ” in each prospective drop down menu for what I have created as Color or Pattern.

    I have switched themes to use 2017 and the problem still occurs. I have increased the max_input_vars in my php.ini file and the problem still occurs.

    I’m hopeful you could help me out!

    Best,

    Bryan

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Support Stuart Duff – a11n

    (@stuartduff)

    Automattic Happiness Engineer

    Hi Bryan,

    Cross testing for you using the latest version of WooCommerce on an install which has been updating all product variations which I added or edited are saving and that data is being correctly displayed on the products which they were created for. I’m also not seeing any other reports of any similar behaviour from users for the latest version of WooCommerce which would isolate this to only your install at the moment.

    I would first check that your WC Version number matches the WC Database Version from WooCommerce > Status and both numbers should be the same.

    If both numbers are the same I would enable WP DEBUG on your site to see if there are any error messages being logged within that file.

    https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging

    If there are no error messages within the debug log file that identify why you are experiencing this behaviour it could be a plugin conflict of some kind. The quickest way to test that is to disable all plugins leaving only WooCommerce activated and also temporarily change to Twenty Seventeen again. Once you have your site configured like this try adding or editing variations and see if the behaviour persists.

    There are other people having the same issue. Check the trouble tickets… other people are reporting the same error: https://wordpress.org/support/topic/3-2-4-variations-not-setting/

    I have noticed the problem on multiple sites I manage. This problem does not occur with previously entered variations, but only with new entries and not always predictable what product entry will incur the error.

    Just like bryanr18lowe, I have disabled all plugins and reverted to 2017 theme as a test, but the WooCommerce Variations selections fails intermittently since upgrading to Woocommerce 3.2.4. Fails in the sense that in some cases, when saving the attributes chosen, a unspecified number of variations will revert to “Any Options…” Combine this with the problem that from the user side, the images will not load according to the selected option or one option will get hung and no longer show the other options including the correct price. Very messed up. There is a identifiable disconnect between saving the attributes and the edits actually saving to the database. The data streams seems to become scrambled.

    I have performed all the typical tests. Those noted above, combined with verifying Memory Limit set to 256MB, PHP 5.6.32, MySQL 5.6.38, PHP max input vars: 3000. No cache installed. WC database same version as WC install: 4.9. Dedicated server with 1GIG network node, SSD drive. Everything is in order. I have tried editing from Chrome, Firefox and Firefox Developer, same failure. Define(‘WP_DEBUG’, True) does not reveal anything. I am very skilled on CMS frameworks and ecommerce, but there is something intermittently wrong with the new WooCommerce release when it comes to variations. A visual review of the database and each entry does not reveal any errors. The data is added correctly in the database, but does not feed correctly back into WooCommerce.

    I would provide my login credentials to any Automattic developer who would assist with this issue. The website build in progress cannot be viewed because it is behind a SeedProd Coming Soon Page Pro, never-the-less admin access is required to replicate the bugs. I have a product post identified that will prove the problem exists.

    Thanks Inndesign for your detailed response… I too have been having problems with this issue. Everything has been fine up until this latest update. I have tried disabling all plugins and changing theme but still the same issue. Incredibly frustrating… I hope Automattic can resolve this soon.

    Also see this support thread: https://wordpress.org/support/topic/unable-to-create-more-than-one-variation-since-upgrade/ More than one user on the thread reports the problem, but Automattic keeps offing the issue as non-existent because they can’t replicate it. The key word is intermittent… the problem is real!

    Having the same issue here. Cannot create new variations on products. Wish they would issue a fix for this. It is crippling my site.

    Automattic WooCommerce release 3.2.5 – 2017-11-22

    Fix – WordPress 4.9 – Fix an issue saving variation attributes on new products and with attributes containing slashes.

    Uhhh. nope. The problem still exists! Variations still does not work right. Same exact problem still exists.

    Come on Automattic, gain some qualified developers. This needs fixed!

    Fix this problem pleeeease. The new update not fix it.

    Plugin Support Hannah S.L. a11n

    (@fernashes)

    Automattic Happiness Engineer

    Hey there! As @stuartduff mentioned above, we aren’t able to replicate this on our end – we test on sites which only have WooCommerce and a default theme enabled, so the variables are minimal, while production sites are far more complicated.

    If you can set up a staging site, only enable WooCommerce and a default theme such as Twenty Seventeen, and then show us the issue, I’d be happy to take a closer look for you.

    Please fix this… This is getting beyond a joke now!

    The problem hasn’t a thing to do with production environment @fernashes. If that was true, it would not be possible to still have problems after all plugins are disabled and the WordPress theme 2017 selected. Plus every other user affected has robotically conformed to the same elimination ritual without any effective results.

    I have setup a temp site with the exact same build that has variable items I can point to as problematic. You can do anything you want to the build, where it is a clone of the working site. I will delete it after you are done proving the error.

    Please delete this login after taking note:

    https://wpbuild36.com/wp-login.php
    Username: admin
    Password: VariablesBuggy

    The item to review is located at: https://wpbuild36.com/wp-admin/post.php?post=1157&action=edit

    Click on Variations tab, then click on #1172 and select “Battery Charger”. Click on #1170 and select “Extra Battery”. Click on #1169 and select “Go-Pro Camera Housing”. Now click “Save Changes”. It will revert back to “Any Options…” I have tried deleting the variation and redoing them, nothing works.

    Next, review the same item user side at: https://wpbuild36.com/product/hooker-electric-gopro-housing/. You can chose different options, and the image nor the prices change. Very screwed up!

    Same with this one: https://wpbuild36.com/wp-admin/post.php?post=1142&action=edit #1149 cannot be saved as “Standard 8 Foot”.

    The variations added under WooCommerce 3.2.3 are fine. On another site I tried to add some additional variations to previous items created under 3.2.3 but after updating to 3.2.5, they to fail.

    So there you have it: Proof. No more denial by Automattic to say a variations bug doesn’t exist. When multiple users replicate the same error, it is no longer a case of one user with an isolated problem.

    • This reply was modified 4 years, 2 months ago by Inndesign.

    Thanks for your tenacity Inndesign… Please Automattic, will you sit up and take notice!

    @inndesign
    I don’t work for WooCommerce. Thank you for setting up the test environment. I can see there is corruption in the two variable products that you mention and they do not work properly. There have other been problems posted on the forum where the cause has been corruption in a variable product, for various WC versions, but in perspective these instances have been very rare given the number of installs there are out there. Infrequent random corruption can be difficult to debug.

    I was able to set up a similar variable product from scratch that worked fine. Regarding the two corrupted products, the fix was fairly simple, find the product in the list of products and click the duplicate link. The corruption did not carry over into the duplicate product. The next step would have been to delete the original product and remove the “(Copy)” from the title of the duplicate and from its permalink. However I have left the corrupted products in place for others to investigate.

    I have multiple variations failures across multiple sites @lorro. I have deleted and recreated variations over and over with similar results, including duplicating. With the rash of users reporting this problem, it is not rare or isolated problem as of current. I too had experience past variations issues, but they were always easily resolved.

    What was provided above was merely two examples. Please let Automattic developers resolve the problem correctly, which subsequently arose after the release of WooCommerce 3.2.4.

    • This reply was modified 4 years, 2 months ago by Inndesign.

    When I review the database via phpMyAdmin, I can see a potential problem @fernashes. I first ran “Check Table” to assure no corruption. There was none. All the below was done on the working site, not the clone site.

    I personally like using the Duplicate Post plugin, version 3.2 By Enrico Battocchi which may not be a problem. However, when reviewing the database, I noticed under let’s say “GoPro Underwater Housing” the “post_name” commercial-grade-harpoon-2, commercial-grade-harpoon-2-3, commercial-grade-harpoon-2-3-2 for each GoPro Underwater Housing variation. While the slugs should read “gopro-underwater-housing” that should not be a problem, but it might be with the latest WooCommerce?

    I first deleted the variations and then the whole post of the two noted products, and finally deleted permanently to assure total database purging. I then created a new item post for each, without duplicating a previous product post and it resulted in a dependable working post in each case. Again, I have used this cloning method for many sites for a few years, but apparently something changed in WooCommerce that doesn’t allow working predictably with duplicated posts. This should be fixed, where duplicating product posts saves hours on site builds. Actually, WooCommerce should include a duplicating function after each post, to aid in site builds.

    Then I examined a working variable in the database: wp_posts > post_title. Data reads: GoPro Housing – LED Replacement. For the failed variables that does not save edits, the post_title reads “GoPro Housing” but lacks the hyphen and variable? The “guid” made reference to the harpoon listing which was a previous clone during the product additions, a result of duplicating.

    In another failed variable case, the “guid” made reference to: https://domain.com/?post_type=product&p=1157 which was inconsistent to the working variations added. This support window doesn’t allow the pasted string above to display correctly, where the extended character “#038;” (ampersand) falls between the ampersand and the lower case “p”, added by Woocommerce into the variation string in the database. Meaning there are two ampersands being saved to the database. One the keyboard character followed by the ASCII character value #038;. This can be a sure cause of date retrieval failure and should be fixed!

    Again, this more aggressive variation problem only started after updating to WooCommerce 3.2.4. The above notes is a combination of problems that could result in unpredictable variations failures. I don’t count this matter solved, rather it is more a revelation into the need for Automattic to fine tune their current PHP.

    • This reply was modified 4 years, 2 months ago by Inndesign.

    The Woo update (3.2.5) has fixed this for me!

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Woocommerce 3.2.4 – Product Variations do not save – Variations Revert to Defaul’ is closed to new replies.