Support » Plugin: WPC Smart Compare for WooCommerce » Woocommerce 3.0 not compatible

  • Hello sir,

    We have found one error in our plugin. When we activate the plugin at that time in shop page it gives me an error that “Notice: id was called incorrectly. Product properties should not be accessed directly. Backtrace: require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’)”

    So, we have noticed that you have called id directly but please update that $product->get_id() in behalf of $product->id for WooCommerce version >= 3.x
    Make sure that plugin works for both (older and newer) WooCommerce versions.

    Thank you,
    Nitin

  • The topic ‘Woocommerce 3.0 not compatible’ is closed to new replies.