Support » Plugin: WooCommerce » Woocommerce 3.0 is not woocommerce

  • Fabri

    (@fabrisancho)


    3.0 this is not an update is a new ecommerce system without compatibility with everything done

    All existing plugins that made woocommerce an ecommerce that could solve most of the needs will stop working with this new plugin

    So woocommerce 3.0 has stopped being woocommerce

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Mike Jolley

    (@mikejolley)

    3.0.0 is a major update – the clue is in the version number. Read https://woocommerce.wordpress.com/.

    Get updates for extensions from extension developers with compatibility. If you are a developer, this has been in beta/RC for 3 months so you should have tested before launch.

    Thanks

    Fabri

    (@fabrisancho)

    I am not a plugin developer, I am a user.

    Are you going to keep getting security updates for 2.6? Or are you going to leave without support all the people that can not be upgraded to 3 because all their themes and plugins depend on the previous version?

    Plugin Author Mike Jolley

    (@mikejolley)

    If themes and plugins rely on 2.6 and will never be updated, you should seriously evaluate why you’re using them over others? As I said, this update has not come out of the blue. We’ve been shouting about it for months.

    2.6 will not receive updates. WordPress.org does not support separate version updates like that.

    Fabri

    (@fabrisancho)

    2.6 will not receive updates.

    jeje fantastic news for the millions of woocommerce stores installed and will not be able to upgrade to version 3

    Hackers are welcome

    @mikejolley, I think 90% issues are there for using local template overrides. I am personally a theme developer but I do not use template overrides for my theme. Therefore I am getting minimum issues with v3.0

    Please note – I am not a core PHP or WooCommerce developer. I have moderate knowledge in PHP and I follow codex.

    Don’t you think you should force developers to integrate WooCommerce with proper hooks and filters?

    You cannot blame users. That’s totally foolish thing. Changes are welcome but don’t think you are GOD yet! There are serious negligence from WooCommerce.

    I hope you understand me.

    Thanks,
    Amit

    Plugin Author Mike Jolley

    (@mikejolley)

    > Don’t you think you should force developers to integrate WooCommerce with proper hooks and filters?

    This would not go down well either 🙂 Overriding templates is FINE if you keep up to date with new releases. If you don’t of course it will fall over one day.

    > You cannot blame users. That’s totally foolish thing. Changes are welcome but don’t think you are GOD yet! There are serious negligence from WooCommerce.

    Asking a user to get updates from the developers who provided the code is not BLAME, it’s what he needs to do. If the developer is not keeping code updated, using their services might not be the best cause of action. He should use vendors like you, who test and do things correctly.

    Dear @mikejolley it’s most of the time is nearly impossible to switch themes. There are many reasons for that. That’s why I have mentioned if developers will be forced to use only proper hooks and filters, it will be easier for all. Because I believe non technical users will face minimum issues without any core functionality loss.

    Anyway, this is mainly painful for users. If the theme authors are sincere, it will be resolved sooner or later.

    It is true that we cannot ignore the hard work contribution that you guys are giving is lifeline for anyone. WooCommerce is still the best and will be.

    Btw, I am facing a small issue in mini cart ajax update. Can you please look at this issue once? – https://wordpress.org/support/topic/minicart-ajax-issue/

    Agreed. I’ve rolled back and have no intention of going forwards at the moment. I may of missed something but the phrase if it ain’t broke don’t fix it. It just worked. I’ve had to tell other people that I’ve installed sites for what ever you do don’t update. Across my sites I did not get a single update from anyone at the same time as Woocomerce one so I guess not one of the addons were changed for this new market place,

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Woocommerce 3.0 is not woocommerce’ is closed to new replies.