Support » Plugins » WooCommerce 2.4.8 update causes redirect issue

  • When updating the WooCommerce 2.4.8 plugin it crashed my site. I now get the following error messages:

    Firefox:
    The page isn’t redirecting properly
    Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

    Chrome
    This webpage has a redirect loop
    ERR_TOO_MANY_REDIRECTS

    Safari
    Safari Can’t Open the Page
    Too many redirects occurred trying to open “www.paradisemarshi.com” This might occur if you open a page that is redirected to open another page which then is redirected to open the original page

    —————

    I have set up Support Ticket #351459 – Opened on the 3rd November 2015 – and haven’t heard from the Ninja team. Documentation says half of these issues are due to incompatibility with the theme. However when I deactivate the WooCommerce plugin the site is restored. Anyone have any suggestions?

Viewing 7 replies - 1 through 7 (of 7 total)
  • I have been waiting for over five days for Ninja Support at WooCommerce to even acknowledge my ticket I sent in about the issue in this thread and not even an acknowledgement of my ticket. I am very disappointed with the tech support for a paid subscription to two of the extensions. Has anyone else experienced such a long waiting period for the ‘Ninja Team’ to reply to a ticket? Has anyone else experienced this issue? I would appreciate any advice about this.

    Finally the Ninja Team has arrived and is assisting in resolving this issue.

    Want to update what happened. Learned something from the Ninja but still haven’t resolved this.

    Here is the edited ticket the Woocommerce Ninja and I had so you can know what I know:

    Redirect loop
    WooCommerce Ticket #351459 – Opened on the 3rd November 2015
    • When upgrading to Woocommerce plugin to 2.4.8 it causes the site to go into a redirect loop on Safari, Chrome and Firefox. Please advise what the fix is for this issue? We are using PHP Version 5.6.14. We are using the latest version of WooCommerce 2.4.8.
Nov 3, 2015
    • After updating the WooCommerce plugin to Version 2.4.8 this creates and issue where the web site goes goes into a redirection loop. Here is the error message:
Firefox: 
The page isn’t redirecting properly 
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
Chrome 
This webpage has a redirect loop 
ERR_TOO_MANY_REDIRECTS
Safari 
Safari Can’t Open the Page 
Too many redirects occurred trying to open “www.paradisemarshi.com” This might occur if you open a page that is redirected to open another page which then is redirected to open the original page
We have had to deactivate the plugin to allow the site to load.
Please advise what the solution is to this issue?
thanks,
——
Nov 3, 2015 

    • Very disappointed with your support. It has been over five days and not even an acknowledgement of this ticket? Is your Ninja support not available? Please reply.
 Nov 7, 2015 

    • Howdy ———,
Thank you for contacting Woo Support! I am sorry about the delay in getting to your case. We are experiencing very large numbers of support requests at this time. Thank you for your patience.
Redirect loops are such a headache. Sorry that you have to deal with this.
The redirect may be coming form a Plugin + WooCommerce. Can you try disabling all the Plugins and but not WooCommerce and see if that helps?
Did you happen to change the .htaccess file when you upgraded?
Please let me know the results and we can go from there.
Thank you,
Ninja. – Happiness Ninja
WooThemes Support
Ninja Tip: Check out our Theme Customization 101 Guide for tips and best practices!
 ninja Nov 9, 2015 

    • Hi Ninja, 
That was an excellent idea. I turned them all off but the WooCommerce plugin and my site is restored with the shopping cart. However when turning on each plugin one at a time the issue is with the WooCommerce Authorize.net CIM Gateway plugin. It crashes the site and puts it into the redirect loop. I deactivated it and the site is restored. Here is the link to the site: 
http://www.paradisefarmshi.com/
I have the WooCommerce Authorize.net CIM Gateway plugin deactivated. 
So what is the plan?
 You Nov 9, 2015

    • Hi ———,
Well, that’s interesting.
I cannot recreate it. I have a site up with 2.4.8 and the WooCommerce Authorize.net CIM and no redirect.
Do you have anything specific in the .htaccess file that you added for that gateway?
Would you be up for me logging in and taking a look? You can enter a username here in this conversation and then securely leave a password here and include the link.
It would also be great to get a bit more data to help. Can you enable WP_DEBUG?
To do that:
login to your site via FTP
    • download the wp-config.php file
    • duplicate this file to create a backup (just in case something goes wrong)
    • replace this:
    • 
 define(‘WP_DEBUG’, false);
    • /* That’s all, stop editing! Happy blogging. */
    • 
with this:
 define(‘WP_DEBUG’, true); // Turn debugging ON
    • define(‘WP_DEBUG_DISPLAY’, false); // Turn forced display OFF
    • define(‘WP_DEBUG_LOG’, true); // Turn logging to wp-content/debug.log ON
    • /* That’s all, stop editing! Happy blogging. */
    • 
save and re-upload this file to your site.
Sorry about the extra steps, this is an interesting one. I have a feeling it’s server related. So if you would not mind giving me FTP access as well to poke around, that would be great.
Cheers!
Ninja. – Happiness Ninja
WooThemes Support
Ninja Tip: Check out our Theme Customization 101 Guide for tips and best practices!
 ninja Nov 9, 2015 

    • Changed the wp-config.php file. I made a backup. 
FTP Username: ————
FTP Server: http://ftp.——————
pw 
————
FTP & explicit FTPS port: 21 
SFTP port: 22
 You Nov 9, 2015 

    • If you want to activate the WooCommerce Authorize.net CIM Gateway plugin and watch it go into the redirect loop here is access to the WordPress dashboard: 
http://—————————
user name 
————
pw 
————
 You Nov 9, 2015 

    • Hello ————,
Do you mind if change the theme temporarily?
Also, the debug is not being written. I don’t want to mess with your permissions. Can you configure the perms so that the log is written to?
Thank you,
Shane
Ninja. – Happiness Ninja
WooThemes Support
Ninja Tip: Check out our Theme Customization 101 Guide for tips and best practices!
 Ninja Nov 10, 2015

    • Ninja, 
No Problem. Do what you gotta due. We need this fixed so we can have our shopping cart up and running. It has been down for over a week. You can deactivate plugins, change themes, whatever. 
You
 You Nov 11, 2015 

    • You can change the perms however you want. Just help us fix the issue.
 You Nov 11, 2015

    • Hello ———,
I am able to activate the Extension now by disabling Force secure checkout.
Do you know if your sever is behind a proxy? This will often cause issues with SSL.
Thank you,
Ninja. – Happiness Ninja
WooThemes Support
Ninja Tip: Check out our Theme Customization 101 Guide for tips and best practices!
ninja Nov 11, 2015 

    • Not sure about a proxy. However, we did purchase a SSL certificate from our host. Do you need access to the host cPanel?
 You Nov 11, 2015

    • Hello ———,
You’ll want to decide if your entire site will be encrypted, or just the Checkout page. If you have the entire site forced through HTTPS and use Force Secure Checkout, this can cause problems like we are seeing.
If you go to:
http://www.paradisefarmshi.com/
That you are redirected to:
https://www.paradisefarmshi.com/
And if I get rid of the www it’s added back. WWW and SSL are being forced.
I hope this helps!
Thank you,
Ninja. – Happiness Ninja
WooThemes Support
Ninja Tip: Check out our Theme Customization 101 Guide for tips and best practices!
ninja Nov 11, 2015 

    • I sort of understand. So what is the solution? It worked before the update. Isn’t this a plugin issue with the Authorize.net plugin we purchased? What are you suggesting we can do? Make just the checkout page use SSL? How can we have just the checkout page use SSL and the rest of the site not use it?
 You about Nov 11, 2015 

    • Are you still working on this?
    You about Nov 11, 2015





    Not too happy with the Ninja support. From what I gather from all this is that we update all the Woocommerce plugins including the purchased Authorize.net plugin that is supposed to make the payment module work with the woocommerce shopping cart and it makes our site go into a redirect loop. It appears it is up to me to figure out whether I want my entire site with an SSL certificate or to just have the check out page use the SSL. I have no idea how to make this happen. If anyone can assist me this would be much appreciated, since the Ninja hasn’t replied in over 14 hours.

    So the nutshell version of what happened is when I went to the Dashboard we needed to update a bunch of stuff which I did:

    WordPress 4.2.2 and update the Divi theme to 2.5.6 and then the three Woocommerce plugins. After I updated the plugins the site went into the redirect loop. After working on this for hours with the Woocommerce Ninja Team it was narrowed down to the Authorize.net Woocommerce plugin you purchased from Woocommerce. If this plugin is deactivated the site works. If you activate it the site goes into the redirect loop. After further investigation the Ninja says he was able to make the cart work by simply unchecking the forced checkout box:

    Dashboard > WooCommerce > Settings > Checkout

    Simply uncheck the FORCE SECURE CHECKOUT

    And of course this gives the message at the top of your Dashboard:

    WooCommerce Authorize.net CIM Gateway: WooCommerce is not being forced over SSL; your customer’s payment data may be at risk.

    Finally got the solution from the Ninja:

    Hey…..,

    Sorry about the delay. I was out sick yesterday.

    If you check now, the site is working. We removed https from the settings page for WordPress Address (URL) and Site Address (URL). So now the site is running http until you get to the cart which is then https and is working. No redirect on the homepage now.

    Cheers!

    Ninja. – Happiness Ninja
    WooThemes Support

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WooCommerce 2.4.8 update causes redirect issue’ is closed to new replies.