Support » Plugin: WooCommerce » Woocommerce 2.0.3 update error

  • lamakun

    (@lamakun)


    I just updated to Woocommerce 2.0.3 and my site just stopped working. The error has to do with the customized shipping method I am using. In the log it shows like:

    PHP Fatal error: Class ‘WC_Shipping_Method’ not found in …..

    Wher it used to work perfectly.

    Anyone has any clue?

    Thanks

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 14 replies - 1 through 14 (of 14 total)
  • xlarchery

    (@xlarchery)

    I just updated 2.0.3 too and everything went dead! Thanks alot Woocommerce! Please post an solution asap! i depend on woocommerce/wordpress for my daily income!

    O. G. Hippiechick

    (@o-g-hippiechick)

    Yup! Here too. Everything went dead. Since I had less than 100 products, and a good backup, I just deleted woocommerce from my webhost cpanel, renamed my .htaccess file to .old, and voila, my website came back. It still has the shop page, but no woocommerce. I am debating to wait a week or so, or to revert back to woocommerce 1.6.6. Ugh!

    xlarchery

    (@xlarchery)

    Well a friend of mine who works in ict fixed it for me, and i am still waiting for a reply from both wordpress as woocommerce… So once again i am not helped by any of their service desks… But it works fine now… it only wants to install a update from wordpress thats already installed. But i just ignore it and wait for another update to see whats going to break next time….

    johnqla

    (@johnqla)

    I’m having the same problem. Updated to 2.0.3 and my site is completely blank. Please help!

    annagsb

    (@annagsb)

    Same here. Does anyone have a fix for this issue?

    annagsb

    (@annagsb)

    Ok guys, my website wasn’t displaying properly after the update to 2.0.3. I am using the Flexishop theme and my website went completely blank. Here’s what I did:

    Go to Appearance – Editor – function-woocommerce.php

    Do a search for WooCommerce_Widget_Cart(); and change that to WC_Widget_Cart();. Save. Worked like a charm for me.

    pglendin

    (@pglendin)

    Help I am really struggling I am trying to follow annagsb advice as my problem is the same
    Go to Appearance – Editor – function-woocommerce.php

    Do a search for WooCommerce_Widget_Cart(); and change that to WC_Widget_Cart();. Save. Worked like a charm for me.

    But I can’t find Function-woocommerce.php after I select Editor

    Please help urgently

    pglendin

    (@pglendin)

    Help I am really struggling I am trying to follow annagsb advice as my problem is the same
    Go to Appearance – Editor – function-woocommerce.php

    Do a search for WooCommerce_Widget_Cart(); and change that to WC_Widget_Cart();. Save. Worked like a charm for me.

    But I can’t find Function-woocommerce.php after I select Editor

    Please help urgently

    annagsb

    (@annagsb)

    What can you see on the right hand side when you go to Editor? Is there a list of .php files for your theme?

    pglendin

    (@pglendin)

    Yes there is a list the only ones mentioning function are
    functions-colors.php
    functions-core.php
    functions-dashboard.php
    functions-fonts.php
    functions-metaboxes.php
    functions-sliders.php
    functions-template.php
    functions-widgets.php
    hooks.php

    If i click functions-widgets I get to Maya Shop: functions-widgets.php (core/functions-widgets.php which I think is where my problem could be

    pglendin

    (@pglendin)

    annagsb
    Hopefully you are still there and can help me?
    my problem is a little different to yours (but I am hopeful your fix will work for me if you can show me how to achieve it) my problem is not that my site went blank when I updayed rather my cart got messed around see here http://www.caffeottavo.com.au/shop/gran-gusto

    annagsb

    (@annagsb)

    I found a solution to my problem on Flexishop theme’s support page. Try here for Maya Shop: http://themeforest.net/item/mayashop-a-flexible-responsive-ecommerce-theme/discussion/2189918

    Flangewood

    (@flangewood)

    Hi, I’ve a problem with Mystyle template after update to Woocommerce 2.0.3. Shipping rates I set in the old version appears on the interface but aren’t showed on the website. There’s an additional problem: I put the right settings to allow people to use paypal but Woocommerce doesn’t recognize them. Please help, the website worked perfectly before the update.

    SkinnybCurvyc

    (@skinnybcurvyc)

    Thanks annagsb! your fix worked like a charm. I appreciate your input because I know I would be waiting awhile for support to get back to me.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Woocommerce 2.0.3 update error’ is closed to new replies.