WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » WooCommerce 2.0.0 – Problems with Prices – Everything Free.

WooCommerce 2.0.0 – Problems with Prices – Everything Free.

Viewing 11 replies - 1 through 11 (of 11 total)
  • i made a rollback to 1.6 version and is working fine… =/

    the update caused prices to get small and the mainpage to give the free price problem!

    Yes!
    Same here! Argentum Theme… everything is free! How did that happen? however each product page indicates costs. Just the home page appears to be affected.

    Anyone?

    Roy Ho

    @splashingpixelscom

    Ask your theme developer if their theme is 2.0 compatible…

    Same problem with the Argumtum theme…everything on the home page is free…product page indicates cost.

    Going to try to roll back. If anybody knows of a fix?

    And the Argentum theme that we’re having a problem with is a Woo Theme…one we paid for.

    The warning comes up after the install that the theme does not declare woocommerce support. But it’s their theme?

    Anybody from Woo out there to help?

    I added this and it is a patch, but doesn’t solve the problem:
    http://www.foxrunsoftware.net/articles/wordpress/hide-woocommerce-free-price-label/

    Okay-

    This worked for me:

    My ver. of Argentum was 1.3.5. The latest version is 1.7.5. I downloaded the latest, made a backup of the full-theme-settings from within Dashboard-Argentum-Back up settings. Copied old 1.3.5 version, then deleted it. Uploaded new 1.7.5 Argentum theme, activated it, and didn’t even have to restore settings… worked great. All done.

    We were having the same issue, and I eventually found the answer. We are using a child theme, with a modified index.php file. The query to retrieve the products on the home page has changed slightly since we created that child theme (for one thing, they are now declaring a global $product in each query). Once I updated the parent theme to the most recent version (we are using Woo’s “Sliding” theme), and then updated the index.php file in our child theme to use the current query format… the Free! problem went away.

    Hope that helps someone…

    I am having this same exact issue and for the past two hours I cant get a solution. Here is my website…

    http://www.liveshotsimaging.com/store

    Looking at the index.php file, ive located the issues down to the line, but I dont know where the problem lies within the following line…

    span class="price"><?php echo $_product->get_price_html(); ?></span>

    I am inept when it comes to php as I know more css/html, so hopefully someone can help??

    Thank you!!

    oops forgot the end bracket on the code above…

    <span class="price"><?php echo $_product->get_price_html(); ?></span>

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WooCommerce 2.0.0 – Problems with Prices – Everything Free.’ is closed to new replies.
Skip to toolbar