Support » Plugin: WooCommerce For Japan » woocommerceバージョン 3.6.1アプデ―トからのエラー

  • Resolved not1_name

    (@not1_name)


    woocommerceバージョン 3.6.1アプデ―トしてから下記エラーはPHPログに表示されます。注文いただく際のエラーです。

    Warning: Invalid argument supplied for foreach() in /……/wp-content/plugins/woocommerce-for-japan/includes/class-wc-address-field-4jp.php on line 513

Viewing 3 replies - 1 through 3 (of 3 total)
  • load_country_states()が3.6.0でdeprecated になったので、global $statesが使えなくなったようです。代わりにget_states()を使います。

    woocommerce-for-japan/includes/class-wc-address-field-4jp.php
    の459行目

    $woo_countries = new WC_Countries();
    $states = $woo_countries->get_states();
    $states = $this->wc4jp_states( $states );
    と追加すれば動くと思います。

    ありがとうございました!

    プラグインのアップデートまでこれを使ってみます

    Plugin Author shohei.tanaka

    (@shoheitanaka)

    jamojisanさん、解決先を提示頂いてありがとうございます。
    1.2.27のアップデートで解決対応をさせていただいております。

    対応に時間がかかってしまって申し訳ございませんでした。

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.