Support » Plugin: PublishPress Blocks – Advanced Gutenberg Blocks, Permissions, CSS and Layouts » woo-products “featured” showing non-featured

  • Resolved scmsteve

    (@scmsteve)


    We have a woo-products block that is set to show only featured items. In the block editor the three items displayed are correct and are featured. However, on the page when viewed on the site the second item that is displayed is not marked as featured and shouldn’t be there.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Thread Starter scmsteve

    (@scmsteve)

    I can verify that if I send this REST request:

    /wp-json/wc/v1/products/?per_page=3&featured=1

    I get featured and non-featured items.

    If I change v1 to v3:

    /wp-json/wc/v3/products/?per_page=3&featured=1

    It properly filters.

    I’m not into block development much yet, but it looks like you are overloading the REST API with a /agwc/v1/products endpoint, and if I try to call that (/wp-json/agwc/v1/products/?per_page=3&featured=1) I am told I cannot list resources.

    I don’t know how to test much further to verify if this is a core Woo issue with the /v1/ endpoint not respecting the filter or what.

    Plugin Author htmgarcia

    (@htmgarcia)

    Hi @scmsteve,
    thanks for reporting this bug. We’ll work on a fix.

    Regards

    Thread Starter scmsteve

    (@scmsteve)

    Thanks. Woocommerce had said that if it is due to using the v1 API they won’t fix it because it is deprecated. I don’t think that should mean broken, but whatever, that is their call. I know the v3 endpoint was working so hopefully you can make it work with your plugin.

    Plugin Author htmgarcia

    (@htmgarcia)

    @scmsteve we’ll implement the required changes as soon as possible.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.