Support » Plugin: WooCommerce Services » Woo commerce services fatal error can’t access admin

  • Resolved jellybeansandwellyboots

    (@jellybeansandwellyboots)


    Hi,
    Warning: require_once(classes/class-wc-connect-extension-compatibility.php): failed to open stream: No such file or directory in /home3/icecream/public_html/wp-content/plugins/woocommerce-services/woocommerce-services.php on line 39

    Fatal error: require_once(): Failed opening required ‘classes/class-wc-connect-extension-compatibility.php’ (include_path=’.:/opt/php56/lib/php’) in /home3/icecream/public_html/wp-content/plugins/woocommerce-services/woocommerce-services.php on line 39

    Please be kind, I am trying to learn quickly with website hosting and all the jargon but essentially I’m an early years teacher, trying to run a small business from home and very much learning on the hoof! I’ve had my site for a good few months now and everything has been running well. However I suspect there has been an automatic update on the 13th March for my Woo Commerce plugin as since then my site has been down. I cannot access my wp admin panel- I receive the above message. I have tried accessing through the main WP site and it tells me my site cannot be accessed and I can delete it if I wish. Clearly I do not wish to do this. I don’t fully understand FTP but recall an issue I had early on with a theme that I was able to rectify through going through my Host site (Hostgator) and going through the file manager and changing the theme.

    So I’ve gone onto Hostgator and located the Woo Commerce Services file (php) which indeed says it was modified on the 13th March.

    I may be barking completely up the wrong tree but from my understanding the error message roughly translates to “there’s something amiss with line 39 of this file that’s cocking everything else up”. If I go into that file and scroll down to line 39 this is what is in that line:
    require_once( plugin_basename( ‘classes/class-wc-connect-extension-compatibility.php’ ) );

    I don’t really want to try anything before seeking advice and make the situation worse but my initial thought is to use the File Manager on Host Gator to delete the “Woo Commerce Services.php” file and then download it again onto my comp and upload it into here and see if that helps. Or am I completely barking up the wrong tree?

    I was advised to download the services plug in folder onto my comp and upload it via my host overwriting the existing file to see if this worked but sadly it didn’t and my site is still down.

    Any help would be really appreciated. Thank you for reading.
    Joanne

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Marcin

    (@robobot3000)

    Hi @ jellybeansandwellyboots,

    Looks like you have an older version 1.12.0 of the plugin which introduced this error.

    Since you have access to FTP, you can fix this in the following way:
    1. Delete the whole woocommerce-services directory in wp-content/plugins
    2. Your admin panel should load now
    3. Download the new version of the plugin here: https://downloads.wordpress.org/plugin/woocommerce-services.1.12.1.zip
    4. In your admin panel navigate to Plugins > Add New > Upload plugin and select the file you downloaded
    5. Activate the plugin

    jellybeansandwellyboots

    (@jellybeansandwellyboots)

    Hi,
    I did step one, step two worked. Downloaded step 3, added and activated plugin as per 4 and 5.

    I’m now getting this message when I load my website:
    Warning: require_once(classes/class-wc-connect-extension-compatibility.php): failed to open stream: No such file or directory in /home3/icecream/public_html/wp-content/plugins/woocommerce-services/woocommerce-services.php on line 39

    Fatal error: require_once(): Failed opening required ‘classes/class-wc-connect-extension-compatibility.php’ (include_path=’.:/opt/php56/lib/php’) in /home3/icecream/public_html/wp-content/plugins/woocommerce-services/woocommerce-services.php on line 39

    Fatal error: Call to undefined function is_user_logged_in() in /home3/icecream/public_html/wp-content/mu-plugins/endurance-page-cache.php on line 370

    Plugin Contributor Marcin

    (@robobot3000)

    Let’s try this: the zip file you downloaded should have a file called class-wc-connect-extension-compatibility.php in the classes folder. If it doesn’t then you can download it from here: https://raw.githubusercontent.com/Automattic/woocommerce-services/master/classes/class-wc-connect-extension-compatibility.php

    Using FTP, upload the above file to the wp-content/plugins/woocommerce-services/classes directory on your server

    jellybeansandwellyboots

    (@jellybeansandwellyboots)

    yep it has that in it already 🙁

    jellybeansandwellyboots

    (@jellybeansandwellyboots)

    just to update. My friend’s husband knows a little bit and had a look at my site. He says it will work with http:jellybeansandwellyboots.com but not with the www. prefix. Still same error code for that. Not sure if that info helps at all.

    Plugin Contributor Jeff Stieler

    (@jeffstieler)

    Hello @jellybeansandwellyboots,

    I just wanted to follow up – is WooCommerce Services fixed now? It looks like I can reach your store, so that looks good!

    Plugin Support stephjacq

    (@stephjacq)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Woo commerce services fatal error can’t access admin’ is closed to new replies.