WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » Woo commerce not working with IE10

Woo commerce not working with IE10

  • The checkout process just “hangs” in IE10 / windows8

    It works on all other browsers, but not with Internet explorer.

    when you click on checkout to go to paypal, the little “wheel” spins on your screen and the page gets stuck and freezes.

    This is quite a majot problem and would like to know if there is a fix on the way?

    thanks

    http://wordpress.org/extend/plugins/woocommerce/

Viewing 15 replies - 1 through 15 (of 33 total)
  • Hey, I was wondering if you have this figured out. I have the same problem. Checkout works fine in Chrome and FF, but not in IE10. It works in IE10 compatibility mode.

    No, never did…
    That’s pretty bad but can’t find a solution. It is strange woocommerce have not addressed that.

    Plugin Author James Koster

    @jameskoster

    Could you share a link to your site? Not seen any reports of this before.

    My site is in maintenance mode. I have temporarily made it live. Its
    hajjsolutions.com

    I have tested the checkout in Chrome, FF and IE8, and IE10.
    It works in all except in IE10 normal mode. I have read all the forums available and have tried to fix it my increasing PHP size limit, disabling all plugins and verifying if the short code it correct. I even reset all the settings of IE10.
    I have the exact same issues with a localhost site.

    Let me know when you are done looking at it so I will put it back in maintenance mode.

    Here is a link to a test site.
    This has a COMPLETELY new installation of WP 3.5.1 and only the Woocommrece 2.0.5 plugin. I have not installed any other plugins and have disabled all other plugins. The theme is the default WP themes.
    I have not changed ANY settings except added a test product.
    I have tested the site and it works in every browser (Chrome, Firefox, Safari IE8, IE10 on Win7)
    Only in IE10 with Windows 8 (in non-compatibility mode), the ‘Add to Cart’ button in the shop and the bottom of the checkout page doesn’t work.

    Plugin Author James Koster

    @jameskoster

    Hi there,

    I just tested your test site in IE10 on Windows 8 using Browserstack. Seems to work just fine to me? Could you describe exactly what happens?

    Thanks, Jay

    Hi Jay,

    not sure what the other user experiences, but I can tell you that for me, on Windows 8 / IE10, when you checkout and get to the stage where you fill in your customer details register etc. and click “place order”, the page just hangs.., you get the little wheel showing in the middle, as if the page is trying to load or something but it just fails to do anything

    evertyhing works perfectly on other browsers and full checkout to payapl works 100%.

    seems the browser is unable to process that page.

    I have the same problem as vinny199.

    1) On the checkout page everything below the “Your Order” heading is greyed out with the two dots spinning continuously.
    Basically everything in the <div id=”order_review”> section.

    2) On the shop page (product archives), if I click the “Add to Cart” button, the checkmark to the right of the button appears, but the no item is added to the cart.

    vinny199, could you see if you also have the second problem.

    Here is a screenshot of the problem and the IE version

    Thanks

    Has anyone found a solution to this problem yet?

    not that I’ve heard of.. I wonder if it is something woocomerce guys just can’t fix. there’s never been any feedback on this issue from them as far as I’m aware of.

    Woocommerce still hasn’t fixed the issue. I guess either they gave up or do not care. It’s a big drawback for this plugin.

    Hello musab_bari and vinny199, I have just tested the latest woocommerce on IE10. I have installed win7 with IE10, the order takes two times as long as it would on firefox or chrome. A total time of 8 seconds to redirect to order page.

    Chrome is 4 seconds. It works in win7, it must be a win8 problem if this still persists.

    yes, it seems to be a problem with IE10 / Windows 8 combination, whihc in my opinion is a pretty major draw back..

    Yes, the problem is in win8 IE10.
    This unfortunately is the browser a lot of our guests have been using.

    As I mentioned earlier, it was working for me with IE10/Win7. It’s just IE10/Win8. Its not as if the demographic of people using IE10/Win8 is going to decrease, Woocommerce needs to address this issue.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘Woo commerce not working with IE10’ is closed to new replies.
Skip to toolbar