• Resolved oceanswardrobe1

    (@oceanswardrobe1)


    Back to an old problem redeveloped since December 2020 updates. The link provided a year ago in support relating to the same problem and it cure no longer works.

    I use woo commerce. Desktop version works fine however when testing AMP using a mobile I get this at basket entry.

    “….It appears your submission was successful. Even though the server responded OK, it is possible the submission was not processed…..”

    The problem is consistent across the entire product range after adding to intended purchase to the basket. The basket remains empty when using amp.

    All Dbase, woo commerce and amp plugins are up to date.

    Your assistance is appreciated.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 16 through 30 (of 32 total)
  • Thanks for posting an update, and always worth checking in with the developers. If you happen to determine the redirection to a users cart isn’t working let me know and we can perform some troubleshooting steps.

    Thread Starter oceanswardrobe1

    (@oceanswardrobe1)

    Thank you James. I am going to try a trouble shoot plugin used with site health.

    Thread Starter oceanswardrobe1

    (@oceanswardrobe1)

    Hi sorry for the long delay in update. Since our last coms I have deactivated every plugin except and then reset one by one. I have tried your suggestion sadly does not work.
    The only change has been that plug in suppression in AMP shows it is not compatible with storefront , divi, nor w3 total cache or so I am unsure how to proceed.
    your advice is appreciated
    The amp consol error readsas follows when adding to cart from product page is as follows
    ON PRODUCT PAGE https://oceanswardrobe.xen.co.za/product/bikini-top-scrunch-top/?amp=1

    Powered by AMP ⚡ HTML – Version 2105150310000 https://oceanswardrobe.xen.co.za/product/bikini-top-scrunch-top/?amp=1
    cdn.ampproject.org/rtv/012105150310000/v0/analytics-vendors/googleanaylitics.json:1 Failed to load resource: the server responded with a status of 404 ()
    v0.mjs:2 [AmpAnalytics 3d9ffd95fc57] Error loading vendor config:  https://cdn.ampproject.org/rtv/012105150310000/v0/analytics-vendors/googleanaylitics.json Error: HTTP error 404​​​
        at ka (v0.mjs:2)
        at ib.createError (v0.mjs:2)
        at v0.mjs:17
        at new Promise (<anonymous>)
        at lf (v0.mjs:17)
        at v0.mjs:17
        at async Promise.all (/product/bikini-top-scrunch-top/index 1)
    fb @ v0.mjs:2
    v0.mjs:2 [AmpAnalytics 3d9ffd95fc57] No request strings defined. Analytics data will not be sent from this page.
    fb @ v0.mjs:2
    v0.mjs:2 [AmpAnalytics 3d9ffd95fc57] Ignoring request for event. Request string not found:  pageview

    PLEASE HELP

    Thread Starter oceanswardrobe1

    (@oceanswardrobe1)

    Hi James and \Co, , After some weeks of fiddling I thought I had cure the problem only to have caused a huge woo dbase tables which I had to clean.

    I had decided to use option three in AMP. All went great for a day but on the second day on hand held mobile the image is lost when one has chosen the product style and tried to add to cart.
    The consol error message isas follows

    Powered by AMP ⚡ HTML – Version 2106030132000 https://oceanswardrobe.xen.co.za/product/thong-sheer-when-wet/?amp=1
    cdn.ampproject.org/rtv/012106030132000/v0/analytics-vendors/googleanaylitics.json:1 Failed to load resource: the server responded with a status of 404 ()
    log.js:255 [AmpAnalytics 3d9ffd95fc57] Error loading vendor config:  https://cdn.ampproject.org/rtv/012106030132000/v0/analytics-vendors/googleanaylitics.json Error: HTTP error 404​​​
        at ka (index.js:59)
        at lb.createError (log.js:344)
        at xhr-utils.js:384
        at new Promise (<anonymous>)
        at hf (xhr-utils.js:378)
        at xhr-impl.js:184
        at async Promise.all (/product/thong-sheer-when-wet/index 1)
    ib @ log.js:255
    log.js:255 [AmpAnalytics 3d9ffd95fc57] No request strings defined. Analytics data will not be sent from this page.
    ib @ log.js:255
    log.js:255 [AmpAnalytics 3d9ffd95fc57] Ignoring request for event. Request string not found:  pageview
    ib @ log.js:255
    oceanswardrobe.xen.co.za/:1 Tracking Prevention blocked access to storage for https://secure.gravatar.com/avatar/141116e44388f1d4a44f97a3245b9ee8?s=42&d=mm&r=g.

    please help if able.

    @oceanswardrobe1 Thanks for reaching out. When checking your non AMP URLs I don’t seem to be able to proceed, the system doesn’t recognize my product option selections. Can you confirm all is working on your non AMP as expected first of all?

    Thread Starter oceanswardrobe1

    (@oceanswardrobe1)

    Good morning James. Humble appolgies for not getting back to you yesterday. the site is up and running reader format 2016 is the AMP scheme while storefront is used for the non amp.
    You can go ahead with the mobile test.
    regards hugh

    Thread Starter oceanswardrobe1

    (@oceanswardrobe1)

    Thought to advise that the AMP problem remains while the desktop option is able to sell. I know because we had some sales over the weekend and all complained about AMP failing to add from product selection page to cart.

    Thanks for the update. Please allow me some time in order to check this on my side. I can see the redirect to your shopping cart is not working, along with the item not getting added to the cart.

    @oceanswardrobe1 Many thanks for your patience on this. I’ve tested this on a couple of sites and I can reproduce the same. I’ll check this with my colleague and report back to you here.

    In the meantime you have the option to disable AMP on product pages by using the plugins “Supported Templates” configuration.

    Thread Starter oceanswardrobe1

    (@oceanswardrobe1)

    Thank you James I will do so. Ihave lived with this for weeks and tried everything so a week or two extra is neither here nor there as our beaches have been closed ergo no sales. I do not wish to lose google amp listing.

    Thread Starter oceanswardrobe1

    (@oceanswardrobe1)

    Thank you James, your idea works well enough for now but we have struck another problem inasmuch that there is a clash with form seven as well. This means that any mobile enquiries are stuck on submit. The result is that no enquiry mails are being accepted. best regards.

    Thanks for the update. For Contact Form 7 please try this mini plugin. After download the file (via the “Download Zip” button) upload, install and activate as a standard WordPress plugin from your plugins page.

    Let me know if that works for you.

    Just to keep you update we are working on a mini plugin that will hopefully allow WooCommerce to work for you as expected. We’ll keep you updated here with any follow ups, or inform you when it’s ready for testing. So far from testing it seems that this can occur in particular for products that have variations or product options.

    I also never include the link to the Contact Form 7 extension. You’ll find this here.

    Thread Starter oceanswardrobe1

    (@oceanswardrobe1)

    I am seriously chuffed that you have worked so dilligently in the resolution of this problem. A grateful Thank you. Kind regards Hugh

    We’ve just discovered that this particular issue may be addressed by installing and activating the AMP Enhancer plugin. Can you give this a try and I can check your site once more?

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘woo commerce / amp fails to add to basket’ is closed to new replies.