Support » Plugin: WooCommerce » Woo API 401on HTTPS (woocommerce_rest_cannot_view”)

  • 
    {
      "code": "woocommerce_rest_cannot_view",
      "message": "Sorry, you cannot list resources.",
      "data": {
        "status": 401
      }
    }
    

    Server hosting = geek plan on siteground
    Fresh installation of wordpress and woocommerce through softacolus. HTTP works as it should, HTTPS gives the error above. Tried a lot of things, different server (plesk on digitalocean – same problem persists).

    Support of siteground said:

    Hello

    The reported issue is application related rather than a server side one. You have stated that the authentication works when the HTTP URL is used. That is a proof that the issue is not related to the server’s configuration. The Let’s Encrypt SSL certificate seems to be properly installed and I cannot detect any issues with it. An online tool do not indicate issues as well:

    https://www.sslshopper.com/ssl-checker.html#hostname=xyz

    We have carefully investigated the problem, and tried to resolve it however to no avail. As a part of my investigation I tried to change the PHP version for the site, the .htaccess redirect rules, disable a security Apache module called mod_security, updated file and folder permissions etc. Moreover I checked online for a related articles and suggested solutions – it seems that the issue is quite common:

    https://github.com/woocommerce/wc-api-node/issues/43
    https://github.com/woocommerce/woocommerce/issues/11714

    The log records on the server also do not indicate what can be the reason for the issue. We do have experienced engineers/technicians, seasoned in dealing with various hosting-related WordPress issues. We do try to assist as much as possible with any application based related issue that you might approach us with, although sometimes there are more complex issues that require deeper investigation, which includes dedicating time and effort for debugging a problem, and this is usually best done by a professional developer. If a specific setting is suggested, we would gladly apply it for you (if the hosting environment allows it). You can find such developers in the most popular freelance websites.

    Best Regards,

    Hope this thread finds a correct person who will be able to solve the issue for me.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Woo API 401on HTTPS (woocommerce_rest_cannot_view”)’ is closed to new replies.