Support » Plugin: Syndicate Press » Won't show full content of feed articles

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author SP developer

    (@hranchfundi)

    Hi Brand New,
    From your description it sounds like the feed publishers wordpress site is not publishing the full post in their rss feed. This is typical of many wordpress sites as WP defaults to only publishing the first portion of the post via rss and then inserts a ‘…’.

    If you will post the rss feed url we can double check that this is the issue. You can also check for yourself by putting the rss feed url into a browser to see if the articles are being published in full or just an excerpt. I usually use the firefox browser when looking directly at a feed url because it formats the feed nicely.

    Best regards,
    SP Developer

    Thanks. Yes, you’re right. Having checked it’s not pulling it all through. However, I’m not sure why it’s doing that as in Reading Settings I’ve set it to ‘For each article in a feed, show Full text’. Is there something else I’m missing. WP is fully up to date. Thanks again.

    Plugin Author SP developer

    (@hranchfundi)

    Hi Brand New,
    You might try clearing the SP input and output caches. Perhaps SP has the old feed content cached.

    Also, after you have changed the settings on the wp publisher feed site, open the feed url in a browser to see if the full article is being published in the feed.

    Best regards,
    SP Developer

    I’ve always had Full text selected and it makes no difference to the feed that’s output. This seems to be a WP issue not the plugin so I guess I need to take it up now elsewhere.
    Thanks for your help.

    Plugin Author SP developer

    (@hranchfundi)

    Hi Brand New,
    I have also run into the issue with several of my WP sites. If I find a solution I will post it. If you find one, please post it here too as it will help out lots of us. 🙂

    Best Regards,
    SP Developer

    Plugin Author SP developer

    (@hranchfundi)

    Hi Brand New,
    I may have found a solution for this that can be integrated into SP. I’ll have to do some more research, but I’ll ping you back when I get a little closer to a prototype.

    Best Regards,
    SP Developer

    Thanks for your replies.
    The strange thing is that I have problems visiting the direct feed link (by putting /feed/ on the end) but I can visit it via category.
    E.g.
    Page: http://prayernetwork.info/journal/
    Feed: http://prayernetwork.info/journal/feed/ – can’t visit as it just reverts back to previous page. Strangely though it works when accessing it via MailChimp for my newsletter AND pulls up the full text!
    Category feed: http://prayernetwork.info/category/journal/feed/ – I can access this via my FF browser but only pulls up the summary text.

    I hope this is useful…

    Plugin Author SP developer

    (@hranchfundi)

    Hi Brand New,
    looks like what is happening is that WP is putting the excerpt into the ‘description’ field of the rss feed item and is putting the full article intot he encoded content field of the feed item. Turns out that firefox only displays the description field which is why we were only seeing the excerpt in firefox.

    I will be modifying SP so that it can also support the encoded content of the feed.

    Will you post your feed URL so that I can use it as a test to verify that the new feature support is working?

    Thanks & Best regards,
    SP Developer

    Thanks. OK, see my previous post. You can use those.

    Hi. Just revisiting this issue. Are you any further on the testing you were doing? I have another feed I want to use but need the full text displaying. Thanks.

    Plugin Author SP developer

    (@hranchfundi)

    Not yet. This is on top of the priority list for SP though.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Won't show full content of feed articles’ is closed to new replies.