[resolved] Wont save widget check boxes - server wide (10 posts)

  1. adamsr
    Posted 3 years ago #

    Something has happened which has caused me to lose full control of my widgets and menus on my entire server. The server contains two multisites, and three single wordpress installations. It was all working last week, but has quit this week. For testing purposes, I have created an entirely separate test wp single site with no add-ons or themes installed. That site wont even allow me to drag and drop my widgets. The multisite allows me to drag and drop. None of my sites will save my changes on the check boxes. For instance, if I change the archives to a drop-down list, and hit save, it will drop all check boxes and revert back. Menus have similar problems. I can't figure out what might have changed to cause this problem on my server. I have tried enabling accessibility mode, and using that, I can get my widgets posted on all my blogs, but I still can't seem to get it to retain my check-box settings. The only changes that were made were adding SSL to one of my sites - which I have removed at this point, and removal of a blog on one of my multisites. Any ideas?



  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Try adding define('SCRIPT_DEBUG', true);to the bottom of the test site's wp-config.php file (just before the require_once line).

  3. adamsr
    Posted 3 years ago #

    That didn't seem to effect anything on my primary multisite.

  4. adamsr
    Posted 3 years ago #

    Didn't seem to work for my single site.

  5. esmi
    Forum Moderator
    Posted 3 years ago #

    On some hosting environments, aggressive settings for the "mod_pagespeed" addon can break the javascript code and cause scripts to not be able to function. This can cause many problems, such as widgets not working, menus not being draggable, the customizer not working, or the media screens not being available.

    To fix the issue, you will need to disable mod_pagespeed, or adjust its settings to not take effect in the wp-admin directories. You may need to ask your hosting service for help on how to do this.

  6. adamsr
    Posted 3 years ago #

    mod_pagespeed doesn't appear to be installed or running. I am hosting the server. It's highly posible I'm looking at a server issue, but I wanted some insight as to the mods and such that wordpress requires. My other server applications seem to be working fine.

    [Moved to Localhost Installs.]

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    In terms of mods, the following is a list from my local server's httpd.conf file:

    LoadModule actions_module modules/mod_actions.so
    LoadModule alias_module modules/mod_alias.so
    LoadModule asis_module modules/mod_asis.so
    LoadModule auth_basic_module modules/mod_auth_basic.so
    LoadModule authn_default_module modules/mod_authn_default.so
    LoadModule authn_file_module modules/mod_authn_file.so
    LoadModule authz_default_module modules/mod_authz_default.so
    LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
    LoadModule authz_host_module modules/mod_authz_host.so
    LoadModule authz_user_module modules/mod_authz_user.so
    LoadModule autoindex_module modules/mod_autoindex.so
    LoadModule cgi_module modules/mod_cgi.so
    LoadModule dir_module modules/mod_dir.so
    LoadModule env_module modules/mod_env.so
    LoadModule include_module modules/mod_include.so
    LoadModule isapi_module modules/mod_isapi.so
    LoadModule log_config_module modules/mod_log_config.so
    LoadModule mime_module modules/mod_mime.so
    LoadModule negotiation_module modules/mod_negotiation.so
    LoadModule rewrite_module modules/mod_rewrite.so
    LoadModule setenvif_module modules/mod_setenvif.so
    LoadModule php5_module "${path}/php/php5apache2_2.dll"
  8. adamsr
    Posted 3 years ago #

    LoadModule authz_host_module /usr/lib64/apache2-prefork/mod_authz_host.so
    LoadModule actions_module /usr/lib64/apache2-prefork/mod_actions.so
    LoadModule alias_module /usr/lib64/apache2-prefork/mod_alias.so
    LoadModule auth_basic_module /usr/lib64/apache2-prefork/mod_auth_basic.so
    LoadModule authz_groupfile_module /usr/lib64/apache2-prefork/mod_authz_groupfile.so
    LoadModule authn_file_module /usr/lib64/apache2-prefork/mod_authn_file.so
    LoadModule authz_user_module /usr/lib64/apache2-prefork/mod_authz_user.so
    LoadModule autoindex_module /usr/lib64/apache2-prefork/mod_autoindex.so
    LoadModule cgi_module /usr/lib64/apache2-prefork/mod_cgi.so
    LoadModule dir_module /usr/lib64/apache2-prefork/mod_dir.so
    LoadModule include_module /usr/lib64/apache2-prefork/mod_include.so
    LoadModule log_config_module /usr/lib64/apache2-prefork/mod_log_config.so
    LoadModule mime_module /usr/lib64/apache2-prefork/mod_mime.so
    LoadModule negotiation_module /usr/lib64/apache2-prefork/mod_negotiation.so
    LoadModule setenvif_module /usr/lib64/apache2-prefork/mod_setenvif.so
    LoadModule status_module /usr/lib64/apache2-prefork/mod_status.so
    LoadModule userdir_module /usr/lib64/apache2-prefork/mod_userdir.so
    LoadModule asis_module /usr/lib64/apache2-prefork/mod_asis.so
    LoadModule imagemap_module /usr/lib64/apache2-prefork/mod_imagemap.so
    LoadModule rewrite_module /usr/lib64/apache2-prefork/mod_rewrite.so
    LoadModule php5_module /usr/lib64/apache2/mod_php5.so
    LoadModule authz_default_module /usr/lib64/apache2-prefork/mod_authz_default.so

  9. adamsr
    Posted 3 years ago #

    I also have some additional plugins on my multisite that are acting the same as the widgets and menus. They act like they are working fine, but they don't save any changes made.

  10. adamsr
    Posted 3 years ago #

    I fixed it with a php.ini cache setting. Hopefully it doesn't come back if something more is wrong. Thank you for your time and assistance!

Topic Closed

This topic has been closed to new replies.

About this Topic