Support » Plugin: WP Mail SMTP by WPForms » Won’t save my settings

  • Resolved ibowden

    (@ibowden)


    I’ve used your plugin many times in the past and love it and haven’t encountered this problem before!
    In the main configuration screen, I’ve entered some info that I wish to change – and I just can’t change it! I put the changed info into the field(s) and click on the save button and get the “Settings successfully saved” notice at the top of the page. But they aren’t really saved and, when I go to leave the page, I get the browser warning me that some input data hasn’t been saved yet!
    I’ve tried:
    – uninstalling and reinstalling your plugin
    – deactivating every other plugin
    – cleaning the database after uninstalling your plugin and before reinstalling
    – using a different browser
    and I continually end up in the same place.
    Some help here would be greatly appreciated.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @ibowden,

    Thanks for the details. Do you have such issues with other pages in your WordPress dashboard, such as general settings? Are you using constants to secure your SMTP settings? If possible, could you please share the screencast video?

    Please let me know!

    Thread Starter ibowden

    (@ibowden)

    No, I am not using constants and I have not seen or experienced any similar issues with any other plugin or configuration settings in this website. This anomaly is exclusive to this website installation only.

    I have prepared a screenshot video for you: https://www.loom.com/share/a6fe499032a64bcb96870b8d6a8f5f79

    [redacted]

    Thanks for your help thus far on this crazy problem!

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    @ibowden

    Please don’t offer to send or post logon credentials on these forums: https://wordpress.org/support/guidelines#the-bad-stuff

    You may trust this developer/author, but it normalizes a dangerous practice. It’s a fine line, but one that we need to enforce. Thanks for your cooperation.

    Thread Starter ibowden

    (@ibowden)

    It’s been my experience that many plugin-makers need – as a last resort – access to the dashboard of a website in order to determine what’s not functioning properly and fix the problem. How might such information be provided by me in the future if not through an email?
    Thank you for doing this job – which, I’m sure, comes with many valuable perks!

    • This reply was modified 1 year ago by ibowden.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    @ibowden If developers want login info, they can request that elsewhere.

    We simply cannot have that happen here, on these forums, for liability reasons.

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @ibowden,

    It looks like there is an issue with the URL, you are not on the WP Mail SMTP page. It should generally be: wp-admin/admin.php?page=wp-mail-smtp and not wp-admin/admin.php. Could you please let me know if you are on multi-site or installing WP on sub-directory, and if you have any custom rules set for this? Do you have the same URL when visiting other menu items such as Essential add-ons?

    Thanks!

    Thread Starter ibowden

    (@ibowden)

    Yes, I have installed this website (which is staging) into a sub-directory, something I typically do when creating staging sites and that has never been an issue in the past. Could this be the root of the problem?
    When I am on the WP Mail SMTP settings page the URL is: https://demozone.ca/caprice/wp-admin/admin.php?page=wp-mail-smtp
    When I’m on the Essential Addons settings page the URL is: https://demozone.ca/caprice/wp-admin/admin.php?page=eael-settings
    Hope that info helps!

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @ibowden,

    There should not be any issues installing in the sub-directory. Please setup the error log and let me know the full errors (if recorded) after saving the settings in WP Mail SMTP, or you might need to follow this troubleshooting guide to identify the issue.

    I hope this helps!

    Plugin Support Sanjeev Aryal

    (@sanzeeb3)

    Hi @ibowden – We haven’t heard from you in about a week, so I’m going to go ahead and mark this ticket resolved. If you still have questions, though, please feel welcome to continue the conversation.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Won’t save my settings’ is closed to new replies.