WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Won't save Flickr API information

[Resolved] Won't save Flickr API information

  • RyuMaou
    Member

    @ryumaou

    Just installed Photonic Gallery and tried to put in the Flickr API key and secret and everything seemed to save okay, until I went to actually put a gallery on a page. At that point the plugin said I had to fill in the settings, which I did, again. And got the same result.
    Any ideas here?

    http://wordpress.org/plugins/photonic/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Sayontan Sinha
    Participant

    @sayontan

    I don’t believe your settings are saving. You might be facing a conflict with a plugin that doesn’t include JavaScript properly in the admin dashboard.

    RyuMaou
    Member

    @ryumaou

    Okay, so are there any *known* conflicts? Is there a list?

    RyuMaou
    Member

    @ryumaou

    I literally turned off every plugin except Photonic Gallery and Aksimet and I still couldn’t seem to save my settings. And ideas? Is there an error log I should be looking at?

    Plugin Author Sayontan Sinha
    Participant

    @sayontan

    If you view the Photonic back-end in Chrome, then right-click anywhere on the page and say “Inspect Element”, you will be able to go to a tab called “Console”. Monitor that tab when you click on Save.

    RyuMaou
    Member

    @ryumaou

    Okay, when I get back is:
    Uncaught Error: no such method ‘select’ for tabs widget instance

    and the offending script seems to be:
    wordpress/wp-admin/load-scripts.php?c=1&load%5B%5D=jquery-core,jquery-migrate,utils,quicktags&ver=3.6

    But that error seems to come up as soon as I get on the page. It doesn’t change when I click the “Save/Reset” button.
    Also, for your reference, I seem to be having the problem in both Chrome and Firefox and on both 3.6 and the latest build of 3.7. I started on the 3.7, which is my test blog, and then had the issue again on one of my 3.6 version sites.

    I appreciate your help!

    Plugin Author Sayontan Sinha
    Participant

    @sayontan

    I have found the issue, but I am on a new laptop and I need to install some software before I check in my code. Give me a couple of hours and this will be sorted.

    Plugin Author Sayontan Sinha
    Participant

    @sayontan

    OK – get version 1.44. That should solve the issue for you.

    RyuMaou
    Member

    @ryumaou

    Oh, wow! I didn’t expect you to fix it the same day!

    I checked it on both the 3.6 and the 3.7 and it works on both!
    You can see the test gallery here:
    http://www.fantasist.net/wordpress/index.php/gallery-test/

    Thank you so much!!

    RyuMaou
    Member

    @ryumaou

    Sorry, I forgot to mark this as closed before, but the issue is completely resolved for me.
    And, in fact, I appreciated the *fast* help to fix the problem so much I did make a small donation to say “thank you”. (And, I admit, I should donate to more plugin authors for the same reason and encourage others to do so!)

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Won't save Flickr API information’ is closed to new replies.