WordPress.org

Support

Support » Plugins and Hacks » Google Analyticator » [Resolved] Won't save any checkboxes – users to see dashboard widget

[Resolved] Won't save any checkboxes – users to see dashboard widget

  • WP 3.5.1, version 6.4.2, and I got the following error when I tried to add other user roles to see the dashboard widget:

    Warning: stripslashes() expects parameter 1 to be string, array given in …./wp-includes/kses.php on line 1257

    It won’t save, and it also unchecks all checkboxes, including the ones under not to track. None of my choices are saved.

    I went back to 6.4.1 and it is now displaying the dashboard widget again and saving checkbox choices.

    Please fix!
    Thanks!

    http://wordpress.org/extend/plugins/google-analyticator/

Viewing 15 replies - 1 through 15 (of 20 total)
  • UNDER ADMIN DASHBOARD WIDGETS
    I’m having the same issue, no error message it just won’t save the Dashboard User roles that can see the Dashboard. So I don’t see the dashboard.
    Thanks,

    Same here. Non of the checkboxes keep selected when saving the settings. This does not only affect the dashboard widget selection but also the user groups to track.

    Restting the settings and authorizing again did not fix the problem. Only the dashboard widget appears for the first time after authorizing the plugin with Google Analytics. However, in this state the tracking is disabled. Once I change this and press “Save”, all checkbox selections disappear.

    I’m getting the same problem. Unchecks all checkboxes

    I had to remove any calls to wp_filter_kses between lines 310-325 in google-analyticator.php

    This got everything working again as expected. I’m not sure why wp_filter_kses is there in anyway, since the $_POST array already contains the required parameter arrays.

    Yep, and I’m getting a PHP warning on my site when trying to suppress tracking for logged in users (even though the checkboxes aren’t saving on the admin panel).

    Same here, had to revert to older version.

    Exactly the same problem. Cant activate dashboard wedged???

    Temporaly HACK for fix to work.

    Open your DB, search for option name: ga_dashboard_role

    ADD this: a:2:{i:0;s:13:”administrator”;i:1;s:6:”editor”;}

    And you will get widged for Admin and eitor.

    Its a temporaly until plugin fix!!!

    Where can I find an older version of the plugin? I need to have the Dashboard widget showing

    Same Problem with WP 3.4.1

    @j2000 – Click on the “Developer” tab to download the previous version.

    It would be great if the author of the plugin could fix this ASAP!

    @j2000, Where exactly we should add the code in the Dashboard?

    The same here. Just downgraded to 6.4.1 and the problem solved. Wont upgrade until this is fixed.

    @courtney Fantinato – Thanks!

    @pawelsuder – You don’t enter code in the Dashboard. The plugin has an option to show a widget in the admin Dashboard (which doesn’t seem to be working in the current version),

    Thanks Toto that worked for me as a temp fix.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] Won't save any checkboxes – users to see dashboard widget’ is closed to new replies.
Skip to toolbar