Support » Plugin: Yet Another Related Posts Plugin (YARPP) » Won’t let me deactivate or delete plugin

  • Resolved kndphillips10

    (@kndphillips10)


    After installing this plugin and not being able to produce thumbnails that aren’t distorted, I decided to delete this plugin and use a better alternative. Upon trying to deactivate, it starts to show a feedback popup but then goes away as soon as it appears and does not deactivate. When i deleted it from my c-panel it left pieces with several error codes. How do I get rid of this plugin so I can start fresh?

Viewing 15 replies - 1 through 15 (of 17 total)
  • Plugin Support Michael Nelson

    (@mnelson4)

    Hi @kndphillips10, sorry to hear you’re having such trouble! But thanks for reaching out. Let’s see if we can help…

    Because I don’t have access to your website’s admin area, the following info would really help to figure out what’s going wrong:

    1. What version of PHP and WordPress are you using?
    2. What web browser are you using?

    (Here’s a quick video showing how to get that info on versions of WordPress with the Site Health tool: https://drive.google.com/file/d/1NnHVf0iWgMF_IqPzvKh0LcC6ZyskGSbC/view.)

    Upon trying to deactivate, it starts to show a feedback popup but then goes away as soon as it appears and does not deactivate.

    Ya, that’s strange, you should see the pop-up, optionally enter the info, and then when you click “Skip & Deactivate” or “Submit & Deactivate”. Like this: https://drive.google.com/file/d/1XKp0YtfxaKbZ3G8LGCjFoVbfrON7HxBF/view

    When i deleted it from my c-panel it left pieces with several error codes.

    Do you mean you deleted the plugin’s folder? That’s a pretty-sure-fire way to deactivate a plugin. This is what I see when I do that: https://drive.google.com/file/d/1Jh32BW_uI5g7maxKCTN_dQc_f2l-IMWM/view . What error codes are you seeing?

    After installing this plugin and not being able to produce thumbnails that aren’t distorted

    Do you mean the thumbnails were stretched?

    Anyways, I hope we can figure these issues out.

    • This reply was modified 1 month, 3 weeks ago by Michael Nelson. Reason: formatting

    Hi Michael, that is a very thorough reply! Thank you for your attention. 🙂
    Anyway, WordPress is at 5.4.2 and PHP is 7.0.25. My host is Hostgator and while I was having some other issues last week I talked to them about why the PHP is not more updated but I can’t remember what she said.

    I am using Chrome.

    I have never had a problem deactivating plugins before, so I was expecting exactly what you said should have happened.

    Yes, I deleted the plugin’s folder. Unfortunately, it didn’t get all of the pieces of the plugin in various places in my site, which prompted the error messages. There were about 8 of them if I were to estimate. I can give you one example of one because I copied and pasted it into Google to see if it was viable for me to systematically go through them and remove them. Here is what that one looked like:

    kndphillips/public_html/wp-content/plugins/yet-another-related-posts-plugin/yarpp.php): failed to open stream: No such file or directory in /home2/kndphillips/public_html/wp-includes/functions.php on line 5974

    It was basically random lines of code that didn’t have the rest of the plugin to work.

    And yep, the plugins were stretched. You can probably see that on the bottom of my blog posts at http://www.completeliterature.com.

    I ended up just re-installing the app so I could get rid of the error messages.
    Thank you!

    Marie Phillips

    Plugin Support Michael Nelson

    (@mnelson4)

    Btw @yarpp gets credit for employing me to help you!

    Ya your PHP version and WP look fine, nor are you using a weird browser. Huh.

    The errors you got on deleting the plugin should have come up once (which is expected: from WordPress’ perspective, deleting active plugin files is warning-worthy.) But you shouldn’t get more warnings afterwards. I’ll check to see if I can discern anything meaningful from that file and line number.

    Regarding the deactivation pop-up, maybe there’s another plugin interfering? If you want to share which other plugins are active that would be helpful (it’s easiest to copy-and-paste from tools -> site health) but no worries if not.

    Lastly, I’m sorry it was easier to just leave the plugin active. I mean, of course we want you to use our plugin, but not because of errors deactivating it! But FYI fixing the stretchy images should be quite doable by running the Regenerate Thumbnails plugin: https://wordpress.org/plugins/regenerate-thumbnails/

    See the FAQ: https://wordpress.org/plugins/yet-another-related-posts-plugin/#i’m%20using%20the%20thumbnails%20display.%20why%20aren’t%20the%20right%20size%20thumbnails%20being%20served%3F

    By the way, this seems to be a pretty common issue that’s just coming to our attention and we’re looking into improving.

    Good to hear that yarrp hires great people (at least the one I have worked with, haha).
    Anyway, before I answer your questions, I would like to say that I would be happy to stay with yarrp if we could accomplish two things. First, I would need the pictures to be clear and second, I would need the titles of my posts underneath the pictures to be complete and not truncated.
    When I was using related posts with Jetpack, that was all done automatically and there was never even a thought on my part about it.

    Okay, back to the questions. I only deleted the plugin once and got the errors. I immediately put it all back and didn’t try a second time because I didn’t want random pieces of code hanging out there to interfere with other stuff. I am not tech savvy on the back end of things so it would be a bear trying to figure that stuff out.

    Don’t be horrified at all of my plugins!!!! I know I need to thin them out. The biggest thing on my list in the next month is getting down to just one email service. I have 3 because of compatibility issues over time. I just need to find some time to get all of my lists together and switch it all out.

    Active Plugins

    Ads.txt Manager Version 1.3.0 by 10up
    Akismet Anti-Spam Version 4.1.6 by Automattic
    Alexa Certify Version 4.1.2 by Alexa Internet
    Amazon Affiliate Link Globalizer Version 1.3 by Attila Gyoerkoes, Markus Goetz (Woboq)
    Autoptimize Version 2.7.3 by Frank Goossens (futtta)
    bbPress Version 2.6.5 by The bbPress Contributors
    bbPress WP Tweaks Version 1.4.4 by veppa
    Connects – SendinBlue Addon Version 2.1.3 by Brainstorm Force
    Content Views Version 2.3.2 by Content Views
    Convert Plus Version 3.5.7 by Brainstorm Force
    Cornerstone Version 4.2.3 by Themeco
    Display PHP Version Version 1.5 by David Gwyer
    Easy Table of Contents Version 2.0.11 by Steven A. Zahm
    Fix Image Rotation Version 2.2.1 by Gagan Deep Singh
    Google Analytics Version 3.0.2 by Themeco
    Google Analytics for WordPress by MonsterInsights Version 7.10.4 by MonsterInsights
    Image Widget Version 4.4.7 by Modern Tribe, Inc.
    Imagify Version 1.9.10 by WP Media
    Insert Headers and Footers Version 1.4.5 by WPBeginner
    MailPoet 3 (New) Version 3.47.4 by MailPoet
    MailPoet 3 Premium (New) Version 3.0.86 by MailPoet
    MemberPress Basic Version 1.8.11 by Caseproof, LLC
    MemberPress MailPoet Version 1.2.1 by Caseproof, LLC
    Newsletter, SMTP, Email marketing and Subscribe forms by Sendinblue Version 2.9.17 by Sendinblue
    OptinMonster API Version 1.9.8 by OptinMonster Team
    Page Builder by SiteOrigin Version 2.11.0 by SiteOrigin
    PHP Compatibility Checker Version 1.5.0 by WP Engine
    SiteOrigin CSS Version 1.2.8 by SiteOrigin
    SiteOrigin Widgets Bundle Version 1.17.0 by SiteOrigin
    Sucuri Security – Auditing, Malware Scanner and Hardening Version 1.8.24 by Sucuri Inc.
    UpdraftPlus – Backup/Restore Version 1.16.25 by UpdraftPlus.Com, DavidAnderson
    WPForms Lite Version 1.6.0.2 by WPForms
    WP Old Post Date Remover Version 3.0.7 by Ben Meredith
    WP Super Cache Version 1.7.1 by Automattic
    Yet Another Related Posts Plugin (YARPP) Version 5.1.6 by YARPP
    Yoast SEO Version 14.3 by Team Yoast

    Inactive Plugins:

    Jetpack by WordPress.com Version 8.6.1 by Automattic
    MOJO Marketplace Version 1.5.4 by Mike Hanse

    I did get the Regenerate Thumbnails plugin and it helped. But the photos are still not great because they are being forced to fit into a square and the vast majority of blog post photos are rectangular. It’s definitely better than it was, though!

    Plugin Support Michael Nelson

    (@mnelson4)

    First, I would need the pictures to be clear and second, I would need the titles of my posts underneath the pictures to be complete and not truncated.

    I personally agree, those are some of YARPP’s two biggest issues. You can get them to work out, but they’re both tricky. They should just work out of the box.

    Thanks for the list of plugins. I bet one (or some combination of them 😵) is causing YARPP’s deactivation survey to malfunction. Although it may also be a browser-extension, too.

    Hey @kndphillips10 are you able to make a screen recording? Either from your computer (eg using Screencastify browser extension, which also simplifies sharing the recording from Google Drive) or just your phone. If so, it might be helpful to see what happens when you try to deactivate YARPP.

    I did get the Regenerate Thumbnails plugin and it helped. But the photos are still not great because they are being forced to fit into a square and the vast majority of blog post photos are rectangular. It’s definitely better than it was, though!

    Ok thanks for the feedback there, ya usually thumbnail images are rectangular so rectangular thumbnails would be better.

    Plugin Support Michael Nelson

    (@mnelson4)

    Hmm I tried installing as many of those plugins locally as I could, but didn’t get the same problem. The deactivation survey pop-up worked as intended for me. (This is one of those strange situations where I’m disappointed that things are working… it would be far easier to debug if they malfunctioned for me too 😝)

    But we have a hunch about what was going wrong: when you clicked to uninstall YARPP, either a plugin or a browser-extension was automatically causing a click event to happen elsewhere (or, it’s possible that you were clicking again?) If there was a click anywhere outside the pop-up, it closed the pop-up, and the plugin wasn’t deactivated.

    So, the fix was to only close the pop-up when you explicitly click the “Cancel” button inside the pop-up. So hopefully version 5.1.8 of YARPP fixes that deactivation problem for you. If you’re still having trouble please let us know.

    Regarding the layout issue: you’re not alone, I just noticed someone else on another support thread mentioning that as a big concern, so it’s definitely moving up in our priorities.

    Haha, I get the disappointed when things are working point.
    I saw the update this morning and immediately did it and then tried to deactivate to see if it would work, but no luck.
    I’m definitely only clicking once, so I don’t think that’s the issue. I tried it with both my mouse and my track pad but no luck either. I appreciate your suggestions, though!
    I did record with Screencastify but I don’t know how to share that with you here.
    And it’s good to hear that they are working on making it better. 🙂

    Plugin Support Michael Nelson

    (@mnelson4)

    Argh, sorry the update didn’t fix anything. But thanks for letting us know.

    With regards to sharing the Screencastify video: when I use it, after I record the video, there’s a button in the top-right corner of the screen saying “Copy shareable link” (here’s a screenshot: https://drive.google.com/file/d/1jDsbmzOZrAFbhss26viTwUVFG9Z3_XZE/view). There’s also an option underneath that to change the video’s visibility. So you’d just change it to either “public” or “unlisted”, then click “Copy shareable link” and paste it in here.

    Regarding trying the bulk deletion (that’s what I think folks call using the checkboxes like you tried), ya that was a workaround I meant to suggest. I’m pretty stumped about why it would be redirecting you like that. Not only is there that obvious problem with it repeating yet-another-related-posts-plugin in the URL over-and-over again, but even it sent you to the page it sounds like it intended to (https://completeliterature.com/wp-content/plugins/yet-another-related-posts-plugin/yarpp.php) that’s not a page you should be visiting anyway! It’s a file that contains PHP code that doesn’t show anything. I’m sorry but that’s really got me puzzled.

    I take it you don’t get a similar error when you temporarily deactivate a different plugin, do you?

    It is all pretty weird to me too.
    Here is the screenshot. I never noticed the sharing link in the corner.

    https://drive.google.com/file/d/1GeFSSTQ5C5Bqr_H8PxYEP4-g_c3Qto2R/view

    And you are right, I don’t get any of these erros when deactivating other plugins. They are all fine.

    Plugin Support Michael Nelson

    (@mnelson4)

    Ok thanks. The only clue is that the URL on the plugins page is weird… it’s https://completeliterature.com/wp-admin/yet-another-related-posts-plugin/yarpp.php. It should just be https://completeliterature.com/wp-admin/plugins.php. If we can figure out why it’s different, that would be a huge step forward…

    If you know what other plugin or browser extension is changing that it would be great, but no worries if not.

    When you visit the plugins page, is the URL always https://completeliterature.com/wp-admin/yet-another-related-posts-plugin/yarpp.php? Or is it initially something else, and it changes once you click to deactivate YARPP?
    (A video recording showing you clicking on the plugins page and then clicking to deactivate YARPP would also show it.)

    The plugins page starts with the normal URL (https://completeliterature.com/wp-admin/plugins.php) and then ends up with this one when I try to deactivate: https://completeliterature.com/wp-admin/yet-another-related-posts-plugin/yarpp.

    That is just what you were expecting.
    Once I refresh that new URL, of course it gives me the 404 because it’s not really a page.

    Plugin Author yarpp

    (@jeffparker)

    @kndphillips10 this has both Mike and I a bit stumped. We think it might be something very specific to your install or environment. If possible, if you’re willing, it would greatly speed up a resolution if we could take a direct look at your admin console to see what may be going on. If that’s cool with you, please send an invite to jay at yarpp dot com Thank you in advance, either way, you decide 🙂

    Plugin Support Michael Nelson

    (@mnelson4)

    Actually @kndphillips10 I have a couple hunches, in case you’d rather not grant us access (which is totally reasonable.)

    Hunch 1: Bulk activation might still work if you:
    1. Visit the plugins page but DO NOT click the link to deactivate YARPP (which changes your browser’s URL)
    2. Click the checkbox beside YARPP
    3. At the bottom of the page, in the “Bulk Actions” dropdown, choose “Deactivate” and click “Apply”
    Here’s a quick video showing that: https://drive.google.com/file/d/1svgJPa8dB6TCjjJhegtdNMO72nwbaBhh/view?usp=drivesdk
    Hunch 2: The pop-up window code we’re using normally changes the URL **after** the # (pound sign), but somehow on your site its malfunctioning. But, we can disable that URL rewriting and the pop-up should still appear. Here’s a test version of YARPP that does that, that I hope will fix the issue for you: https://drive.google.com/file/d/1GVxUpcpM8NGF4dTWmFs8Unyewl-sUC6h/view

    To try it, deactivate the current version of YARPP (use steps from “Hunch 1” above), then go to Plugins -> Add New -> Upload, select the zip file and upload it, then activate it. Then you can try deactivating the plugin as normal and it should work.

    This time the bulk deactivation worked!!!! That was all so crazy. I still have no idea what happened but it finally worked for whatever reason. Thank you so much for you all’s patience and work with me on this.
    And honestly, if I find out that the formatting of the thumbnails and titles are fixed, I wouldn’t mind giving it another try.
    Again, thank you!

    Marie Phillips

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.