Support » Plugin: NextGEN Gallery Optimizer » Wont deactivate!

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi @chrisb070819,

    Thanks for using NextGEN Gallery Optimizer, and apologies for any inconvenience.

    The fatal error you’re experiencing is caused by the major NextGEN Gallery v2.0.7x update, just released a few days ago on the 19th of February 2015.

    As key parts of the NextGEN v2.0 API were completely removed in this update (without any graceful deprecation, or backwards-compatibility in place), Optimizer (and likely many other NextGEN extensions) will display fatal errors, and not function correctly with this release, until all affected integration components are rewritten.

    The reason the plugin won’t deactivate properly is due to the presence of a fatal error, which is caused by the complete removal of the C_Lightbox_Installer class (and its uninstall_lightbox() method) in NextGEN Gallery v2.0.7x.

    I’m currently working on compatibility with NextGEN v2.0.7x (and hope to have an update ready soon), but in the meantime, I would recommend rolling-back to the immediately-preceding stable release of NextGEN v2.0.66.33.

    Optimizer’s broad, existing compatibility with NextGEN (v2.0.0 to v2.0.66.33), NextGEN Legacy (v1.6.2 to v1.9.13) and NextCellent Gallery remains unaffected.

    I’ve just posted a detailed notification about this temporary incompatibility to the very top of Optimizer’s main plugin page here at the WordPress plugin repository. Hopefully other users will now be aware of this issue before downloading, until compatibility can be achieved, and an update released.

    All the best,
    Mark.

    Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi @chrisb070819,

    As promised, the big compatibility release of Optimizer v2.1 is now available, and includes (amongst many other things) full support for the recent major update of NextGEN Gallery v2.0.71 (up to the current v2.0.77).

    This version fixes the won’t deactivate/fatal error issues caused by NextGEN v2.0.71+ that you’ve experienced, and I encourage you to update at your earliest convenience.

    As always, you can update to Optimizer v2.1 via the plugins page in your WordPress admin, or by downloading it from Optimizer’s main plugin page here at WordPress.org.

    For the full list of improvements and additions, please see…
    http://www.nextgengalleryoptimizer.com/blog/nextgen-gallery-optimizer-v2-1-now-available/

    All the best,
    Mark.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Wont deactivate!’ is closed to new replies.