Support » Plugin: Advanced Browser Check » Wont active, error

Viewing 9 replies - 1 through 9 (of 9 total)
  • Brought my whole site down….

    Same here.

    It looks like ABC no longer supports PHP 5.3 and below. Line 23 in abc-core.php is now using [] instead of array() to declare an array.

    26 occurrences in abc-core.php
    1 occurrence in abc-output.php

    I recommend downgrading to ABC 4.3 until the issue is resolved.

    Plugin Author Mattias

    (@darkwhispering)

    Hi @armando_e @davidoshiro

    I’m sorry for the issues you have run into. Unfortunately this slipped through my testing (did not test activating the plugin properly I realize).

    I’ll have this issue resolve during my day today and post an update here when it is available.

    Again, sry for the issues.

    Plugin Author Mattias

    (@darkwhispering)

    Hi again @armando_e @davidoshiro

    I have just updated the plugin to v4.4.1 fixing the issues reported.

    I’m again very sry for the issues caused by my plugin. The change of PHP version requirements was unintentional (force of habit using [] in newer PHP versions and not having PHP 5.3 installed locally to test on). If you still get errors, please let me know and I will fix them asap.

    Minimum PHP version supported for the plugin is PHP 5.3 though, just FYI.

    Note: I really do encourage you to update to a newer version of PHP if your hosting provider allows. PHP 5.3 is no longer supported and therefore don’t get any security updates.

    I appreciate you fixing the issue quickly. Thanks for the plugin!

    Thank you Mattias! Great work!

    Hi. I’m having the same issue with my site. It is currently down. Could you please help me to solve it? I cannot login to admin as well…

    Plugin Author Mattias

    (@darkwhispering)

    @limcoh If you have the exact same error as described in the original post you aren’t running the latest version of the plugin. The latest version, 4.4.1 should resolve the issue for you.

    If you can’t access your admin dashboard and you are sure it is due to the Advanced Browser Check plugin, just access your site over FTP/SFTP and delete the plugin manually. You should then be able to access admin and then download the latest version of the plugin.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Wont active, error’ is closed to new replies.