Support » Plugin: Wordfence Security - Firewall & Malware Scan » won’t activate due to fatal error after WP 5.4.2 update

  • Resolved metaceptive

    (@metaceptive)


    This website simply produced a white screen and Jetpack monitor registered that the website had gone down around 20 mins after WP was updated to 5.4.2 . I disabled all plugins and after re-enabling one by one worked out it was Wordfence. When trying to reactivate it I get the message “plugin could not be activated because it triggered a fatal error”. I deleted and reinstalled the plugin but same again. This is a Genesis framework theme. All my other sites (none are Genesis framework) which also all use Wordfence are OK.
    Any ideas? I may have to use another security plugin if not…

    • This topic was modified 5 months, 2 weeks ago by metaceptive.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 20 total)
  • I have exact the same problem. Theme is one of the default themes, no special framework.
    I tested with only a few plugins active (Hello Dolly, Akismet, both from Automattic). Activating Wordfence triggered the white screen of death.
    Also deleted and freshly installed from within the plugin page (so not an earlier downloaded version). This gave exact the same results.
    I have another site which also uses wordfence and without any problems.
    Both my sites have SSL, so that doesn’t seem to be the problem either.

    My page: Ilse Mul

    ETA: I found the solution that worked for me here

    In my case I can access PHP version in my cPanel en from there I can adjust the memory_limit. I set it to 512 and that did the trick. I hope it helps for you as well!

    • This reply was modified 5 months, 2 weeks ago by Sheriziya. Reason: Found the solution (at least for my site)

    I had a similar error yesterday, before the wordpress update. I updated 2 other plugins, and shortly after that, my website showed the white screen, and I could not login. I disabled all of my plugins, and when I went through them one-by-one to reactivate them, wordfence is the only one that caused an error. It still isn’t working today, after the automatic wordpress update.

    Did this not help?:

    ETA: I found the solution that worked for me here

    In my case I can access PHP version in my cPanel en from there I can adjust the memory_limit. I set it to 512 and that did the trick. I hope it helps for you as well!

    Thanks @sheriziya

    This was causing me stress on one of my websites. Your solution resolved my issue.

    Thanks a lot

    You’re welcome @wally10 Glad I could help out šŸ™‚

    Thank you so much @sheriziya I tried increasing the memory to 512 and it works.

    I have the same issue. Changing memory_limit had no effect, I am not getting a memory error so this was not surprising. I reactivated all plugins one at a time. The one that fails is Wordfence.

    I’ve got 2gb allocated on my account and upped it to full 2048 but still won’t activate

    I was having same issue and solved it with:

    1. uninstall wordfence
    2. install wordfence assistant
    3. click the uninstall all tables and data button
    4. click the uninstall firewall button
    5. reinstall wordfence
    6. go through normal setup procedure

    Thank you @rtpharry. I followed your instructions and everything seems to work fine now.

    OK I had another problem, after it worked from increasing the PHP memory as suggested by @sheriziya , I then increased the PHP version to 7.2 (from 7.0), This then gave me the white screen again, but then after reverting back to PHP version 7.0 it’s fine again. Strange as Wordfence is supposed to be best with 7.3 according to their documentation. (If I use 7.3 I get the message “There has been a critical error on your website.”)

    I may well try the solution from @rtpharry using Wordfence assistant (thanks for that).

    Thanks @rtpharry, your method works for me too! much appreciated.

    @metaceptive likely your php version changing issue is something else.

    I recommend trying my method to get your site working with wordfence.

    Once that is done, change the php version again and you will probably still see it error out.

    My guess for this would be that your hosting company, like one I use, has an extra control panel page for selecting which PHP modules are enabled and when you change to a new PHP version you are changing to a version without the same set of modules selected. In cPanel this would normally be under “select my php version” then at the top look for a “modules” tab (wording roughly remembered off the top of my head).

    Thanks @rtpharry, this site currently has Wordfence working fine with PHP 7.0 but not with 7.2 however I’ll give your method a go…

    FYI @rtpharry, I deactivated Wordfence, changed PHP version to 7.2, the site was fine, then tried to reactivate Wordfence and received the message “Plugin could not be activated because it triggered a fatal error.”
    So I then deleted Wordfence, used Wordfence assistance and uninstalled all tables and data, then reinstalled Wordfence and it has activated fine now.
    What all that means I can only guess (some conflict between those data/tables and pHP 7.2?) but thank you for the solution.

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.