Support » Plugin: Nomiddleman Bitcoin and Crypto Payments for WooCommerce » Won’t Activate. Causes Fatal Error.

  • camosoul

    (@camosoul)


    PHP Warning: Version warning: Imagick was compiled against ImageMagick version 1802 but version 1803 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
    PHP Fatal error: Array and string offset access syntax with curly braces is no longer supported in /usr/share/nginx/html/store/wp-content/plugins/nomiddleman-crypto-payments-for-woocommerce/src/NMM_Util.php on line 54
    Fatal error: Array and string offset access syntax with curly braces is no longer supported in /usr/share/nginx/html/store/wp-content/plugins/nomiddleman-crypto-payments-for-woocommerce/src/NMM_Util.php on line 54
    PHP Fatal error: Uncaught TypeError: fclose(): Argument #1 ($stream) must be of type resource, bool given in /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php:149
    Stack trace:
    #0 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php(149): fclose()
    #1 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php(209): WC_Log_Handler_File->open()
    #2 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php(101): WC_Log_Handler_File->add()
    #3 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/class-wc-logger.php(146): WC_Log_Handler_File->handle()
    #4 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/class-wc-logger.php(192): WC_Logger->log()
    #5 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/class-woocommerce.php(225): WC_Logger->critical()
    #6 [internal function]: WooCommerce->log_errors()
    #7 {main}
    thrown in /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php on line 149
    Fatal error: Uncaught TypeError: fclose(): Argument #1 ($stream) must be of type resource, bool given in /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php:149
    Stack trace:
    #0 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php(149): fclose()
    #1 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php(209): WC_Log_Handler_File->open()
    #2 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php(101): WC_Log_Handler_File->add()
    #3 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/class-wc-logger.php(146): WC_Log_Handler_File->handle()
    #4 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/class-wc-logger.php(192): WC_Logger->log()
    #5 /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/class-woocommerce.php(225): WC_Logger->critical()
    #6 [internal function]: WooCommerce->log_errors()
    #7 {main}
    thrown in /usr/share/nginx/html/store/wp-content/plugins/woocommerce/includes/log-handlers/class-wc-log-handler-file.php on line 149

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.